Imposible to run Agent on Debian Sarge kernel 2.4.x

Discussion in 'Acronis True Image Product Line' started by tuflipes, Aug 15, 2006.

Thread Status:
Not open for further replies.
  1. tuflipes

    tuflipes Registered Member

    Joined:
    Aug 15, 2006
    Posts:
    1
    HI there,

    I want to install TI 9.1 agent on a debian sarge with kernel 2.4.27-2 . I have read /usr/lib/Acronis/Agent/HOWTO.INSTALL but no success :(

    If i install using your script AcronisTrueImageAgentLinuxEnterprise.i686 , i shows sucessfully installed, but it doesnt work fine:

    mailsrv0098:~/acronis# /etc/init.d/acronis_trueimage_agent start
    Starting Acronis Remote Agent:
    mailsrv0098:~/acronis# /etc/init.d/acronis_trueimage_agent status
    Acronis Remote Agent is stopped
    mailsrv0098:~/acronis#

    where to check log for error? because /var/log/trueimage-setup.log is only for install errors,anyway i post it:

    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.pu8v9i/dkms-2.0.4-2.noarch.rpm':
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.pu8v9i/snapapi_modules-0.7.3-1.noarch.rpm':
    finished
    Running 'rpm -e trueimage':
    error: package trueimage is not installed
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.pu8v9i/TrueImageAgent-9.1.3666-1.i386.rpm':
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.5glOF7/dkms-2.0.4-2.noarch.rpm':
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.5glOF7/snapapi_modules-0.7.3-1.noarch.rpm':
    finished
    Running 'rpm -e trueimage':
    error: package trueimage is not installed
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.5glOF7/TrueImageAgent-9.1.3666-1.i386.rpm':
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.5glOF7/TrueImageSecZone-9.1.3666-1.i386.rpm':
    finished
    Launching '/usr/sbin/dkms install -m snapapi -v 0.7.3 2>&1'.

    Error! DKMS tree does not contain: snapapi-0.7.3
    Build cannot continue without the proper tree.

    Launching '/usr/sbin/dkms ldtarball --force --archive /usr/lib/Acronis/kernel_modules/snapapi-0.7.3-all.tar.gz 2>&1'.

    Loading tarball for module: snapapi / version: 0.7.3

    Loading /usr/src/snapapi-0.7.3...
    Creating /var/lib/dkms/snapapi/0.7.3/source symlink...

    DKMS: ldtarball Completed.

    Launching '/usr/sbin/dkms install -m snapapi -v 0.7.3 2>&1'.

    Error! Could not locate snapapi.o for module snapapi in the DKMS tree.
    You must run a dkms build for kernel 2.4.27-2-386 (i686) first.


    Preparing kernel 2.4.27-2-386 for module build:
    (This is not compiling a kernel, only just preparing kernel symbols)
    Storing current .config to be restored when complete
    using presented .config
    make oldconfig....(bad exit status: 2)
    make dep....(bad exit status: 2)

    Building module:
    cleaning build area....(bad exit status: 2)
    make KERNELRELEASE=2.4.27-2-386 -C /lib/modules/2.4.27-2-386/build SUBDIRS=/var/lib/dkms/snapapi/0.7.3/build modules.....
    cleaning build area....(bad exit status: 2)

    DKMS: build Completed.
    exited with status 0.
    Launching '/usr/sbin/dkms install -m snapapi -v 0.7.3 2>&1'.
    Running module version sanity check.

    snapapi.o:

    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/2.4.27-2-386/kernel/drivers/block//

    snumbd.o:
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/2.4.27-2-386/kernel/drivers/block//

    depmod......

    DKMS: install Completed.

    If i check for snappy:

    mailsrv0098:/var/log# ls /usr/src/snapapi-0.7.3/
    dkms.conf Makefile snapapi.c snapapi.h sn_huge_ptr.h snumbd.c snumbd.h
    mailsrv0098:/var/log#

    aboud df :

    mailsrv0098:/var/log# df -a
    S.ficheros Bloques de 1K Usado Dispon Uso% Montado en
    /dev/hda1 152317284 1413096 143166884 1% /
    proc 0 0 0 - /proc
    devpts 0 0 0 - /dev/pts
    tmpfs 257640 0 257640 0% /dev/shm
    /devfs 0 0 0 - /devfs
    usbfs 0 0 0 - /proc/bus/usb
    mailsrv0098:/var/log#

    So.. whats wrong with agent and debian? we made test with centos 4.x and no problems, it starts fine, but it seems imposible with debian and major of our srevers are debian sarge.

    thks in advance
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello tuflipes,

    Thank you for choosing Acronis Remote Server Backup Software.

    Please accept our apologies for the delay with the response.

    I would recommend that you download the latest build (3718 ) of Acronis True Image 9.1 Enterprise Server for Windows. To get access to updates you should first register your software. After that please install Acronis True Image Agent using the latest build.

    If the issue persists, download the Linux System Report utility available here and do the following to create the report:

    - Unpack the archive: # tar xvf sysinfo.tar

    - Make the script executable: # chmod +x sysinfo

    - Run the executable: # ./sysinfo

    Then submit a request for technical support. Attach all the collected file and information to your request along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with the solution.

    Thank you.
    --
    Aleksandr Isakov
     
Thread Status:
Not open for further replies.