IIS7 Being Blocked

Discussion in 'ESET Smart Security' started by Aokiji, Feb 8, 2011.

Thread Status:
Not open for further replies.
  1. Aokiji

    Aokiji Registered Member

    Joined:
    Feb 8, 2011
    Posts:
    2
    Hi guys my firewall is on interactive mode, now my problem is that eset smart security firewall blocks my IIS7 server, if i disable the fire it works fine but once enabled its blocked again, though eset havnt asked to add IIS7 to its firewall config
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    Have you tried switching the firewall to learning mode for a while until all necessary rules are created? When done and everything works as you expect, review the rules and switch to the policy-based mode.
     
  3. Aokiji

    Aokiji Registered Member

    Joined:
    Feb 8, 2011
    Posts:
    2
    it works on automatic filtering but, what does it block if its on interactive filtering?
     
  4. ThomasC

    ThomasC Former ESET Support Rep

    Joined:
    Sep 8, 2008
    Posts:
    209
    Hello,

    It only blocks what you specify. Otherwise it is the same as automtic mode. However, my first recommendation would be to install ESET NOD32 on your web server and use a hardware firewall.

    If you still plan to use ESET Smart Securty on your web server and you are not being prompted to create the rule you desire then you could always reset the firewall . Keep in mind this is going to delete all the non-standard / default firewall rules. After resetting the firewall you can set it to interactive mode and then create an application based firewall rule for ISS7 or wait to be prompted.

    Since this machine is acting as a web server I would recommend configuring it according to ESET Recommended server settings and as I stated at the before, personally I would avoid the software firewall entirely and install ESET NOD32 on the server instead of ESET Smart Security.
     
    Last edited: Feb 8, 2011
Thread Status:
Not open for further replies.