IE9, you want History or Protective Mode?

Discussion in 'other software & services' started by Indyrod, Nov 11, 2012.

Thread Status:
Not open for further replies.
  1. Indyrod

    Indyrod Registered Member

    Joined:
    Oct 28, 2012
    Posts:
    7
    Location:
    USA
    after researching the hell out of this bug after I upgraded to IE9, my browsing History was randomly not being updated like it always has. no rhyme or reason I could see, the History just started to not show much of anything. Yes, I checked everything there is to check, and the only, and I mean only, thing that fixed it, was to disable "Protective Mode" in IE security settings. After that was done, the History started recording perfectly. With Webroot and Windows security, I'm not sure the Protective Mode was doing much for me anyway, so that's why I'm posting, to get your input on disabling the Protective Mode option.

    just to add, my History is set for 21 days, and I only upgraded to IE9 about a week ago, after going back to IE8 for a while. Nothing like that ever happened in IE8, the History was always updated with no problem. I don't have anything clicked, like deleting history on exit, or anything at all. My Add-ons are just fine, and no, I never go into Private Browsing. I found that fix after reading posts on the Net for hours trying to figure it out, and many many people are having the same problem with IE9 not updating History.
     
  2. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,853
    Worked perfectly fine for me when I was using it, have you tried launching IE without addons from the accessories menu?
     
  3. Indyrod

    Indyrod Registered Member

    Joined:
    Oct 28, 2012
    Posts:
    7
    Location:
    USA
    no, I didn't do that, because I read so many stories about possible ways to fix it, and the user usually came back with, that worked for a while, but stopped updating History anyway. I looked at my add-ons, and nothing there besides the usual suspects. The only fix that always worked, and continued to work indefinitely, was turning Protective Mode off, or going back to IE8. If I'm going to any suspect websites, it asks me if I want to turn it on anyway, so I would rather have correct History and use PM as little as possible. I'm just not sure how that affects my security, and if Webroot gives the proper protection, without using PM. thanks for the suggestion, there's no shortage of those around the Net.
     
  4. Indyrod

    Indyrod Registered Member

    Joined:
    Oct 28, 2012
    Posts:
    7
    Location:
    USA
    just switched to Google Chrome, tired of screwing around with IE, and Chrome has an IE Tab available anyway. not much reason now to try and figure why IE9 is just a pain in the butt.
     
Loading...
Thread Status:
Not open for further replies.