IE7 - links not working correctly

Discussion in 'other software & services' started by appster, Aug 25, 2007.

Thread Status:
Not open for further replies.
  1. appster

    appster Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    530
    Location:
    Paradise (Hawaii)
    I recently installed IE7 and I'm finding that clicking on URL links doesn't work! I can get it to work by right-clicking on the link and then clicking Open, but not by simply clicking on the link (as I did with IE6)... Is this due to a setting that I'm unaware of? :doubt:

    Thanks for any help - oh yeah, I'm running WinXP, not Vista.
     
  2. Franklin

    Franklin Registered Member

    Joined:
    May 12, 2005
    Posts:
    2,517
    Location:
    West Aussie
    Go into "Progrms Access and Defaults" and reset IE as your default browser.

    Or Try this from my old help tips archive.

    Start Internet Explorer
    Select the Tools > Internet Options menu
    Select the [Programs] tab
    Look for a checkbox labelled "Internet Explorer should check to see whether it is the default browser"
    If this checkbox is not ticked, then this may be the cause of the problem, so tick it!
    Click OK
    Close Internet Explorer
    Re-open Internet Explorer
     
  3. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Hi appster :)

    If the solution of Franklin won't work try this :

    Start | run | ... (and for each dll used by IE)

    regsvr32 Urlmon.dll
    regsvr32 Shdocvw.dll
    regsvr32 Oleaut32.dll
    regsvr32 Actxprxy.dll
    regsvr32 Mshtml.dll
    regsvr32 Shell32.dll
    regsvr32 Browseui.dll
    regsvr32 jscript.dll
    regsvr32 vbscript.dll
    regsvr32 Shell32.dll

    and check also if you have these registry keys and values:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}
    Default value : IDispatch
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid
    Default value : {00020420-0000-0000-C000-000000000046}
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid32
    Default value : {00020420-0000-0000-C000-000000000046}

    Then re-apply the Franklin's solution.

    Hope this help. Let us know.

    :)
     
  4. appster

    appster Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    530
    Location:
    Paradise (Hawaii)
    Thanks guys - I'll try those 'remedies' when I get home this eve. ;)
     
Loading...
Thread Status:
Not open for further replies.