ICMP Echo ping reply failed

Discussion in 'other security issues & news' started by KeyPer4Life, May 26, 2014.

Thread Status:
Not open for further replies.
  1. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Ping Reply: RECEIVED (FAILED) — Your system REPLIED to our Ping (ICMP Echo) requests, making
    it visible on the Internet. Most personal firewalls can be configured to block, drop, and
    ignore such ping requests in order to better hide systems from hackers. This is highly
    recommended since "Ping" is among the oldest and most common methods used to locate systems
    prior to further exploitation.

    The "Shields Up" test result at grc.com. How serious is this?
    Since this test targets a connected modem/router (not software firewall) how does one get
    a pass? There was a setting in modem & router for blocking ICMP which I checked. Still
    failed test, but ports came up stealthed.
     
  2. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    8,634
    Location:
    NSW, Australia
    Do you have a router setting to "block wan ping"?
     
  3. prius04

    prius04 Registered Member

    Joined:
    Apr 14, 2007
    Posts:
    1,238
    Location:
    USA
    Are you, by any weird chance, using an Arris TG862G gateway provided by Xfinity (Comcast)? I am and have the same issue. Apparently, there is no way to block pings as is outlined in at least one thread on the Comcast board (link below).

    http://forums.comcast.com/t5/Home-N...m-quot-setting-not-blocking-ICMP/td-p/1749747
     
  4. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,273
  5. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Checked the router settings and under (Block Wan Requests) I don't see anything like "block wan ping".
    Have checked Block Anonymous Internet Requests in router firewall settings.

    There is also settings for Blocked Services > PING > Service Name: Ping and Protocol: ICMP > Port Range 0~0
     
  6. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974

    Was using a DSL modem before which had settings that didn't respond to ICMP ping reply. Result : Pass.
    Now I had Arris modem set to custom with ICMP set to block, but according to your posted comcast
    link it blocks outgoing ping requests instead of incoming and sounds like it has yet to be fixed.
     
  7. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    8,634
    Location:
    NSW, Australia
    I have a Billion router. "Block wan ping" fixes that "Shields Up" test result at grc.com.
     
Loading...
Thread Status:
Not open for further replies.