I did it!

Discussion in 'all things UNIX' started by Murderlove, Jan 16, 2009.

Thread Status:
Not open for further replies.
  1. Murderlove

    Murderlove Registered Member

    Joined:
    Jul 18, 2008
    Posts:
    99
    Hello everyone,

    I finally did a dualboot with XP and Linux after trying a few distro's :cool: . My favorites so far are OzoS, Ubuntu and Linux Mint. I now have Linux Mint 6.0 Felicia installed. But I have a question regarding my graphic card settings. I do not know where to save the file so that Mint can startup with the settings I have specified. I have taken pictures of it so hopefully someone can help me out.



    http://img177.imagevenue.com/img.php?image=18988_1_122_420lo.jpg
    http://img104.imagevenue.com/img.php?image=18990_2_122_75lo.jpg
    http://img152.imagevenue.com/img.php?image=18991_3_122_976lo.jpg
     
  2. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,702
    Hello,

    First, congratulations!

    Second, once you setup the desktop, it should remember and launch every consequent time. To access system files, like xorg.conf, you'll need root permissions or sudo in ubuntu or mint. The best way to merge, copy, backup files is from the command line.

    Mrk
     
  3. Murderlove

    Murderlove Registered Member

    Joined:
    Jul 18, 2008
    Posts:
    99
    Hello Mrkvonic,

    It does not seem to load in the resolution and refreshrate I had put in the driver settings, which is what I want. I had the same with Ubuntu. It seems to load into the highest resolution my monitor supports, and a different refreshrate, and that is something which I do not want.
     
  4. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,702
    Maybe your graphics driver does not support those rates?
    Don't force too much, you can damage your monitor ...
    Mrk
     
  5. Murderlove

    Murderlove Registered Member

    Joined:
    Jul 18, 2008
    Posts:
    99
    I do not know why it returns to the automatic selection of both resolution and refreshrate. The r_mode which I choose is 7 1152x864, and my monitor supports a refreshrate up untill 140 in that specific r_mode. I only put it on 100 in the driver settings, which is apparently the maximum in those drivers of Linux.
     
  6. Beavenburt

    Beavenburt Registered Member

    Joined:
    Dec 17, 2006
    Posts:
    566
    I've got an nvidia card. What you need to do is open nvidia settings as root. So in Mint do a "sudo nvidia-settings" in terminal. That will open the settings as root. Set your resolution etc then click the save to x config file button to update your xorg.conf
    That's it. Always works for me. I suspect it's not saving because you're running nvidia-settings as user rather then root.
     
  7. lewmur

    lewmur Registered Member

    Joined:
    Dec 22, 2008
    Posts:
    332
    It has nothing to do with your monitor. This is a stupid bug in Ubuntu, which is the base of Mint, where the nVidia Settings applet is not opened with root privileges. It has been known for a long time but they won't fix it because some feel you shouldn't be allowed to modify xorg.conf from an applet. Just plain dumb in my opinion.

    The solution is to open a terminal and type "gksudo nvidia-settings" from the command line. This will allow you to save your settings.
     
  8. lewmur

    lewmur Registered Member

    Joined:
    Dec 22, 2008
    Posts:
    332
    Your answer is correct but I wanted to point out why the bug exists.
     
  9. Murderlove

    Murderlove Registered Member

    Joined:
    Jul 18, 2008
    Posts:
    99
    Hello everyone,

    Thank you so much for your help! gksudo nvidia-settings did the trick:D
     
Loading...
Thread Status:
Not open for further replies.