HTTP Scanner problem

Discussion in 'NOD32 version 2 Forum' started by rdsu, Aug 15, 2006.

Thread Status:
Not open for further replies.
  1. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    Hi,

    I'm developing an application using Java Servlets and Tomcat.
    I'm having problems to send the request line, for example:
    "GET /servlet/sdist.Calc?var1=3&var2=9&type=raw HTTP/1.1"

    The server return a error because it says that the method "ET"(it should be GET) is not supported!

    After a lot of debugging and desperation, I remembered that NOD32 have a HTTP scanner and could be the cause of the problem, and when I turned it off, the problem was solved!

    Is this a normal behaviour on the NOD32 HTTP Scanner or what!?

    If you need more info...
     
  2. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    I think that nod's http scanner doesn't work on servers, but maybe someone else has a better explanation.

    Cheers,

    Alphalutra1
     
  3. alglove

    alglove Registered Member

    Joined:
    Jan 17, 2005
    Posts:
    904
    Location:
    Houston, Texas, USA
    Are you running NOD32 on the client computer or on the server?
     
  4. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    Everything are on the same computer...
     
  5. alglove

    alglove Registered Member

    Joined:
    Jan 17, 2005
    Posts:
    904
    Location:
    Houston, Texas, USA
    Do you have the IMON --> Setup --> HTTP --> "Client compatability" items set to "Higher efficiency" or "Higher compatability"?
     
  6. NOD32 user

    NOD32 user Registered Member

    Joined:
    Jan 23, 2005
    Posts:
    1,766
    Location:
    Australia
    The reason IMON is disabled by default for servers and recommended that way is to do with the internal operation of server applications.
    Sounds to me like you should also have IMON disabled for your setup, although it may be possible through use of both compatability and application exclusion setting in IMON to tune your issue out of it between these two options.

    Cheers :)
     
  7. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    Everything are in "Higher compatibility".
     
  8. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    I already disabled the port 8080, but would be nice if the NOD32 developers add an option to exclude hostname, like avast! WebShield does...
     
  9. alglove

    alglove Registered Member

    Joined:
    Jan 17, 2005
    Posts:
    904
    Location:
    Houston, Texas, USA
    Do you know which executables are used for the "server" side processes? If so, you may be able to exclude them via IMON --> Miscellaneous --> Exclusion --> Edit.
     
  10. rdsu

    rdsu Registered Member

    Joined:
    Jun 28, 2003
    Posts:
    4,456
    Didn't work...
     
Thread Status:
Not open for further replies.