HOWTO: Install Acronis on Ubuntu 7.04

Discussion in 'Acronis True Image Product Line' started by AaronAnderson, May 2, 2007.

Thread Status:
Not open for further replies.
  1. AaronAnderson

    AaronAnderson Registered Member

    Joined:
    Jul 28, 2006
    Posts:
    65
    Code:
    sudo apt-get install rpm build-essential linux-source linux-headers-`uname -r`
    wget http://download.acronis.com/sl/dhflvmvvunqzvvxjgmvm/support/ticket/995195/snapapi26_modules-0.7.19-1.noarch.rpm
    
    
    
    --- run trueimage installer, skip module compile. don't forget to chmod +x your file.
    
    sudo rpm -Uvh snapapi26_modules-0.7.19-1.noarch.rpm --nodeps
    sudo dkms ldtarball --archive=/usr/lib/Acronis/kernel_modules/snapapi26-0.7.19-all.tar.gz
    
    cd /usr/src/
    sudo tar xjvf /usr/src/linux-source-2.6.20.tar.bz2
    
    sudo dkms build -m snapapi26 -v 0.7.19 -k 2.6.20-15-generic --config /boot/config-2.6.20-15-generic --arch i686 --kernelsourcedir /usr/src/linux-source-2.6.20
    sudo dkms install -m snapapi26 -v 0.7.19 -k 2.6.20-15-generic --config /boot/config-2.6.20-15-generic --arch i686 --kernelsourcedir /usr/src/linux-source-2.6.20
    
    

    Now if I can just get the damn icons to work so I don't have to "sudo trueimage" from a terminal
     
    Last edited: May 5, 2007
  2. Himbeertoni

    Himbeertoni Registered Member

    Joined:
    May 5, 2007
    Posts:
    2
  3. AaronAnderson

    AaronAnderson Registered Member

    Joined:
    Jul 28, 2006
    Posts:
    65
    Last edited: May 5, 2007
  4. Himbeertoni

    Himbeertoni Registered Member

    Joined:
    May 5, 2007
    Posts:
    2
    Thanks.
     
  5. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello AaronAnderson and Himbeertoni,

    Thank you for choosing Acronis Linux Server Disk Backup Software.

    Please note that the link AaronAnderson provided is generated by Acronis Support Engineers and it is time limited. Thus, we would recommend that you contact Acronis Support Team should the link expired.

    AaronAnderson, please note that Ubuntu is one of the few Linux distributions, which will not enable the root account. Acronis True Image 9.1 Server for Linux can be used under the account with root permissions only. Thus, under Ubuntu you should use "sudo" command to start the program.

    Thank you.
    --
    Aleksandr Isakov
     
  6. nonono

    nonono Registered Member

    Joined:
    May 8, 2007
    Posts:
    1
    Hi, only gksudo or kdesu should be used to start up apps with root priveleges, NOT sudo.

    https://help.ubuntu.com/community/RootSudo#head-0c932eb3f1619126fc8307ee7690f462552d34ec

     
  7. WaxWeazle

    WaxWeazle Registered Member

    Joined:
    May 11, 2007
    Posts:
    4
  8. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello WaxWeazle,

    Please see this post for instructions.

    Thank you.
    --
    Marat Setdikov
     
  9. AaronAnderson

    AaronAnderson Registered Member

    Joined:
    Jul 28, 2006
    Posts:
    65
    There's been a kernel update that will fubar your true image installation..

    Replace the last two lines above, with these:

    Code:
    sudo dkms build -m snapapi26 -v 0.7.19 -k 2.6.20-16-generic --config /boot/config-2.6.20-16-generic --arch i686 --kernelsourcedir /usr/src/linux-source-2.6.20
    sudo dkms install -m snapapi26 -v 0.7.19 -k 2.6.20-16-generic --config /boot/config-2.6.20-16-generic --arch i686 --kernelsourcedir /usr/src/linux-source-2.6.20
    
     
  10. schlappohr82

    schlappohr82 Registered Member

    Joined:
    Jun 1, 2007
    Posts:
    2
    hello at all,

    thanks for your how-to's, but the 2 links for the snapapi26_modules-0.7.19-1.noarch.rpm don't work.
    could you post an URL that is valid?

    thanks a lot
     
  11. AaronAnderson

    AaronAnderson Registered Member

    Joined:
    Jul 28, 2006
    Posts:
    65

    Please read through the thread. You'll see that you need to contact support to get the file. Or send me a PM and i'll help you.
     
  12. schlappohr82

    schlappohr82 Registered Member

    Joined:
    Jun 1, 2007
    Posts:
    2
    ..my fault,
    I've contacted the support-team and I've got the link. :D

    thank you
     
  13. mknux

    mknux Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    1
    Hi,

    I have the same problem during the installation of Trueimage server on a ubuntu 7.04. Someone can send a good link for download snapapi26_modules-0.7.19-1.noarch.rpm ?

    Thank in advance.

    Alexandre
     
  14. Christian_Jensen

    Christian_Jensen Registered Member

    Joined:
    Jun 28, 2007
    Posts:
    1
    Hey im using the Acronis True Image Management Console® version 9.1 (build 3.666) and tryed to install the Linux Agent on a Debian Linux.


    insmod snapapi26.ko
    insmod: error inserting 'snapapi26.ko': -1 Unknown symbol in module

    Why do I get this error ?

    The Management Console is giving me the error code :
    E000101F4: Application module error

    I am using the snapapi26 -v 0.7.3 could it be the reason ?
    where can I find the v. 0.7.19 and is it the reason why it dont work for me ?
    If someone could send me the snapapi26_modules-0.7.19-1.noarch.rpm to trend2006 at gmail.com, then I might try that out :)
     
    Last edited by a moderator: Oct 3, 2007
  15. biggyL

    biggyL Registered Member

    Joined:
    Apr 29, 2006
    Posts:
    7
    Hi folks,

    Could someone send me snapapi26_modules-0.7.19-1.noarch.rpm to lkolchin at gmail.com so I could install trial version on latest Gentoo server?
     
    Last edited by a moderator: Oct 3, 2007
  16. res5it

    res5it Registered Member

    Joined:
    Aug 23, 2007
    Posts:
    3
    Could someone send me snapapi26_modules-0.7.19-1.noarch.rpm

    snapapi26_modules-0.7.19-1.noarch.rpm


    I need it 2 ,I want to try the software on my debian 4.0 eth,please send it to me res5it at gmail.com

    Thanx in advance
     
    Last edited by a moderator: Oct 3, 2007
  17. Advia

    Advia Registered Member

    Joined:
    Oct 3, 2007
    Posts:
    1
    snapapi26_modules-0.7.19-1.noarch.rpm


    I need it 2 ,I want to try the software on my ubuntu 7.04,
    Please send it to me ugur at its.com.tr or ugur at guncer.com

    Thanx in advance
     
    Last edited by a moderator: Oct 3, 2007
  18. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
  19. nostra

    nostra Registered Member

    Joined:
    Oct 25, 2007
    Posts:
    2
    at Acronis Support

    snapapi26_modules-0.7.XX-X.noarch.rpm

    I need it too ,I want to try the software on my ubuntu 6.10, 7.04 and 7.10
    Please send it to me nostrada60 at gmail.com or ahelmig at ify.ch.
    I send a request to Support and i dont recieve anythings.

    Thanx in advance
     
  20. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello all,

    To nostra - I've checked and found that the link and additional instructions were sent to you. Could you please clarify if you've received this answer?

    Thank you.

    --
    Michael Levchenko
     
  21. nostra

    nostra Registered Member

    Joined:
    Oct 25, 2007
    Posts:
    2
    :(

    I received your instructions - not resolved my probs on install - hope your new instructions will help!

    Thanks for the moment

    Now is working with the new Agentfile 3877 - perfect

    Thanks so lot :D :D :D
     
  22. vadda

    vadda Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    1
    Hi!

    How did you solve your problems?

    Acronis Support sent me agent build 3877 and snapapi26_modules-0.7.26-1.noarch.rpm but I'm still not able
    to compile the module in ubuntu 7.10 or opensuse 10.3.

    regards,
    vadda
     
  23. ozz

    ozz Registered Member

    Joined:
    Nov 16, 2007
    Posts:
    1
    Im also very much so interested in giving this a shot on my ubuntu installation. could I also get the appropriate links? Thank You
     
  24. TAcuMopo

    TAcuMopo Registered Member

    Joined:
    May 2, 2008
    Posts:
    1
    Please, send me file snapapi26_modules-0.7.19-1.noarch.rpm to Der.Schwarze1 at gmail.com
    All links in this posts are invalid. I`m very need this file.
    Thank you!
     
  25. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
Thread Status:
Not open for further replies.