how to turn off remote desktop service in windows 10

Discussion in 'privacy general' started by taleblou, Aug 25, 2015.

  1. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    I tried turning off the remote desktop service in windows 10 and disable it in the service windows, but after reboot it turns back on and in automatic mode. It seems I can not get it to disable and stay disable. Any help?

    mine is a windows 10 home 64bit
     
  2. Infected

    Infected Registered Member

    Joined:
    Feb 9, 2015
    Posts:
    665
    have you tried in group policy?
     
  3. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,785
  4. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    windows 10 home 64bit of mine does not have group policy? I searched and ran : gpedit.msc, etc. and all show no group policy exist. So what can I do? Maybe win 10 home edition does not allow editing group policyo_O

    any other ways would be appreciate it.
     
  5. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,785
  6. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
  7. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,785
    If I open up the old Control Panel and then enter "remote access" in the search bar in the upper right corner, a link appears for enabling it. Maybe there's a way to disable it from the same menu/window once you click the link? I didn't try it cause I don't want to screw anything up here...
     
  8. Kobayashi maru

    Kobayashi maru Registered Member

    Joined:
    Nov 7, 2009
    Posts:
    124
    Location:
    Drivin' all night my hands wet on the wheel....
    So you don't want a possible exploitable feature to run, or you simply won't use it, but your own choice is forcibly reset....
    Group policy is a 'Pro' feature. You won't have it.

    Nice that MS deem home users to be reduced to such a lesser degree, don't you think? Why would you bother entertaining them?

    Anyway, mstsc.exe is win 7's remote desktop 'app', so maybe disabling that from running, or the Win 10 equivalent, will serve your purpose.... Some things never change.
     
  9. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,763
    Location:
    Texas
  10. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    I ahve no use and its a exploitable feature I want to turn off and tighten my windows.
     
  11. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
  12. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,785
    It's possible that the service could be running and yet it's actually not enabled in the settings. I don't think it's anything to worry about.
     
  13. TS4H

    TS4H Registered Member

    Joined:
    Nov 5, 2013
    Posts:
    512
    Location:
    Australia
    @taleblou Maybe try a Regedit file if you have not already;

    Code:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 1 /f
    regards.
     
  14. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    can you please state what to edit in that registery file? I went there and opened edit and I have a value of "1", so should I change it or what? Thanks in advance.
     
  15. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    all signs shows remote connection and control is off, but yet the service starts automatically. I hope you are right and its nothing to worry.
     
  16. wshrugged

    wshrugged Registered Member

    Joined:
    Jun 12, 2009
    Posts:
    202
    According to tenforums, there are three services in W10 associated with remote desktop. Did you disable each of them? Multiple options for disabling explained in the tutorial.

    image.jpg
    http://www.tenforums.com/tutorials/4499-services-start-stop-disable-windows-10-a.html
     
    Last edited: Aug 26, 2015
  17. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    yes and one of those services called "remote desktop services" is the one that turns back on automatically even after disabling. The other 2 stays disable. Although I used OO suite 10 for turning off windows 10 spyings.

    But that remote desktop services that turns on is mysterious to me? I do not know what causing it but could a program been doing this? Something like norton IS?
     
  18. wshrugged

    wshrugged Registered Member

    Joined:
    Jun 12, 2009
    Posts:
    202
    Don't think NIS would affect it, if anything, you might have to open a hole in NIS to get remote desktop to work properly. Can't hurt to try disabling NIS for troubleshooting purposes.
    Don't know if using OO suite is confusing the issue.
    What I'd try -- check the 'remote desktop services' properties tab for any dependencies. Could give you a clue as to what is triggering the start. Specific W10 set-ups might not allow you to change corresponding services' start settings.
    Try setting the service start to manual rather than disabled. 10 might not allow disabled for that service.
    I'd try each of the options in the tutorial link I posted earlier.
    Good luck.
     
  19. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,785
    Many services run at startup and are never used, and some on demand also. It's nothing to be concerned about. If your Settings show it's disabled or off, I think you're good. Good luck anyhow....
     
  20. TheWindBringeth

    TheWindBringeth Registered Member

    Joined:
    Feb 29, 2012
    Posts:
    2,086
    Misc ideas: SysInternals autoruns to look for a related item not yet addressed? Reviewing scheduled tasks to look for something starting it that way? Reviewing event and/or other logs to see when it is started and what else is going on shortly before that time? Checking to see if the startup is [also] triggered during user logoff/logon (which would be more convenient for testing purposes than having to fully reboot each time). Ask the OO folks if they are seeing the same thing and/or know whether there is a satisfactory solution?
     
  21. TS4H

    TS4H Registered Member

    Joined:
    Nov 5, 2013
    Posts:
    512
    Location:
    Australia
    Sorry I should have been more clear;

    Go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" to make the changes.

    Change the Dword from 0 to 1 to disable "fDenyTSConnections" or remote desktop connection.

    The fact that you have it already enabled to 1 and you still get a remote desktop service startup is very strange. In the same location

    Check also if "TSUserEnabled" is set to 0
    Check if "AllowRemoteRPC" is set to 0


    Also navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Remote Assistance"
    Check "fAllowToGetHelp" is set to 0.

    Other than this im out of ideas, maybe check your scheduled tasks, it could be turning on Remote desktop connection. Specifically look for "Microsoft\Windows\RemoteAssistance\RemoteAssistanceTask" and set to "Disable"

    regards

    Edit:

    Navigate to "KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\UmRdpService" find "Start" and change Dword to 3-Manual or 4 Disabled.
     
    Last edited: Aug 27, 2015
  22. anon

    anon Registered Member

    Joined:
    Dec 27, 2012
    Posts:
    4,095
  23. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166

    its all according to what you say. So thats strangeo_O
     
  24. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    for dependencies:
    this service depends on: remote procedure call (RPC)
    the following system component depends on: Remote desktop services usermode port redirector
     
  25. taleblou

    taleblou Registered Member

    Joined:
    Jan 9, 2010
    Posts:
    1,166
    My current running startup apps are hitman pro alert, secureaplus, heimdal, software informer, f-secure freedome, norton internet security and Jondo. SO could any of these be a culprit??
     
Loading...