How to recover a boot disc from Disc Director

Discussion in 'Acronis Disk Director Suite' started by jomoer, Jun 6, 2006.

Thread Status:
Not open for further replies.
  1. jomoer

    jomoer Registered Member

    Joined:
    Jun 6, 2006
    Posts:
    1
    I want to share my problem experienced with Disc Director and the solution, and hopefully it will be of some use to others. This may be covered somewhere else but I couldn't find any references.

    My Windows 2000 pc was hit by a power spike and I couldn't start it up. After some fiddeling I worked out it wouldn't power up if the hard drive was connected, but I didn't know if it was because of the drive or the power supply. To isolate the problem I plugged my drive into a friend's pc on the second IDE channel to see if it would power up and if it was accessible. It worked fine on his pc, but I noticed at the time he was running Acronis Disc Director. I replaced my power supply and powered up my pc, but startup failed and I got a message that system files were missing. Luckily (I thought) I had an Emergency Rescue Disk, so I went through the repair procedure, but no matter how I tried to do the repair it always failed. So I started looking at the directory structure, and noticed my main directories (WINNT, Program Files, and Documents and Settings) were all empty, and my boot.ini file was missing! I also had a new directory called BootWiz. I figured this was from Disc Director, but didn't know how to recover from this. I asked my friend what he knew, but he was also stumped, and didn't even know something like this would happen if a drive was plugged into his system. I googled for hours to find a solution and found nothing except some old comments about running fixmbr, which didn't work. I was getting desperate (this was my development system) so I took another look at my directory structure, and noticed that the missing directories and files were in the one and only directory under BootWiz. I looked through the entries and compared them to another Win2000 system, and they all looked fine. I also remembered that when I plugged my drive in my friend's pc it came up pretty quickly, so it couldn't have done much copying when it "corrupted" my drive. So I took the chance of moving the directories and missing file back to the root, and it worked!

    Step by step: What I actually did was first copy the partition to another drive so I could try different things without losing anything (you don't have to do this once you know what to do, but I'd recommend it anyway if your system is precious). I then plugged it into a system that was running Total Commander and didn't have Disc Director (TC wasn't required but it sure helped). I then marked and moved the contents (directories and files) of the WINNT directory under BootWiz to the empty WINNT directory in the root. Trying to move the WINNT directory itself to the root started a copy-and-delete, which took quite a long time and eventually failed - I had to move the files back to where they came from and start again. You'll know it's moving rather than copying because it's almost instantaneous. I did the same with the other 2 directories until I was left with only empty directories under BootWiz. I also moved the boot.ini to the root. There were 2 other files as well, but comparing them by content to the ones already in the root confirmed they were exactly the same. In the end, after doing a practice run on my copy drive, the fix took less than 2 minutes. I then put the drive back into my pc and started it up, and everything was fine.

    Hopefully this will help someone else with the same problem so that they don't spend hours fruitlessly searching for a solution. The Disc Director help doesn't tell you how to do this.
     
  2. crofttk

    crofttk Registered Member

    Joined:
    May 15, 2004
    Posts:
    1,976
    Location:
    Eastern PA, USA
    Cool. Thanks for writing, jomoer ! No need for someone with a similar situation to reinvent the wheel.
     
  3. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello jomoer,

    Thank you for choosing Acronis Partition and Disk Managing Software.

    Actually, Acronis OS Selector does not move all the system folders to the special Bootwiz folder automaitcally. The special option in the Operating system properties->Folders should be enabled. You can find the information about this in the section 7.7.5 of Acronis Disk Director Suite 10.0 User's Guide.

    Most likely the power spike has occurred during the bootup process of the operating system and Acronis OS Selector has not finished the system folders recovering.

    However, thank you for sharing your experience. If you have any further experience to share, please feel free to post it on this forum.

    Thank you.
    --
    Kirill Omelchenko
     
Thread Status:
Not open for further replies.