How to let Windows 8 Smartscreen Filter through firewall

Discussion in 'other firewalls' started by zerotox, Mar 14, 2013.

Thread Status:
Not open for further replies.
  1. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Hi guys. I have Windows 8 firewall with outbound enabled and obviously that affects Windows 8 Smartscreen Filter preventing it to connect. What rules should I create to let it through as I'm not sure which executable is responsible for it.
     
  2. alexandrud

    alexandrud Developer

    Joined:
    Apr 14, 2011
    Posts:
    1,231
    Location:
    Romania
    Smart Screen Filter is a feature in Internet Explorer that helps detect phishing websites. You should allow connections for iexplore.exe.
     
  3. harsha_mic

    harsha_mic Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    791
    Location:
    India
    Hi,

    Isn't Smart Screen supposed to be allowed thru windows firewall by default?

    Smart screen works w/o any issues for me. I have not configured anything specific in windows firewall.

    Is there any setting in windows firewall to enable outbound control?

    Thanks,
    Harsha
     
  4. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Internet explorer connects just fine. On Windows 8 Smatscreen filter is integrated into the system, it's not just an Internet Explorer feature.
     
  5. Windows_Security

    Windows_Security Registered Member

    Joined:
    Mar 2, 2013
    Posts:
    3,083
    Location:
    Netherlands
    Smartscreen is listed in group policy settings as a feature of Internet Explorer, so Alexandrud's explanation seems valid to me. Looking at its function to filter url's and content (downloads), it would also be logical to put in a higher OSI-layer like a browser.
     
  6. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    It's strange then as IE 10 connects out just fine while Smartscreen filter comes out with "check your internet connection message" and "cannot connect".
     
  7. m00nbl00d

    m00nbl00d Registered Member

    Joined:
    Jan 4, 2009
    Posts:
    6,623
    Have you enabled firewall logging in Windows 8? (It comes disabled by default in Windows 7.)

    You could then check Event Viewer and see what process(es) get blocked when using SmartScreen. Another option would be to use something like Process Explorer and see what process makes the call.
     
  8. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Good idea, thank you! Logging is enabled in Windows 8 firewall but doesn't show the process, just the protocol type, ports etc. Will try with Process explorer.
     
  9. arsenaloyal

    arsenaloyal Registered Member

    Joined:
    Nov 1, 2009
    Posts:
    507
    you have to allow explorer.exe to connect to the internet,this is hte process that screens applications in windows 8.
     
  10. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Thank you very much, you are absolutely right. When I made an allow rule for explorer.exe to connect out to port 443 (https), Smartscreen filter connects out.
     
  11. safeguy

    safeguy Registered Member

    Joined:
    Jun 14, 2010
    Posts:
    1,718
  12. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
  13. safeguy

    safeguy Registered Member

    Joined:
    Jun 14, 2010
    Posts:
    1,718
    Yes it does that. On the other hand, you can always right-click on the .exe, go to Properties and "Unblock". ;)
     
Loading...
Thread Status:
Not open for further replies.