How to disable native pdf viewer in Firefox 19?

Discussion in 'other software & services' started by Raza0007, Feb 19, 2013.

Thread Status:
Not open for further replies.
  1. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    I have Adobe Acrobat installed so I want to disable the new native pdf viewer that is built in to Firefox 19. How do I do it?

    I tried changing this from Option>Applications to force pdfs to open through Adobe Acrobat, but it did not help, they still open with the native pdf viewer.

    I then changed the "pdfjs.disabled" to true, inside about:config, but that disabled pdfs from opening inside Firefox all together.

    Any suggestions?
     
  2. bigc73542

    bigc73542 Retired Moderator

    Joined:
    Sep 21, 2003
    Posts:
    23,873
    Location:
    SW. Oklahoma
    couldnt you just go to plugins and hit the disable button??
     
    Last edited: Feb 19, 2013
  3. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    The native pdf does not show up in the add-ons. There I have the adobe add-on installed and it is enabled, but the pdfs inside Firefox still opens through the new native pdf viewer. I want them to open with adobe acrobat instead.

    I am searching the web, but the directions found there just disable the opening of pdfs inside Firefox all together. I want to pdfs to open inside firefox but through adobe acrobat, not the native viewer
     
  4. bigc73542

    bigc73542 Retired Moderator

    Joined:
    Sep 21, 2003
    Posts:
    23,873
    Location:
    SW. Oklahoma
    The native PDF reader is a Foxit plugin. It does show up as in my screen shot. getting adobe to open through Firefox. cant help you there.
     
  5. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    No. Foxit is a different company, that makes pdf readers. You probably have that installed on your system.

    See here.
     
  6. bigc73542

    bigc73542 Retired Moderator

    Joined:
    Sep 21, 2003
    Posts:
    23,873
    Location:
    SW. Oklahoma
    the foxit came with the installation of FF. never had it installed.
     
  7. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    I do not have it on my system. I do have a plugin from adobe installed, but I have had that before upgrading to v19.

    Go to the plugin page and click "more" after the plugin. It will tell you the date it was installed the date it was last updated on your system.
     
  8. ratchet

    ratchet Registered Member

    Joined:
    Feb 20, 2006
    Posts:
    1,912
    There is a drop down menu in Tools>Options>Applications>pdf>choose what you want to use!
     
  9. bigc73542

    bigc73542 Retired Moderator

    Joined:
    Sep 21, 2003
    Posts:
    23,873
    Location:
    SW. Oklahoma
    It was never on my system. Had to replace the HDD two weeks ago and it was never installed. Had to start over nothing was transferred from the old HDD it was DOA.
     
  10. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    I did. It is set to "Use Adobe Acrobat (in Firefox)" but the pdfs still open through the new native pdf viewer.
     
  11. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    How did you use to view pdfs in Firefox before upgrading to v19? Because before today, Firefox did not have a native pdf viewer, so if you could view pdfs inside Firefox, then you or somebody else must have installed the Foxit addon for Firefox, as it does not come natively with Firefox.
     
  12. bigc73542

    bigc73542 Retired Moderator

    Joined:
    Sep 21, 2003
    Posts:
    23,873
    Location:
    SW. Oklahoma
    I didnt I have adobe and I didnt use FF before Ver. 19
     
  13. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    Well then I can assure you that Foxit plugin does not come natively with Firefox. It is a third party plugin that a user can install if they want to view pdf documents inside Firefox without downloading them to the computer first.
     
  14. Tyrizian

    Tyrizian Registered Member

    Joined:
    Apr 26, 2012
    Posts:
    2,806
    type "about:config" in your URL bar and hit the ENTER key on your keyboard

    Click the "I'll be careful, I promise" button

    On the search bar on the about:config page, type or copy the following "pdfjs.disabled". The default value is set to false, double click on it to set it to true.

    Restart Firefox

    the PDF Viewer should no longer be set to it's default values
     
  15. pandorax

    pandorax Registered Member

    Joined:
    Feb 14, 2011
    Posts:
    330
    So you didn't download it from official site? And you have old flash, just saying.
     
  16. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    I did that already. But this disables pdfs opening inside of Firefox. The only option is to download the file and open it through Adobe.

    I want to have Firefox open pdf inside the browser through adobe acrobat, not its own native pdf viewer.
     
  17. Tyrizian

    Tyrizian Registered Member

    Joined:
    Apr 26, 2012
    Posts:
    2,806
    Try reinstalling the PDF viewer of your choice, see if that overwrites and changes it's attributes as default PDF Viewer for Firefox.

    That would be my next step
     
  18. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    Okay. I fixed it!

    Here are the steps if someone encounters similar problems

    1- Go to about:config and change the "pdfjs.disabled" to "true"

    2- Make sure inside Firefox>Options>Applications "Use Adobe Acrobat (in Firefox) is selected by default.

    3- Follow the directions in this article from Mozilla.

    Specifically you need to delete two files inside your profiles directory

    mimetypes.rdf
    pluginreg.dat

    When you restart Firefox, everything will be fine i.e. you can now view pdfs inside Firefox through Adobe Acrobat.

    Thanks to everyone who tried to help.
     
  19. Tyrizian

    Tyrizian Registered Member

    Joined:
    Apr 26, 2012
    Posts:
    2,806
    Glad you fixed it :thumb:

    Also, thanks for sharing the fix
     
  20. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    8,029
    Location:
    Lloegyr
    I have noticed on two separate computers that this native reader has frozen momentarily when I have tried to open any of these AV Comparatives links. The odd thing is that the next time I try to open them everything is fine. Even if I close the browser & open it again. I can open normally using the Google Docs Viewer extension. Both versions of Firefox were set-up almost identically on both computers. I'm guessing that this may be an extension clash. I'll probably try to disable this native viewer.
     
  21. mantra

    mantra Registered Member

    Joined:
    Jan 25, 2005
    Posts:
    5,152
    Thanks
    i was looking for it too!!!
     
  22. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    So the PDF reader is written in Javascript, but are PDF's opened by it able to execute Javascript?
     
  23. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    The built in pdf viewer might just be a basic viewer and may not be compatible with all pdfs. While I was searching for a way to disable it, I came across threads where people were talking about how the built-in pdf viewer in Chrome was not compatible with some websites and they needed to use adobe or some other reader for those sites. So, Firefox's pdfs viewer might have similar problems as well.
     
  24. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
  25. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    8,029
    Location:
    Lloegyr
    It's a possibility. I am tending to favour the idea that it is more to do with what default PDF reader you are running to begin with. Most of the problems seem to be with those who are running something other than Adobe Reader. I have set PDF XC to open (Tools Options) instead of the new native default reader & everything seems back to normal (PDF XC opens in Firefox instead of the native default). I have had conversations on other forums with people who have had problems with this Firefox reader & who have Foxit as their default.

    I have had a similar problem on three different computers. All of them run PDF XC as the default reader.
     
    Last edited: Feb 21, 2013
Loading...
Thread Status:
Not open for further replies.