How to disable Compiz Fusion?

Discussion in 'all things UNIX' started by aigle, Dec 13, 2009.

Thread Status:
Not open for further replies.
  1. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    How can I siable Compiz-Fusion in PCLOS without uninstalling it? I change it to normal GTK GUI but it loads again on reboot with Emerald theme.

    Is there anything in linux like Autoruns in Windows where I can enable/ disable start up items?

    Thanks
     
  2. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Compiz Fusion icon. It's in the repository.

    Compiz icon.png

    Edit:- Whoa ! Too fast on the draw maybe - not sure whether in PCLOS repo. I have the bad habit of always assuming (U)buntu. :oops:
     
    Last edited: Dec 13, 2009
  3. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I think I tried it but on restart it reloads. Let me try it again.

    BTW what is this theme and what is the icon left to OPera?

    Thanks
     
    Last edited: Dec 13, 2009
  4. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    This should fix it .. http://www.ubuntu1501.com/2008/04/stop-compiz-fusion-from-loading.html

    The icon is for gufw a GUI frontend for iptables. I don't really need it in the panel. Once set to Deny All (plus whatever outgoing connections you want to
    allow or deny) your iptables will be configured and there is no need to have it start up with session and therefore no need to have it shown in the panel.

    I think the theme is New Wave and it is the default theme that comes with Ubuntu 9.10 (Gnome)...I think.

    Edit: You can also try this:-
    Run metacity --replace (temporarily stops compiz)
    compiz --replace (enables it again)
     
    Last edited: Dec 13, 2009
  5. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,696
    Check the startup sessions manager and see if compiz is launched from there, simply untick the box and Bob's your uncle. If not, time to figure out what is starting it.
    Mrk
     
Loading...
Thread Status:
Not open for further replies.