How to delete 'Legacy' registry entries?

Discussion in 'other software & services' started by Tommy, Aug 1, 2006.

Thread Status:
Not open for further replies.
  1. Tommy

    Tommy Registered Member

    Joined:
    Dec 24, 2002
    Posts:
    1,169
    Location:
    Buenos Aires - Munic
    I have some 'legacy' registry entries which have been left from old software. Problem i can't delete theme - acces denied, tried also 'Safe Mode'. Some ideas?
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    when ur in safe mode, have u tried using the (winxp-created) administrator account?

    also try changing the permissions for the registry entries u want to delete.
     
  3. Coff

    Coff Registered Member

    Joined:
    Oct 29, 2005
    Posts:
    53
    Location:
    UK
    Download PsExec from http://www.sysinternals.com/utilities/psexec.html

    Create a folder in your Program Files folder and name it PsExec. Place the psexec file in the folder. Create a batch file by opening Notepad and copying and pasting the following line into it :

    Start "" "c:\Program Files\PsExec\psexec" -i -d -s c:\windows\regedit.exe

    Save the file as PsExec Regedit.bat (the important thing is the .bat extension.)

    When you click on the .bat file you've created it will open regedit in such a way that you should be able to delete the legacy keys.
     
  4. Tommy

    Tommy Registered Member

    Joined:
    Dec 24, 2002
    Posts:
    1,169
    Location:
    Buenos Aires - Munic
    That worke very smooth, thanks:ouch:
     
  5. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.
    Will this only work for XP? On my 2k PC I get the error "......regedit can not be found".
     
  6. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    What happens if you change the instructions to reflect where regedit.exe resides in a Win2K OS....C:\WinNT :doubt:
     
  7. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.

    a-duh. Thanks Bubba. Betting that will do the trick. wished I`d thought of it :oops:


    Yep. That did it. Wish Windows would make up there mind where they are going to put stuff :rolleyes: then keep it there. ;) :p
     
    Last edited: Aug 1, 2006
  8. incursari

    incursari Registered Member

    Joined:
    May 16, 2004
    Posts:
    153
    Location:
    SG
    You can try by right click at that registry key -> Permission -> and check the Allow "Full control" box , then delete the key.
     
  9. Tommy

    Tommy Registered Member

    Joined:
    Dec 24, 2002
    Posts:
    1,169
    Location:
    Buenos Aires - Munic
    I tried that (was my first idea when the problem apeared), for some strange reason that doesn't do the job for 'special' entries. Anyway the method of @Coff worked perfect.
     
  10. sherwindu

    sherwindu Registered Member

    Joined:
    May 6, 2007
    Posts:
    2
    I think I followed Coff's instructions. I have the psexec file in my Program Files
    directory on my Windows 2000 PC. The file is stored internally as a type bat
    inside a txt file. When I click on it, it just brings up the text file. I tried to
    bring up from the cmd line, but that didn't work either. What's the problem?

    Sherwin
     
  11. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    Welcome to the forum's sherwindu!

    You'll find those file's run properly after placing them "on the path" ~ add the folder location containing those file's ~

    Double check that you've interpreted the batch line's "quote's" correctly. They must also be used to wrap the path anytime spaces are encountered. Try running the dir cmd with it's /x option as an alternative to quoting . It will show you a given file's 8.3 or, short name. For the immediate logged in user on say an XP install, their Documents and Settings folder would be written - docume~1.

    Copy/paste from your's if you have any doubt's.


    Steve
     
    Last edited: May 6, 2007
  12. Coff

    Coff Registered Member

    Joined:
    Oct 29, 2005
    Posts:
    53
    Location:
    UK
    An alternative is to create a shortcut rather than use a .bat file. The location line for the shortcut is as follows, (include the quotes).

    "C:\Program Files\PsExEc\psexec.exe" -i -d -s c:\windows\regedit.exe
     
  13. zapjb

    zapjb Registered Member

    Joined:
    Nov 15, 2005
    Posts:
    3,518
    Location:
    USA - Back in a real State in time for a real Pres
    Good to know. Thanks.
     
  14. sherwindu

    sherwindu Registered Member

    Joined:
    May 6, 2007
    Posts:
    2
    First, thanks for all the advice.

    Second, I had trouble kicking off this batch file from it's text file. I finally
    opened up a command file and manually changed directories to the one
    containing the psexec file. I then typed in the following command:

    start psexec -i -d -s c:\winNT\regedit.exe

    That worked, and although not elegant, it served my purpose.

    I have thoroughly searched my hard drives for the program WinFax and
    cleaned all references to it and it's parent Symantec and Norton. However,
    when I try and run the program Norton_Removal_Tool, the program cannot
    proceed, claiming it finds "Symantec WinFax Pro" which must be removed
    with the "Add/Remove" windows utility. Since WinFax is not in the that list
    of programs, I cannot remove it that way. Perhaps this is a bug in the
    Norton removal program.
     
  15. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    Please comment whether or not you've been to this page before?

    http://service1.symantec.com/SUPPORT/faxprod.nsf/docid/1998102114161204

    PS - As an FYI, "progra~1" isn't on the default path in win2k. If it's still there or you haven't appended the program folder in which it reside's to your path, that would be the holdup. You can get it working by moving psexec to one of the directories displayed after typing "path" in a shell window, then altering it's shortcut "target" to suit.


    Steve
     
    Last edited: May 7, 2007
Loading...
Thread Status:
Not open for further replies.