How to Configure ESS 4 when comp has public IP Address

Discussion in 'ESET Smart Security' started by Pratterscc, Apr 23, 2009.

Thread Status:
Not open for further replies.
  1. Pratterscc

    Pratterscc Registered Member

    Joined:
    Apr 23, 2009
    Posts:
    3
    I have one computer, directly connected to my ISP's modem (DSL). My computer gets a public IP address.

    How do I configure ESS to properly protect this machine, yet still allow applications to access the Internet?

    I've tried setting ESS to ask what to do as applications want to access the Internet, but this doesn't work.

    I reviewed the documentation, but either it's not published or I missed it. Seems ESS expects the computer to have a private IP.

    Not sure if I've provided enough information. If not, please ask. I'll respond.

    Thanks.
     
  2. robis

    robis Registered Member

    Joined:
    Mar 21, 2009
    Posts:
    149
    I dont understand question. Esset works OK. If you are talking about deniing some address or some program to acces internet then you shoul try set firewall to Interactive mode.

    You must speccify problem witch you have.
     
  3. Pratterscc

    Pratterscc Registered Member

    Joined:
    Apr 23, 2009
    Posts:
    3
    robis, thanks for your quick reply.

    I'll try to explain better.

    I have one computer, connected directly to a DSL modem. This computer is assigned a public IP Address by the ISP.

    If I enable the Eset firewall, no applications can access the Internet. IE won't display pages, MS UPdates don't run, can't update Eset, no email, etc.

    If I disable the Eset firewall, all applications work correctly, however, my computer is now completely exposed.

    I've tried configuring rules to allow applications access to the Internet. I've tried putting Eset in the training/learning/interactive/whatever mode, where it asks for permission to allow an application access to the Internet. No matter how I configure things, no matter what rules I put in place, nothing seems to allow these applications to access the Internet while the firewall is enabled.

    Disabling the firewall is obviously not a good option, because then anyone on the Internet could get access.

    My question is this. How do I configure Eset to allow my applications to access the Internet, and still protect the machine from the bad guys on the Internet?

    Thanks!
     
  4. robis

    robis Registered Member

    Joined:
    Mar 21, 2009
    Posts:
    149
    Which version you are using, because what you type here i saw on my PC with older version of firewall. I think firewall 1044 was broken and corected was in version 1045 for me.

    Try instaling last version of program 4.0.424.0

    When I was same problem i shutdown firewall then i was run some www adress and at last I started Firewall at Interactive mode. (but you talk that is not possible) If not then I am sory maybe other peoples knows more.

    GL
     
  5. Pratterscc

    Pratterscc Registered Member

    Joined:
    Apr 23, 2009
    Posts:
    3
    robis, I'm not sure what version it is. I downloaded the setup file on Wednesday night, so unless Eset updated it between then and now, it should be the latest version.

    I sent an email about this issue to Eset tech support as well. They've responded with a suggestion. I'm going to test it today. I'll find out what version I'm running at the same time.

    Whether their passes or fails, I'll let you know so we can move forward from there.

    Thanks.
     
Thread Status:
Not open for further replies.