How do I get useable sound with Linux and onboard Realtek card?

Discussion in 'all things UNIX' started by mirimir, Apr 9, 2013.

Thread Status:
Not open for further replies.
  1. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,029
    I have a Gateway DX4860 that I bought primarily for running VirtualBox VMs, to eventually replace one of my old hosts. I added a 1.5TB RAID6 array, and a decent rear fan. It's running Xubuntu 12.04 x64, and until yesterday I was very happy with it.

    Now, after struggling for hours trying to get the mic to work, I'm extremely unhappy with it! I can play sound files, but there's no mic output. Actually, if I open "Sound Settings | Input", I see mic signal for a few seconds, and then the level indicator freezes. Sound Recorder records only noise.

    The Web tells me that many people have had sound problems in both Ubuntu 12.04 and Xubuntu 12.04, perhaps because of changes in PulseAudio. Also, the machine has an onboard Realtek card (ALC662) and it's my general impression that such cards don't work well in Linux. I did install the latest generic Linux driver from the Realtek site, but that didn't fix the problem. If anything, it made it worse, in that Sound Recorder eventually froze the system, forcing a hard reset.

    I really like the Debian text installer for partitioning (RAID, LUKS and LVM) so I'd like to stick with the Debian family. Would I likely have better luck with Debian Wheezy, instead of Ubuntu or Xubuntu?

    If not, what other distro would likely work better with the Realtek card, and also give me good partitioning tools?

    Alternately, would I be better off adding a good sound card? If so, which brands/models work best in Ubuntu or Xubuntu 12.04?

    Thanks :)

    Edit:

    I've read that the Creative X-FI Titanium Fatal1ty Pro card works.
    But http://www.h-node.org/soundcards/catalogue/en shows the Asus Xonar STX as the only PCIe card that works!
     
    Last edited: Apr 9, 2013
  2. moontan

    moontan Registered Member

    Joined:
    Sep 11, 2010
    Posts:
    3,931
    Location:
    Québec
    you want something that work out of the box?

    use Ubuntu or Linux Mint.

    i tried Mint Debian couple weeks and wasted a few hours searching for help for sound that did not work with a Realtek soundboard.

    in the end i re-installed something that works. ;)
     
  3. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,029
    Yes :)

    I do not want to learn the guts of Linux audio ;)

    Which release?

    I've read that upgrading to Ubuntu 12.04 can break audio :( But that's different from a clean install.

    What I know works are Ubuntu 10.n and 11.n, and this is a RAID/LUKS/LVM machine that I won't be upgrading in place :rolleyes:

    I've decided to get an Asus Xonar STX, and see how Ubuntu 12.04 works.

    I'd try Mint, but I don't see a Debian text mode installer, which I want for doing RAID/LUKS/LVM :(
     
  4. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677

    1st check your mic + plug you put mic switch on/off in ....etc ok or not ............

    right click on sound icon sound preference go to mic increase volume and check other settings as well

    also run command alsamixer and see if volume are down or not card selection etc lot of options you see there in gui mode
     

    Attached Files:

    Last edited: Apr 10, 2013
  5. moontan

    moontan Registered Member

    Joined:
    Sep 11, 2010
    Posts:
    3,931
    Location:
    Québec
    one thing to check out for is if someone has multiple soundcards.

    in my old machine i had 3 soundcards, and on reboot the system would chose one card at random.

    which was maddening because i had to enter commands via terminal to fix the situation.
     
  6. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,029
    Thanks, moontan. I'll be disabling the onboard "soundcard" before installing the new one :)
     
  7. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,029
    Thanks, mack_guy911. I've done those checks, and everything looks OK. Given that I have mic signal for 1-2 seconds in the mixer, I think that some component is hanging or crashing.
     
  8. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,029
    OK, I have success !!!

    I disabled the onboard audio, and installed an Asus Xonar STX (PCIe).

    I then installed Ubuntu 12.04.2 x64 with the alternate disk (for RAID/LUKS/LVM).

    Initially, I had sound output through the headphones, but no signal from the mic. Everything looked OK in Sound Settings (via the speaker icon).

    Opening alsamixer in Terminal, I saw that Mic and Mic Boost were both muted ("MM"). I highlighted each and hit "M", and then quit alsamixer. The mic works now :)

    Maybe this would have worked with the onboard Realtek, but I'm not going to check ;)
     
  9. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    glad it resolve sorry i was on fuduntu live DVD by the time i made screenshots and i dont have mic to check but yes you are right alsamixer sound is muted thats the reason

    good you start this thread and solve the problem :thumb:

    in future if someone need help it would be reference a great point :rolleyes:


    edit: F5 to get all option

    and use left arrow key you scroll to end there mic options ;)
     

    Attached Files:

    Last edited: Apr 12, 2013
  10. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,029
    Thanks again, moontan and mack_guy911 :)

    Off topic, I gotta admit that I am liking Ubuntu 12.04.2 a lot ;)

    But darn it, I really want the launcher at the bottom, and that seems impossible. I get Canonical's point about extra horizontal space on widescreen displays, but I've rotated my widescreen display 90 deg to fit with the other two displays ;)
     
  11. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    you can get unity bar at bottom as well but best thing you can do is hide it

    by going to right click on screen properties (where you change your wallpapers)

    on 2nd tab you see hide switch just on it;)


    for getting it at bottom you need extra ppa i dont remember if it still work in 12.04

    also you can do is hide unity bar and install docky cairo ....etc place it at bottom :)

    like my pics sometimes i play with docky


    https://www.wilderssecurity.com/showthread.php?t=232753&page=40
     

    Attached Files:

  12. moontan

    moontan Registered Member

    Joined:
    Sep 11, 2010
    Posts:
    3,931
    Location:
    Québec
    maybe you could try Xubuntu.
    you can put panels/launchers anywhere you want.

    the new version of Ubuntu will be released on April 25.
    one thing that could be of interest is that Canonical is also launching Gnomebuntu, an official spin of Ubuntu.

    hopefully it will offer more of a traditional desktop experience than Unity...
     
Loading...
Thread Status:
Not open for further replies.