home network

Discussion in 'other software & services' started by bamaman66, Jul 21, 2008.

Thread Status:
Not open for further replies.
  1. bamaman66

    bamaman66 Registered Member

    Joined:
    Aug 11, 2006
    Posts:
    366
    I have a home network consisting of a laptop and a pc. I can ping my pc from the laptop. I can ping my laptop from my pc. I can access my laptop files from pc. I cannot access my pc files from the laptop. I get the message I may not have access to this network source check with the administrator to see if I have permission. I have checked home network name to make sure both computers have the same network name. I have unshared and reshared my files.
     
  2. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,699
    Hello,
    What OS? Any firewall?
    Please provide as much info as you can.
    Mrk
     
  3. bamaman66

    bamaman66 Registered Member

    Joined:
    Aug 11, 2006
    Posts:
    366

    Both computers are xp home edition and both computers have online armor free firewall. I have had this problem before but I cannot remember how it was solved.
     
  4. emperordarius

    emperordarius Registered Member

    Joined:
    Apr 27, 2008
    Posts:
    1,218
    Location:
    Who cares
    I think that the easiest and fastest way would be to go somewhere and get hypnotized so that you can remember how you solved it. :thumb: :D
     
  5. Arup

    Arup Guest

    Have you tried giving your laptop a static IP?
     
  6. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.
    Have you tried disabling the FWs. See if the link can be established then re-enable them. This has worked in many instances for me.
     
  7. bthology

    bthology Registered Member

    Joined:
    Mar 17, 2008
    Posts:
    11
    Depending on what OS you are running, make sure guest account is enabled.
    With Vista make sure password protecting is disabled,
     
  8. L Bainbridge

    L Bainbridge Registered Member

    Joined:
    May 15, 2006
    Posts:
    173
    Location:
    London,U.K.
    I've got the same problem with accessing shared folders between PCs on a Home Network.
    These problems only arose after installing SP3 on 3 of the 4 computers.
    These three can all ping each other but cannot access shared folders (with the same error message you are getting).
    Interestingly, I have one PC not yet updated with SP3 and I can access the shared folders on that PC from any of the others but not vice versa.
    All 4 PCs run XP Home with Windows Firewall & either NOD32 or KAV7 and all are networked using a Netgear DG834G Router either using Homeplugs or Wireless.
    My guess is that it's some change that SP3 has made to Networking in XP Home that is causing the problems.
    If you google it you'll quite a few other people have had the same problem & nobody yet seems to have found a reliable answer.
    If you are feeling strong you could work your way through: http://winhlp.com/wxnet.htm.
    PS disabling the Win firewall doesn't do the trick nor does activating the Guest account.
    For the time being I'm just routing all shared folders through my NAS but I'd be interested to know if you find a solution.
    Good luck
     
  9. wat0114

    wat0114 Guest

    I agree with this suggestion. Also, check the OA fw logs for clues, such as blocked connections.

    In this similar thread thread last September it was registry cleaners that gave you grief.
     
    Last edited by a moderator: Jul 21, 2008
  10. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,054
    I had to deal with all these crazy netwok issues. Threw in the towel and gave Network Magic a whirl. Have it on all my computers, and haven't had network issues since then. You might want to give it a whirl.

    Pete
     
  11. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.
    If the FWs off trick does not work, assigning static IPs or as suggested, Network Magic should probably do the trick. Have never used N.M. but know many who have and love it.
     
  12. L Bainbridge

    L Bainbridge Registered Member

    Joined:
    May 15, 2006
    Posts:
    173
    Location:
    London,U.K.
    I found my answer - perhaps it might help you.
    Thanks to Peter2150 for Pure Networks Magic - didn't solve the problem but highlighted where the problem was...

    The problem was created by the IRPStackSize being changed (? by SP3 with some PCs).
    You need to recreat the DWord for this in each affected PC.

    Open regedit (back up Reg 1st etc.) Drill down to H_KEY Local Machine, then System subkey, then Current Control Set, then Services, then lanmanserver, then parameters.
    Look in Right Hand Pane see if there is a DWord value: IRPStackSize.
    If it is there Right click & modify, change 0 to 15 and change to decimal from hexadecimal - value will change to 21 & save. Then reboot PC.

    If DWord is not there, Right click - create new DWord & rename as IRPStackSize (case sensitive!).
    Right click & modify as above with value of 15 & change to decimal value.
    Save & reboot.
    Presto - all should be working!!
    Good luck
     
Loading...
Thread Status:
Not open for further replies.