HIPS does not work on Win8 Pro

Discussion in 'ESET NOD32 Antivirus' started by reza666, Nov 26, 2012.

Thread Status:
Not open for further replies.
  1. reza666

    reza666 Registered Member

    Joined:
    Jul 23, 2007
    Posts:
    15
    Hi,

    I just bought OEM version of Windows 8 Pro.
    I got "communication with the driver failed. HIPS does not work." but reading on another thread i manged to fix the issue atleast temporary by downloading version 6 (Pre-release). At first the problem was there but after enabling the "pre-release update" and updating the definition HIPS seems to be enabled.
    My Version is 6.0.115.0 and database version 7734.

    What i like to know is if my existing license for V5.2.9 will be possible to use with the final version of V6 for Windows 8? Or will Eset actually make a Win8 version for Nod32 V5?

    Also do i later need to uninstall this pre-release and install the final version or its possible to just update the program to final version later?
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    It is not necessary to enable pre-release updates in order to get v5 or v6 HIPS work on Windows 8. Please right-click the ESET tray icon, select About and copy the information about installed modules and paste it here if you run into the problem with HIPS.
     
  3. reza666

    reza666 Registered Member

    Joined:
    Jul 23, 2007
    Posts:
    15
    Thanks for the info. Although i got another problem today:
    --> Virus Signature database update ended with an error
    When i click update manually the error message disappeared, just wanted to mention it since v6 is not final candidate.

    Info from about:
    ---------------------
    Virus signature database: 7734 (20121126)
    Update module: 1040 (20120313)
    Antivirus and antispyware scanner module: 1372 (20121120)
    Advanced heuristics module: 1137 (20121023)
    Archive support module: 1157 (2012110:cool:
    Cleaner module: 1058 (20121005)
    Anti-Stealth support module: 1032 (20120806)
    ESET SysInspector module: 1229 (20121107)
    Real-time file system protection module: 1007 (20111129)
    Translation support module: 1099 (20121107)
    HIPS support module: 1059 (20121105)
    Internet protection module: 1049 (2012101:cool:
    Database module: 1024 (20121016)
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    You have the most current HIPS module installed which is fully compatible with Windows 8 as it's the very same version as on pre-relese servers. Nonetheless, you may receive this error after a fresh installation of v6.0.115 which contains an older version of the HIPS module.
    As for the error "Virus Signature database update ended with an error", it shouldn't occur as long as Internet connection is established. If that's not the case, I'm willing to connect to your computer remotely and check it out myself (I'm an ESET HQ employee).
     
Thread Status:
Not open for further replies.