High CPU Usage & Physical Memory

Discussion in 'malware problems & news' started by internet addict, Aug 10, 2016.

  1. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    Hello. Recently (yesterday) I noticed my hard drive keeps making this constant whirring noise. So I checked the task manager and it shows the CPU usage and the physical memory consistently stays hovering around 50%. I've done multiple virus scans with Malwarebytes, Avast Free, Bitdefender 60 Second Scan, Norton Power Eraser & Kaspersky's tdsskill. The only one that detected something was Norton Power Eraser which was avastemupdate.exe and avastnm.exe. So I removed those items and the problem still persists. Another thing I've noticed is that I can't uninstall Firefox Light. This is the message I get every time I try to uninstall the program:
    Installer integrity check has failed. Common causes include incomplete download and damaged media. Contact the installer's author to obtain a new copy.

    More information at:
    http://nsis.sf.net/NSIS_Error

    Any help would be appreciated if anyone has any idea what's going on.
     
  2. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,280
    Location:
    England
    What operating system are you using?
     
  3. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    2,872
    Location:
    Australia
    I would not of allowed NPE to remove those files if I used Avast AV.
     
  4. amarildojr

    amarildojr Registered Member

    Joined:
    Aug 8, 2013
    Posts:
    1,974
    Location:
    Brasil
    What version of Windows are you running? Does the problem still exist? Have you check ProcessExplorer to see what may be causing the issue?
     
  5. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    Windows 7
     
  6. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    I realized that after the fact. Wasn't the greatest idea I know. Guess I got too anxious and thought it might have worked.
     
  7. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,280
    Location:
    England
    What shows in the task manager as the main cpu/memory user when this issue happens?

    Is your avast still working?

    Does the issue still happen if you are in safe mode?
     
  8. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    2,872
    Location:
    Australia
    If you start NPE again you should be able to retore what it removed.
     
  9. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    CPU fluctuates between 50 - 70% and the physical memory is 1.93GB/67%

    Avast still seems to be working.
     
  10. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    I have not yet tried safe mode.
     
  11. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    I even uninstalled about 5 web browsers to see if that might be the problem. Apparently not.
     
  12. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,280
    Location:
    England
    What does it say in task manager is the main cpu/memory user when the issue is happening? (you can click on the column headers to make the main user appear at the top of the list)
     
  13. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    I'm not quite sure what you mean. I just know the hard drive is being noisy and the cpu and physical memory is running high. I did read something about the svchost possibly being the culprit.
     
  14. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,280
    Location:
    England
  15. ha14

    ha14 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    53
  16. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
  17. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    I just uninstalled and reinstalled Avast so hopefully that took care of the problem. Now what's interesting is when I do a smart scan everything is fine except for performance issues. Not sure if I want to risk resolving them. What to do.
     
  18. internet addict

    internet addict Registered Member

    Joined:
    Nov 26, 2012
    Posts:
    507
    What does it mean if the guest account seems to be working normal? The fan noise went away and the CPU usage is staying low.