Help needed: How to copy W2K partition then dual boot?

Discussion in 'Acronis Disk Director Suite' started by mecalvint, Nov 11, 2007.

Thread Status:
Not open for further replies.
  1. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    Dear Forum, I am a newbie at ADD/OS and hope you can give me some guidelines before I embark on this exercise.

    This is what I need to do:
    I have a W2K Pro install: System1.
    I need to make a copy of System1 and make another bootable partition: System2.
    I then want to be able to have OS dual boot to either System1 or System2.

    Q1: I should not use OS Copy OS since this copies the OS into a hidden folder, right?

    Q2: I should use ADD Copy Partition, right?

    Q3: Where do I go from Q2?

    I am a bit hesistant because in the past I have sued TI to image System1, then restore into a partition created by Partition Magic. BootMagic did not work in recognising System2 this way. I gather it has something to do with the MBR being imaged.

    Thanks in advance
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Correct. Don't do it this way.

    This should work, but you may have to manually edit the boot.ini file to point to the correct partition after the copy. Also, I would do the procedure from the DD CD and not from in Windows.

    After you have copied the partition, boot to the DD CD, edit the boot.ini file as necessary (you can use DD to browse the partition, right-click on the file and select Edit to do this) and then reboot and install OSS. This is assuming you created a DD CD that contains the OSS program.

    When you reboot to OSS, you should have two Windows 2000 menu entries. Right-click on each and select Properties. Make sure that each have that OS's partition marked as Active and the other's partition marked as Hidden. Also, in the Advanced section, make sure to check the Force hiding... option since you're working with Windows 2000.

    ---

    Do you currently have a good backup image of the drive (a TI image, for example)? I always recommend this before making parition changes. If something goes wrong it makes it much easier to be able to restore and try again.
     
  3. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    Mudcrab, thanks for the guidance.

    Here is what I have found out so far:
    1. Do a chkdsk first before you even try ADD. I ran it on a HD with bad sectors, and ADD would just stop. For a HD ute, you would think that it has at least a chkdsk equivalent. Or it should just repair the bad sectors and move on with the task at hand.

    2. Once I found a PC with a good HD, I boot off ADD. This 40GB HD has one partition SYSTEM.

    3. I had to resize SYSTEM and create one UNALLOCATED partition 20GB.

    4. Copy SYSTEM partition into the UNALLOCATED partition and use all the space there. So in essence, I have 2 Primary partitions, SYSTEM, and SYSTEM2. Before I commit, I make sure SYSTEM2 is PRIMARY, and 2nd in partition order. I also make sure that SYSTEM2 is not ACTIVE.

    5. Reboot into SYSTEM. Install ADD. Reboot. Install OSS from ADD. Reboot.
    NOTE that I did not have to muck around with boot.ini at all.

    6. The PC Reboot and OSS kicks in and ask me which partition I want to boot. I boot into SYSTEM. Changed the background of the admin account.

    7. I rebooted again, in OSS select the Windows Pro 2 partition, and I am still booting into SYSTEM, not SYSTEM2.

    8. While still in Windows I check OSS to see that for each partition, it is active and the other alternate is hidden. And Force hiding is on.

    So I have some further questions:
    1. How do I get OSS to work properly and boot into the right partition?
    1. How do I run ADD on a HD with bad sectors?
    2. Mudcrab, am I OK for not using the boot.ini as suggested?
    3. Anyway I can configure OSS to just display the boot options, and not all the other stuffs? I want Boot Magic simple GUI.

    Thanks,
     
    Last edited: Nov 14, 2007
  4. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    As I was driving home something came up as odd. If the partitions were hidden from each other, how is it that when I boot up in SYSTEM, I see SYSTEM2 in Explorer. I need to check what is going on there tomorrow morning.

    I was hoping that installing OSS in SYSTEM2 would figure all that out for me. You know, hidding partition, boot up and let me choose the partition to boot to etc.

    Looks like I have to do some more work.
     
  5. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    I assume this "other" PC is also running Windows 2000?

    #5 - This could be part of the problem. Was the SYSTEM2 partition hidden when you booted back into SYSTEM? It probably would have been better to try and install OSS from the DD CD instead of booting into SYSTEM and installing it from there. That way you could set your OSS settings before you booted into Windows.

    #6 - It sounds like you ran into the "cross-link" bug in OSS. If possible, can you attach your BOOTWIZ.OSS file to a post (you'll need to make a copy and rename it to BOOTWIZ.TXT). This file is located in a hidden BOOTWIZ folder on the partition where you installed OSS. One way to avoid this bug, is to create a small Primary FAT32 or NTFS partition (150MB or so) and install OSS to that partition (using a Custom install) instead of letting it install to an OS partition. Then, before you install OSS, use DD to set the OSS partition Active and all the other OS partitions as unhidden. Once OSS is installed, boot to the OSS menu and edit the properties of each OS to make sure the correct partition is Active and the correct partition(s) are hidden.

    DD will not resize partitions with bad sectors. You'd have to delete the partitions from the drive and recreate them in the size you want. If you have TI, you could restore an image and resize to the size you want. Make sure to run chkdsk /r on the partitions afterwards to re-tag the bad sectors so they don't get used.

    Without knowing what your boot.ini files look like, I couldn't say if not making changes was the correct thing to do or not. You'll need to boot into OSS and select to edit the boot.ini file for each OS and make sure that they point to the correct partition(#).

    On bootup, if you only want the OSS menu, set the menu to full screen mode.

    Windows 2000 makes it much harder to hide partitions. If force hiding isn't working, then use Windows Disk Management to unassign a drive letter to the partition so it won't be used or available.
     
  6. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    This is driving me absolutely bonkers: I cannot boot into the second partition.
    And I think it has something to do with not able to hide the first partition.

    This is what I did:
    1. Starting with 3 partitions: P1/P2/OSS
    2. Uninstall OSS from the OSS partition.
    3. Delete the P2 partition.
    4. Copy P1 into P2. Make P2 Primary not Active.
    5. Boot into DD, modify boot.ini in P2 to partition(2).
    6. Install OSS into OSS partition.
    7. Boot into OSS, from P1 can hide P2. From P2 cannot set P1 hidden because it is grey out.
    8. Boot into P1, P2 is indeed hidden, some error about cannot set device drive etc.
    9. Boot into OSS, select to boot P2, it just boot into P1

    I will have to send boot file soon.

    Help.....

    I even tried boot into DD, make P2 active and reinstall OSS. Still cannot hide P1.

    Windows 2000 I have.
     
  7. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    This is the "grayed-out checkbox" bug. It can be fixed by editing the BOOTWIZ.OSS file or you can usually avoid it by not having a Windows partiton marked as Active when you install OSS. In you case, the OSS partition should be marked Active prior to installing OSS and both P1 and P2 should be unhidden. However, my tests where with XP and not Windows 2000 so the results may be different with how OSS detects them.
     
  8. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    I still have not got it to work.

    I uninstalled OSS and through ADD, I can Hide P1, Unhide and Activate P2. P2 boot just fine.

    Then I boot into ADD, Unhide both P1 and P2, activate OSS partition, install OSS into that partition. I was hoping that that would not give me the gray box bug.

    And what did I get, gray out box on P1. I cannot hide P1. But I don't understand how not be able to hide P1 in the P2 environment cause me not able to boot into P2.

    Attached is my bootwiz.txt. I don't think there is anything in there I can fix to make OSS hide P1 in P2.

    This is madness!!!!!!!!!!!!!!!!!

    Just to teel you what I am seeing in OSS:
    Operating systems:
    Windows 2000 Pro
    Windows 2000 Pro (2)

    The properties of Windows 2000 Pro Partition:
    Local C: gray check Active, gray uncheck Hidden
    SYSTEMX(1#-2): not gray uncheck Active, not gray checked Hidden
    OSS (D): not gray unchecked Active, not gray unchecked Hidden

    The properties of Windows 2000 Pro Partition (2):
    Local Disk D: not gray check Active, gray uncheck Hidden
    SYSTEMX(C): gray check Active, gray not check Hidden
    OSS (D): not gray unchecked Active, not gray unchecked Hidden

    From those settings, you think I can boot into SYSTEMX. But I cann't. AHHHHH!!!!!!!!!!!!!!!
     

    Attached Files:

    Last edited: Nov 16, 2007
  9. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    OK I am figuring out why it is not working.

    Just so we don't get too confuse, I'll use P2 and SYSTEMX interchangeably. It's the same thing.

    Anyway, OSS keeps resetting my P2's boot.ini file to point to partition(1).

    I boot into ADD, change P2's boot.ini to point to partition(2).
    I rebooted again into ADD, check P2's boot.ini and the change to partition(2) sticks.
    I reboot into OSS, select to boot into P2, and it boots into P1.
    I reboot into ADD, and check P2's boot.ini, and it is resetted to partition(1).

    Help!
     
  10. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    So in this post
    https://www.wilderssecurity.com/search.php?searchid=1917263&pp=25&page=5
    NULJET got it right,
    On my system OSS use a saved version of boot.ini that it keeps in the hidden Bootwiz folder and forces P2 to boot into partition(1).

    So I went into OSS, edit boot.ini in P2(SYSTEMX) and set it to boot into partition(2), and it boots there.
    YEAH!!!!!!!!!!!

    But I still got the problem of P1 not hidden while I am in P2. So P1 is C: and P2 is D:

    How do I hide P1 when that option is grayed out in P2 properties. As you can see my bootwizz.oss is fine in that regards.
     
  11. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    OSS does save copies of the boot files for each OS and that includes the boot.ini file. Sorry, if I wasn't more clear on this, but I stated in Post #5 (third to last paragraph) that you needed to edit the boot.ini file from OSS. Trying to edit the boot.ini files outside of OSS is a useless exercise as OSS will just replace the file with its copy the next time you boot that OS.

    For you BOOTWIZ.OSS file, I think you need to make the following changes to the second OS entry. It's hiding the wrong partition and the multi= setting appears to be wrong (though I don't know exactly what OSS uses this for).

    Your file shows (I've just pasted in the revlevant parts):
    Code:
    	<partitions>
    		<[B][COLOR="Blue"]id1638790056[/COLOR][/B] begin="63" crc="54011" disk="1270290219" fs="ntfs" number="1" serial="c06ad33cb3d33cb8" size="40146372" type="7" />
    		<[COLOR="Red"][B]id1604829138[/B][/COLOR] begin="40146435" crc="54011" disk="1270290219" fs="ntfs" number="2" serial="d54b350d8e65fbd5" size="38057985" type="7" />
    		<id2098470085 begin="78204420" crc="33906" disk="1270290219" fs="fat32" number="3" serial="c40b8b1a" size="2200905" type="12" />
    	</partitions>
    
    
    		<id3614952409 boot_as_ms71="0" boot_as_os2="0" boot_cd_entry="0" boot_partition="1604829138" bootname="bootsect.sys" icon="icon_sys_win" language="english" lba="1" multi="multi(0)disk(0)rdisk(0)partition(1)\WINNT" name_template="%n Professional%l %l(%ll%l) (2)" nthide="1" os_type="nt2000" uninstall_info="1" use_manual_disks_order="0" write_boot="1">
    			<partitions>
    				<id1604829138 active="1" />
    				<id2098470085 hidden="1" />
    			</partitions>
    		</id3614952409>
    I think it should be (scroll sideways to see it all):
    Code:
    		<id3614952409 boot_as_ms71="0" boot_as_os2="0" boot_cd_entry="0" boot_partition="1604829138" bootname="bootsect.sys" icon="icon_sys_win" language="english" lba="1" [COLOR="Blue"][B]multi="multi(0)disk(0)rdisk(0)partition([COLOR="red"]2[/COLOR])\WINNT"[/B][/COLOR] name_template="%n Professional%l %l(%ll%l) (2)" nthide="1" os_type="nt2000" uninstall_info="1" use_manual_disks_order="0" write_boot="1">
    			<partitions>
    				<id1604829138 active="1" />
    				<id[B][COLOR="blue"]1638790056[/COLOR][/B] hidden="1" />
    			</partitions>
    		</id3614952409>
    Try it and see if it helps.
     
  12. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    Mudcrab,
    I do really appreciate your patience with me.

    Update:
    1. I did the changes to bootwiz.oss while in P1.
    2. I rebooted and via OSS, I selected to boot into P2. Windows did not boot and says:
    Windows 2000 could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk.......
    3. I booted into P1 and check bootwiz.oss. Funny enough, P2, where I changed to partiton(2), it now says partition(65535)
    4. I changed it again to partition(2). Rebooted.
    5. I booted again and this time by ADD CD, I check bootwiz.oss. It says partition(65535). Is OSS doing this?
    6. WHile still in ADD, I reset this value to partition(2), and rebooted.
    7. OSS came up, and wipeout out all my changes!!!!!! That is, my fix of boot.ini got reset by OSS. My partitions name, which I change to P1 and P2, got reset back to default names.
    8. I am going back into OSS to change P2's boot.ini.

    I can boot into P2, but I still cannot hide P1 from P2.

    Question: where should I change bootwiz.oss as you have suggested?
    In P1. Or in ADD CD?

    That also prompts me another post where you have a solution for gray out boxes. You said to modify bootwiz.oss as well. SO do that where?
     
  13. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    For now, leave the partition(1) value in the "multi" setting as it is.

    Do you have "Force hiding" enabled for both menu entries?

    You may also be able to unassign a drive letter to the P1 partition when booted to P2 if Force hiding doesn't work.

    Can you correctly access your third partition (the FAT32 partition) from each OS?

    I don't think your problem is related to the "grayed out checkbox" bug. I don't see that in the BOOTWIZ.OSS file.

    As for editing the BOOTWIZ.OSS file. I recommend ONLY using the Windows Notepad program to edit this file. And, yes, sometimes the changes will make OSS revert or reset all its settings.
     
  14. mecalvint

    mecalvint Registered Member

    Joined:
    May 11, 2004
    Posts:
    36
    I used notepad to modify BOOTWIZ.OSS while in P1. The changes you said make sense, but how OSS reacted to the changes, make no sense to me.


    I am travelling right now and will not be able to try unassign the C: from P1 until this weekend.

    Will update this post then.

    Thanks Mudcrab.
     
  15. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    I have reread this thread and think your sysetm is suffering from cross-linking. Everything you describe points to that. The Windows drive letter changing to D:, the C: partition unable to be hidden, Windows not booting when you change the partition(#). What this means is that anything that references drive C: in the Registry or .INI files, etc. is actually accessing your original partition and not the files on the copied partition. This is not what you want. Also, if this is the case, Windows will not let you unassign the C: drive letter as it is the booting drive and contains the system files.

    If the copy were successful, then the Windows drive should be C: in the copy because it's C: in the original (at least this is how it is with XP). Again, I have no experience with Windows 2000 and it does detect partitions differently. However, it should still be possible to get the setup you want.

    Would you mind starting over using this procedure?

    Important Note: Do not reboot in Windows at any time during this procedure until after OSS is installed and all options are set and verified.

    Important Note: When you start DD in the steps below, select to run in Manual Mode. This gives you a lot more control. (You may already being using this mode.)

    • Boot to the DD CD and uninstall OSS. Select the Original Windows 2000 installation as the default OS.
    • Reboot and make sure Windows 2000 boots and runs correctly.
    • Boot to the DD CD and delete the 2nd Windows 2000 partition (the copy). Also delete the OSS FAT32 partition. The only partition left should be the original Windows 2000 partition. The rest of the drive should be unallocated.
    • Reboot and make sure Windows 2000 boots and runs correctly. There should be no other hard drive letters listed in My Computer or Disk Management, just the C: Windows partition/drive.
    • Using My Computer, browse your C: drive and delete the BOOTWIZ folder in the Root Directory (this may or may not have been removed when OSS was uninstalled).
    • Boot to the DD CD and start DD. In the following procedures make sure to apply the changes after each step. Don't do them all and then apply the changes.
    • Copy the original Windows partition to the unallocated space. If you are given the choice, resize to allow room for the OSS partition. Otherwise, after the partition is copied, used DD to shrink the "copy" a little to make room for the OSS partition. (Apply changes)
    • Create the FAT32 OSS partition in the unallocated space at the end. Make it a Primary partition. (Apply changes)
    • Make the OSS partition the Active partition. Do not hide any of the partitions. (Apply changes)
    • Open the Disk Editor for the drive and check your Partition Table. The original Windows partition should be in slot 1, the copy should be in slot 2 and the OSS partition should be in slot 3. Close the Disk Editor.
    • Browse the "copied" Windows partition with DD using Explore and find the boot.ini file.
    • Edit the boot.ini file so the partition(#) value matches the Partition Table slot number (should be 2). Click OK to save the file and close the Explore window.
    • Exit DD and reboot to the DD CD menu. Select to install OSS.
    • Choose the Custom Install option and select the OSS partition as the destination.
    • After OSS is installed, the computer will need to reboot. Remove the DD CD and the computer should boot into OSS. It should find both of your Windows installations and setup menu entries for them.
    • Check the properties for each and see if you can now hide the other OS's partition. The checkered flag icon should be on the Windows partition for that entry and not on the other partition (it'll be cross-linked if it is).
    • In the Advanced section of each entry, check for Force hiding checkbox.
    • For the original Windows entry, its partition should be Active and unhidden and the copy's partition should be hidden.
    • For the copy's entry, its partition should be Active and unhidden and the original's partition should be hidden.
    • Don't worry if the drive letters aren't correct as long as you can set the correct partitions Active and hide the other ones.
    • Once all the menu entry settings are correct, select to either reboot or shutdown and restart the computer.
    • The computer should boot back to the OSS menu.
    • Verify all your settings are still correct.
    • Verify the boot.ini settings for the copy's partition. (Since the boot.ini file was edited before OSS was installed, it should still be how you set it.)
    • If everything looks okay, boot into the first Windows (the original). Hopefully, it will boot and run okay. You should not have a drive entry for the second partition, but will have one for the OSS partition.
    • Reboot and select to boot into the 2nd Windows (the copy). Hopefully, it will boot and run okay. The Windows drive letter should be C: and the only other drive showing should be the OSS partition.
     
  16. CalvinT

    CalvinT Registered Member

    Joined:
    Feb 7, 2007
    Posts:
    6

    Mudcrab, please see my attempt. You would also see in another post my query about not able to copy and boot into the second partition without using OSS. I keep getting "Missing Operating System"
     
  17. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    It does sound like the partitions got cross-linked by OSS. Especially since you're getting inconsistent partition settings.

    I posted in the other thread. Try Brian's method and see if it works. If you can get the system to boot correctly between the two Windows 2000 installations without using OSS, then you should be able to install OSS after that (as outlined previously) and have it (hopefully) detect them correctly. You also should not have to use "Force hiding" because the system is already setup with "normal" DD hiding. If you do this, I would recommend you create an Entire Disk Image backup before you try to install OSS. That way you can return to your working dual-Win2K setup and try again without having to start over.
     
Thread Status:
Not open for further replies.