guard.exe missing from program files

Discussion in 'ewido anti-spyware forum' started by blueoysterdvp, Jul 9, 2007.

Thread Status:
Not open for further replies.
  1. blueoysterdvp

    blueoysterdvp Registered Member

    Joined:
    Jun 26, 2006
    Posts:
    135
    Location:
    Upstate NY, U.S.A.
    As stated in 4 GB file thread,I'm missing guard.exe in my AVG AntiSpyware program files.This is a paid version.Reinstall?Could it have been missing since the 7.5.1.43 update.The properties for the guard in program files is listed for version 7.5.1.36 and was modified June 18,2007.This is also the first day the error log began this.

    6/18/2007 10:54:42 AM] Error: failed to connect to server, Value: 00000002, Position: .\Client.cpp, 26
    [6/18/2007 10:54:42 AM] Error: IPC connect to service failed, Position: .\main.cpp, 258
    [6/18/2007 10:56:54 AM] Error: failed to connect to server, Value: 00000002, Position: .\Client.cpp, 26
    [6/18/2007 10:57:10 AM] Error: [CProcessInformation]: Creating snapshot for module enumeration failed., Value: 00000008, Position: .\ProcessInformation.cpp, 274
    [6/18/2007 10:57:10 AM] Error: [CProcessInformation]: Module32First failed, Value: 00000012, Position: .\ProcessInformation.cpp, 291
    [6/18/2007 10:57:11 AM] Error: [CConnectionInformation]: Creating snapshot for module enumeration failed., Value: 00000008, Position: .\ConnectionInformation.cpp, 227
     
  2. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,293
    Location:
    England
    As you know I have guard.exe in program files, here are my error log entries for June 18th

    [18/06/2007 06:18:14] Error: [CProcessInformation]: Creating snapshot for module enumeration failed., Value: 00000008, Position: .\ProcessInformation.cpp, 274
    [18/06/2007 06:18:14] Error: [CConnectionInformation]: Creating snapshot for module enumeration failed., Value: 00000008, Position: .\ConnectionInformation.cpp, 227
    [18/06/2007 06:18:45] Error: failed to connect to server, Value: 00002741, Position: .\DownloadHttp.cpp, 265
    [18/06/2007 12:19:45] Error: failed to connect to server, Value: 00002741, Position: .\DownloadHttp.cpp, 265
     
  3. blueoysterdvp

    blueoysterdvp Registered Member

    Joined:
    Jun 26, 2006
    Posts:
    135
    Location:
    Upstate NY, U.S.A.
    also missing guard.dmp and guard.err files
     
  4. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,293
    Location:
    England
    Just had a look, I don't have those 2 eithero_O
     
  5. vinzenz.ewido

    vinzenz.ewido former ewido team

    Joined:
    Dec 9, 2005
    Posts:
    425
    Location:
    Brno, Czech Republic
    @blueoysterdvp

    Looks like there's another program which removes the guard. Reinstalling OR updating might solve the missing file.

    It would be really interessting which program removes it...

    It would be really nice if you could figure out if there's another security app which removes it while scanning

    Regards,
    Vinzenz

    PS: guard.dmp and guard.err will be created on crashes of the guard only
     
  6. blueoysterdvp

    blueoysterdvp Registered Member

    Joined:
    Jun 26, 2006
    Posts:
    135
    Location:
    Upstate NY, U.S.A.
    WindowsTask Manager is showing guard.exe in Processes with Memory Usage of 11,152k.But still no program file named guard.exe.Only other App.I use regularly is Trend Micro Security Suite 2007.CCleaner occasionally which usually picks up the old log files,ATF cleaner, CW Shredder,and SpyBlaster.

    Are the errors listed on the log related to the guard.exe?AVG is still finding and cleaning spyware which I thought was part of the guard.exe new function.
     
Thread Status:
Not open for further replies.