Giving up on Returnil

Discussion in 'sandboxing & virtualization' started by solcroft, Dec 12, 2007.

Thread Status:
Not open for further replies.
  1. solcroft

    solcroft Registered Member

    Joined:
    Jun 1, 2006
    Posts:
    1,639
    Returnil has always had this problem of protection not being turned on at startup, despite the Protection mode being set to on. Every now and then for some mysterious reason Protection mode would be set to off - I had to turn it back to on, and reboot for the option to take effect.

    This little quirk happened again today with extremely annoying results. In the middle of a malware testing run it suddenly reverted to "off" after a reboot, and being in a hurry I executed a rootkit trojan before I realized the icon was green.

    This is the last straw. I'm giving Returnil the boot for now in favor of Windows Steadystate to see how it runs. Hopefully the 2008 version will be better than this when it's released.
     
  2. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hello solcroft,
    Please check your settings for the System Protection Scheduler as this will override other preferences and your default protection mode when activated. Further, if you have also suppressed the scheduler warning messages you will not see a warning when the protection is turned off.

    Also were you using mode change to on rather than Session Lock? If you use SL, your protection mode will return to off after reboot. To keep System Protection on through a reboot, you need to change protection mode to ON and turn off the scheduler.

    If these were not the issues, please reply with more detailed information so we can reproduce this.

    Thanks
    Mike
     
Thread Status:
Not open for further replies.