GeSWall and printers

Discussion in 'other anti-malware software' started by IceCube1010, Apr 26, 2008.

Thread Status:
Not open for further replies.
  1. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    Hi Everyone

    I'm new to the forums and thought I'd ask someone with a little experience with GeSWall. How do you allow your printer to be seen and work within GeSwalls isolated browser session. I'm using version 2.7.1 freeware and really like it but I'm no expert with it. Do you need to set a trusted resource for the printer?

    thanks for any help
    Al
    AntiVir 8.0 personnal
    Threatfire
    GeSWall
     
  2. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    Is anyone using GeSWall? How would you allow the printer to be used within the isolated IE browser?

    Any help would be appreciated.

    Al
     
  3. trjam

    trjam Registered Member

    Joined:
    Aug 18, 2006
    Posts:
    9,057
    Location:
    North Carolina
    Just because the browser is isolated yiou should still be able to print. Let me pop that snapshot up and take a look.
     
  4. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    thanks trjam for getting back to me. I understand why its doing it but I'm not sure how to allow it. My printer is a Epson CX5000. Its trying to access some files in this directory: C:\Windows\System32\spool\drivers\w32x86\3 I think these have to do with the scanner portion of the printer.
    The attached file has the screen shot.

    thanks again
    Al
     

    Attached Files:

  5. Kees1958

    Kees1958 Registered Member

    Joined:
    Jul 8, 2006
    Posts:
    5,857
    I had the same problem with a HPdeskjet. I had GeSWall Pro and changed it for DefenseWall. So either buy geSWall Pro (to get support) or buy DefenseWall (ilya is real fast in giving support).

    Brian of GeSWall used to react real also fast. I am unsure how the company is doing right now, because communication is minimal. New releases are also slowed down, may Aigle knows/can shed some light on this, he still seems to have some cantact with GeSwall (and Brian).

    Regards Kees
     
  6. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    thanks Kees. I really like how easy GeSWall functions. I probably don't understand how to use add resources or maybe I need the Pro version and need to add the application the printer is calling. I would hate to buy GeSWall and find out I still have the same problem.

    Al
     
  7. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I don,t use any printer so can,t help. Try sending a mail to Brian. Someday I will write him to add this in FAQ over the web site.
     
  8. LoneWolf

    LoneWolf Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    3,408

    GesWall here with an HP printer but I have no problems like you are having.
    I can surf with an isolated browser and print without any trouble.
    Sorry I don't have an answer for you.
    Maybe if you post your problem over at GesWall's Forum someone can solve this for you.
    They are a little slow in answering there, but it might be worth a shot.

    I do know one cannot install a printer with GesWall on. The driver will be stopped.
     
    Last edited: Apr 27, 2008
  9. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I have sent an e-mail to Brian.
     
  10. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    I had a feeling this was kind of a odd ball thing. I'm sure GeSwall would have figured this one out had it been more common.

    thanks for all your help. I'll keep an eye out if they respond to the email.
     
  11. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I will suggest u to send an e-mail to them urself and to post on their forums too.
     
  12. Kees1958

    Kees1958 Registered Member

    Joined:
    Jul 8, 2006
    Posts:
    5,857
    There is a workaround for it, I had to change a setting of some named pipe. Brian responded 1,5 year ago within a day, so have a go.
     
  13. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    thanks again for the input. I'm currently on a different security path. I'm trying a different product and like it alot. I have to say, this forum is a great source of info. I'm not a security expert by no means but have learned quite a bit in the past few weeks. For everyone who responded keep up the great work!

    thanks
    Al
     
  14. omega5475

    omega5475 Registered Member

    Joined:
    Nov 27, 2007
    Posts:
    34
    Try adding this to your IE rules.

    Resource type is File and allow it.
     
  15. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    There are no files located in that directory. The files that my printer use are located in the directory I posted with the screen shot above. I tried adding those files like you said to my ie browser but that did not work. I will post this issue at GesWall. Maybe they might know whats going on.

    thanks for the suggestion
    Al
     
  16. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    How did u add those files? CAn u post screenshots?

    Also try rebooting ur PC after adding the files as allowed.
     
  17. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    Hi aigle

    I'll be at my computer tonight and post the screenshots. There are about 8 .exe files in the directory out of which 2 (I think) are being used to bring up a window with how much ink is left in the printer etc. There are .dll's also in that directory and I'm sure they are being used as well. I tried adding these files first to the add resources section. When that didn't work I tried adding them to the IE browser under the application section (add rule). I didn't try re-booting after adding these. Also looking at these sections in the console, should I have added the resources then use add rule to point to them? In any event, I'll post tonight. I also took your suggestion and posted at Geswalls forums. Hopefully we can get some answers soon and figure this out.

    thanks
    Al
     
  18. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Try adding by this way. Reboot ur PC or just stop n then restart geswall service.

    Add all the folder to have a single rule for all files in it.
     

    Attached Files:

    • 1 (1).jpg
      1 (1).jpg
      File size:
      156.5 KB
      Views:
      2
    • 1.jpg
      1.jpg
      File size:
      109.9 KB
      Views:
      1
  19. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    thanks aigle. I will try that tonight and post back. I might have tried what you showed above but I know I didn't reboot or stop/start the geswall service.

    Al
     
  20. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    Well here are the rules for the IE browser. I tried adding just the dir, the dir with the files and just the files. I rebooted after each test and still get the add printer window. Theres something missing and I can't figure it out. Geswall is having a problem with the window that is suppose to come up & show how much ink is left in the cartridges. The logs really don't show anything useful pertaining to the problem.

    Hopefully Geswall has an answer.

    Al
     

    Attached Files:

  21. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,502
    Doesn't GeSWall have a log?
     
  22. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Hi, u should add the directory without slash( \) at the end. C:\Windows\System32\spool\drivers\w32x86\3

    I mean 3 instead of 3\
     
  23. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    Thanks for all the help. I tried without the slash and the same thing. Here is the entry the log is showing:
    2008.04.30 22:11:51 iexplore.exe READONLY access to \Device\NamedPipe\lsass (File)

    Geswall has responded to my question and needed this log info. Kees mentioned he had a similar issue with a hp printer and Geswall staff had him change something with the pipe entry. I never thought to try this out with the Pro version. Maybe it could be done easier or a popup window will appear allowing the printer resource to be used within the isolated browser. Note: I only have this issue with my main printer at home that shows the ink window when printing. When I print with my laptop at work, I do not get this issue. I'm using a different printer.

    Al
     
  24. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,502
    So it's solved.
    Next time do remember, if the application has a log, check it. If it's a problem with the rules and not the program itself, the log is probably telling you exactly what's wrong.
     
  25. IceCube1010

    IceCube1010 Registered Member

    Joined:
    Apr 26, 2008
    Posts:
    963
    Location:
    Earth
    No, its not solved. I'm still not clear how to create the rules to allow my ink cartridge window from appearing within Geswalls isolated IE browser session. Sorry if I didn't make that clear in the above post. As you probably can tell, I'm not a security expert so that particular log entry didn't help me. I'm still waiting for Geswall to respond with any info.

    thanks
    Al
     
Loading...
Thread Status:
Not open for further replies.