Foxit Reader & Sandboxie

Discussion in 'sandboxing & virtualization' started by TonyW, Apr 25, 2011.

Thread Status:
Not open for further replies.
  1. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    As a test, I've put Foxit Reader under Program Start/Forced Programs, but whenever I open a .pdf document I get the following message:

    foxitlil.jpg

    What should be enabled to prevent this from showing up?
     
  2. blasev

    blasev Registered Member

    Joined:
    Oct 25, 2010
    Posts:
    763
    u can try to have lower integrity outside sandboxie
    I assume u use windows XP , so u can use dropmyrights.

    when trying dropmyright, don't forget run outside sandboxie for a while ..
    so when the message show up again , just click don't show this again
    the pop up should be gone by then

    or...

    u can simply turn off "drop rights" on sandboxie
     
  3. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I am using Windows XP, and I have now disabled Drop Rights in Sandboxie settings. However, the low integrity level warning still shows up. If I click OK and leave a tick to not show this again, another message keeps appearing one after the other no matter how many times I click OK. I eventually terminate the program via Sandboxie.
     
  4. doktornotor

    doktornotor Registered Member

    Joined:
    Jul 19, 2008
    Posts:
    2,047
    Would suggest reporting the issue to Foxit vendor. (The application is pretty much junk, TBH.)
     
  5. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    Does this warning not occur with other .pdf readers then? I ditched Adobe Reader a long time ago as it was getting too big for its boots so I've no idea if sandboxing that produces the same results or it's just Foxit Reader.
     
  6. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    5,828
    Location:
    Last Breath Farm
    TonyW, I run XP on 2 computers, both with Sandboxie and FoxitReader, and do not experience this issue that you have described.

    In addition to having Foxit Reader.exe listed in Forced Programs, also under Restrictions, I have Foxit Reader.exe given both Internet Access and Start/Run Access, plus I do have DropRights enabled.
     
  7. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    Thank you for the additional info. I have re-enabled Drop Rights, and added foxitreader.exe to the Internet Access and Start/Run restrictions area. Unfortunately, I'm still getting the message I'm in the low integrity level mode.

    I've never configured Sandboxie to this level before so this is new territory for me so forgive me as I embark on this learning curve. :)
     
  8. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    5,828
    Location:
    Last Breath Farm
    I see in the SBIE forum that there are issues with FireFox and FoxitReader and Sandboxie. Are you running Firefox?
     
  9. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I am running Firefox, but I was trying to open a .pdf document outside of that, not from within it. In other words, opening a .pdf document already stored on my computer. Even running the Foxit Reader executable on its own, sandboxed, generates the low integrity level warning.

    I have seen there are issues with the Firefox plugin, but I haven't ventured that far yet. I have been searching for some possible answers as well.
     
  10. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    5,828
    Location:
    Last Breath Farm
    I mentioned in PM the way the executable is entered (with a space), and I just read the following on the SBIE forum, from a guy asking How to force-sandbox the "Foxit Reader"?...
    :doubt: Foxit Reader.exe works perfect for me.
     
  11. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    5,828
    Location:
    Last Breath Farm
    Another random thought, perhaps grasping at straws?
    What version of FoxitReader are you running?
    Do you have the most current version?
    4.3.1.0218
    If not, try installing the latest and see if it changes anything.
     
  12. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    Just tried FOXITR~1.EXE on its own, but doesn't work due to restrictions. How weird this all is, especially as it works for you. I only wanted to see if I could get my .pdf reader sandboxed.
     
  13. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    5,828
    Location:
    Last Breath Farm
    Did you see this solution in the forums...
    I doubt this is for XP Home... maybe XP Pro or another OS... since I don't see Privilege Level under Compatibility on my system (XP Home). But it worked for this user.
     
  14. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I had version 4.3.1.0118, but have upgraded to the latest, which incidentally is 4.3.1.0323. Hasn't made any difference though.

    I may try another free .pdf reader tomorrow to see if there's any difference to how things run.

    Thanks for your suggestions - much appreciated. :)
     
  15. Page42

    Page42 Registered Member

    Joined:
    Jun 18, 2007
    Posts:
    5,828
    Location:
    Last Breath Farm
    I just checked via FoxitReader for available updates prior to posting... so maybe it's real new and hasn't hit all the servers yet? Appreciate the news.
    Sorry I could not help you with your problem.
    I will be very interested in learning what you discover to fix this.
     
  16. mick92z

    mick92z Registered Member

    Joined:
    Apr 27, 2007
    Posts:
    499
    Location:
    Nottingham
    Just to say, I am using Sandboxie 3.50, Foxit 4.31.0323 on an XP machine.
    I am having no problems at all
    I have used many previous versions on Foxit and S.B together.I did have a problem a couple of years ago, which disabling the plug-in solved
    I have always had foxit reader.exe forced. I have tried disabling the plug-in, turning off/on drop rights. I can not produce any problems. Your problem seems unique.
    What version of S.B are you using ?
     
  17. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    An update: I've just tried SumatraPDF 1.5.1 and added it to the relevant places in Sandboxie as well as making it the default .pdf viewer. The result is any .pdf document I open is sandboxed with no warning messages. I haven't tried opening a .pdf document via Firefox yet though.

    @mick92z: I'm using Sandboxie 3.54.
     
  18. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I've just downloaded a .pdf document via Firefox and instructed it to open with SumatraPDF [Foxit is still installed so it gave me that option first.] It was sandboxed with no warning messages.
     
  19. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    3,770
    Location:
    Nicaragua
    Hey Tony, I also use Foxit and have no problems at all. I have it set
    pretty much like Page and, like you, don't use the plugin.
    If you have not tried opening Foxit on a default settings sandbox,
    maybe you should create one and do so to see what happens.

    Bo
     
  20. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I've tried various configurations, including disabling the FF plugin, but I still get the low integrity level warning message. For now, I'm going to use the SumatraPDF reader. Thanks for all your comments. :)
     
  21. PJC

    PJC Very Frequent Poster

    Joined:
    Feb 17, 2010
    Posts:
    2,959
    Location:
    Internet
    Smart ;) decision! :thumb:
     
Loading...
Thread Status:
Not open for further replies.