Firewall blocking Internet Access! Help! NOT in Automatic Mode.

Discussion in 'ESET Smart Security' started by BlindSight, Feb 16, 2008.

Thread Status:
Not open for further replies.
  1. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9
    Ok, so up until now, my internet was working fine. The firewall was doing its job and everything was fine and dandy. But I guess I must have some how made a deny rule for something unkown at one point. And now I have to turn off my firewall to access and browse the internet. I have ESS 3.0.621 retail home edition.

    I tried the following:

    Going to "Detailed Rules" View and hitting delete on every rule.
    Pressing Default button and reseting everything to default.


    Still no luck. I'm stuck and I want to fix this without uninstalling it and reinstalling, but if that is the only way I'll do it. Thanks!:(
     
  2. proactivelover

    proactivelover Registered Member

    Joined:
    Apr 7, 2006
    Posts:
    840
    Location:
    Near Wilders Forums
    please allow these
     

    Attached Files:

    • sds.jpg
      sds.jpg
      File size:
      17.4 KB
      Views:
      466
  3. kringles

    kringles Registered Member

    Joined:
    Aug 5, 2005
    Posts:
    52
    Try reading this thread;

    https://www.wilderssecurity.com/showthread.php?t=196118

    in particular note in post #6 I had a similar problem (all outgoing communication blocked in Interactive mode) after responding 'deny and remember' to an unusual popup.

    regards

    report any problems found directly to Eset
     
  4. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9
    All those seem to be checked already and I'm very noobish on networking. I understand more than the average user as far as computers go, but networking for me is a no no.


    The problem still remains, any ideas?
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Enable logging of all blocked connections in the IDS section of the firewall setup, attempt to browse with IE and then check the firewall log for details about the blocked connection attempts.
     
  6. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9

    Tried that as well, nothing is logging. :(
     
  7. proactivelover

    proactivelover Registered Member

    Joined:
    Apr 7, 2006
    Posts:
    840
    Location:
    Near Wilders Forums
    what is your OS
    1.WINXP SP2 OR SP3RC1,2
    2.WINVISTA
    and your network connection dialup,lan or els
     
  8. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9

    Running XP SP2 with 6 MBPS Cable. Wired router setup with Netgear router and 4 computers attached.
     
  9. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9
    This really is quite aggravating. I really do love ESET software, but this is a bit too much. And the fact that I can't find the rule that's blocking communication will end up forcing me to uninstall and downgrade to NOD32 until the issue at hand is dealt with.
     
  10. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    Blindsight, could you click on the ESS icon in the system tray and select "Show Network Connections" and advise what connections are showing. Preferably do this after opening your web browser and/or email program. There should be some instances of svchost.exe as well as your browser and email program.
     
  11. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    In automatic mode all outbound traffic is allowed so it's really odd that you can't connect in AM. If you switch to interactive mode, do you get a prompt window when attempting to open a website in your browser?
     
  12. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9
    Actually I'm running in interactive mode, I haven't even touched auto before. But no prompt, just a "page could not be displayed" type message. My AIM also shuts off and as does firefox. Seems all inbound or outbound connections seem blocked, strange really.
     
  13. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Could you confirm or deny that it works in automatic mode?
     
  14. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9
    Confirmed not working in auto mode as well. The only way I can get it working is to disable the firewall :\
     
  15. rwt325

    rwt325 Registered Member

    Joined:
    Jul 28, 2005
    Posts:
    101
    Location:
    Strasburg VA
    When all else fails, uninstall the ESS, manually remove the remnants from the registry and re-install ESS clean. Try in automatic mode first.

    I found this helps often when software does not work properly for some unexplainable reason. It could be corrupted. Had a similar problem with the Kaspersky suite some years ago and that proved to be a solution.
     
  16. MenaWSF

    MenaWSF Registered Member

    Joined:
    Feb 20, 2008
    Posts:
    7
    after switching to interactive mode and set a rule for utorrent if i switch to automatic mode, Will that override the rule for utorrent?

    i didn't want to start a new thread so I'm sorry for any disturbing

    thanks
     
  17. BlindSight

    BlindSight Registered Member

    Joined:
    Feb 16, 2008
    Posts:
    9
    It's fine I don't get mad for most people :p

    And to answer your question, I believe the answer is no it won't but I could be wrong as I have never used auto mode. Though I don't see why it would do that.

    Any further input as far as my problem goes? I still have the problem; I know I could just uninstall and reinstall, but I'm the kind of guy that likes to solve a problem from the souce, not just apply a quick fix :p
     
  18. MenaWSF

    MenaWSF Registered Member

    Joined:
    Feb 20, 2008
    Posts:
    7
    ok thanks :)
     
Thread Status:
Not open for further replies.