Firewall and Office 2010

Discussion in 'ESET Smart Security' started by matkus, Jun 15, 2010.

Thread Status:
Not open for further replies.
  1. matkus

    matkus Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    2
    Hello.

    I'm using Eset Smart Security as firewall, and i have it configured to ask me every time new program tries to use internet.
    Lately i've installed MS Office 2010 beta. It uses some virtualization creating new disk Q. Now some program from that disk tries to access internet, and so NOD is asking me for permission. If i click "remember my decision" and click "allow", it will ask me again in few seconds, and again, and again, for same program. NOD simply does not remember my decision.
    But if i click "remember..." and "deny", it will not ask any more, at least until i run Office again next day.

    Any way to overpass this and allow Office to use internet?
     
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    it sounds like a bug if it can't remember your choices possible because the Application Virtualisation (App-V). Office 2010 is on sale now so not sure if Eset will fix it (assuming it is a bug) for beta but maybe possible fix for final version will work for beta too.

    did you try other FW modes like learning or automatic
     
    Last edited: Jun 15, 2010
  3. spalek83

    spalek83 Registered Member

    Joined:
    Jun 12, 2010
    Posts:
    8
    I had that bug, and it drove me to uninstall the beta, as I could find no fix... and it drove me insane

    Good luck
     
  4. JesusV

    JesusV Former ESET Support Rep

    Joined:
    Jan 21, 2010
    Posts:
    93
    What version of ESS do you have installed and what version of Windows do you have? You can create rules for the actual ms executables trying to achieve the connection.
     
  5. pbmcmlxxi

    pbmcmlxxi Registered Member

    Joined:
    Oct 28, 2006
    Posts:
    131
    Location:
    Hants, UK
    Possibly also worth at this stage of the day un-installing the beta and installing either the final retail or final trial version.
     
  6. matkus

    matkus Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    2
    I have win 7 x64 and latest non-beta ESS (4.2.something)
    Here's my theory why this happens.
    When you set rule for application, Eset saves some information about executable file. This way when it is modified, it shows dialog about it. But you can't access to virtual created by office using any file manager, and i think Eset can't access it too. This way it can't create rule, and so it does not store it.

    I have no idea how it is with final version of Office, it is still not available in Poland, and even if it will be, i will not buy probably, but since Office is quite popular application, i hope guys from Eset will do something about it.
     
  7. nickynic

    nickynic Registered Member

    Joined:
    Jul 6, 2010
    Posts:
    1
    Hi.
    I stumbled onto this thread trying to find a solution for my problem.
    XP SP3 and an antique firewall that I hold dearly. It's not as old as AtGuard (that I loved) but still... It's Sygate.
    When the firewall is off, I can send emails.
    When it's on I can't. I can receive and do everything I need, but I just can not send emails.

    The Office 2010 suite is a new one for me in the sense that I don't have any separate applications anymore. All is channeled through the big Office port and comes out with different names, but it's the same big application as far as I can tell.

    Am I missing something? I would love to hear about it.
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    If it's actually the firewall which is preventing Outlook from sending emails, enable logging blocked connections in the IDS section of the firewall setup, reproduce the problem and then check the firewall log for details about the rule that blocked the communication. You can subsequently adjust or disable this rule completely, if appropriate.
     
Thread Status:
Not open for further replies.