FireFox, Opera, XP

Discussion in 'other software & services' started by crockett, Oct 16, 2004.

Thread Status:
Not open for further replies.
  1. crockett

    crockett Registered Member

    Joined:
    Jul 15, 2002
    Posts:
    333
    Hi guys and girls ;)

    Hope everyone is doing fine...

    Since I just got a brand new pc, I just switched from W98SE toXP (which, that's no surprise, was installed by default on the accompanying cdrom). I decided to give XP a try...

    Surprise, my Opera browser which did so well and fast on 98SE is extremely slow and cpu consuming on XP... Never managed to figure out why this might be... Any clue?

    So I went and saw where FireFox (which did not do particularly well on 98SE) was at... It was a nice surprise, 'cause I must admit it is a browser I now like very much.

    Rgds, Crockett :cool:
     
  2. crockett

    crockett Registered Member

    Joined:
    Jul 15, 2002
    Posts:
    333
    Then I went to http://www.leader.ru/secure/who.html to see how FF would perform. I manually changed the sendreferrer value from 2 to 0 so as to not send any referrer, but the two informations shown below were disclosed by FF...

    First, the number of visited sites during the session...
     

    Attached Files:

  3. crockett

    crockett Registered Member

    Joined:
    Jul 15, 2002
    Posts:
    333
    ... and also the version of FF I used for the test...

    Can anyone tell me how to tweak FF to remedy these two (small) poroblems ?!

    Thanks, rgds, Crockett :cool:
     

    Attached Files:

  4. Meltdown

    Meltdown Registered Member

    Joined:
    Sep 17, 2004
    Posts:
    299
    Location:
    Babylon
    I don't think you can tweak FF for that, but you can use Proxomitron with the JakxPack II filters to block info on the referrer, and to spoof your OS and browser.

    The information in the picture below is all spoofed ;) The only thing it got right is the reported remote address, which I've left out of the screenshot.
     

    Attached Files:

  5. Meltdown

    Meltdown Registered Member

    Joined:
    Sep 17, 2004
    Posts:
    299
    Location:
    Babylon
    I have Javascript enabled, but with Proxomitron all they could find out was this:
     

    Attached Files:

  6. Firefox guy

    Firefox guy Guest

    Hey Crockett, Proxomitron is great of course, and can do lots of stuff, but if you don't want to use it, you can use this extension

    http://www.chrispederick.com/work/firefox/useragentswitcher/

    Actually, you don't even need that, but, the extension is easiest.

    As for referrer, I set mine to say 5 :) . Blocking all referrers is fine and dandy but breaks some sites.



    NOTES FOR THE REFERRER FEATURE (TAKEN FROM THE MODIFIED ALL.JS SOURCECODE):
    ------------------------------------------------------------------------------
    pref("network.http.sendRefererHeader", 2);

    // Controls how and when the referrer header will be sent:
    // 0 - Never send the referrer.
    // 1 - Send the actual referrer only for user initiated actions.
    // 2 - Send for actual referrer for both user initiated actions and inline
    // content.
    // 3 - Not currently used.
    // 4 - Send the actual referrer, only to the same home. Send nothing to 3rd
    // parties.
    // 5 - Send the actual referrer to the same host. Send the modified
    // referrer (base URL only) to 3rd parties.
    // 6 - Send the actual referrer to all hosts, but strip off the path for 3rd
    // party requests.
    // 7 - Always send the modified referrer.
     
  7. crockett

    crockett Registered Member

    Joined:
    Jul 15, 2002
    Posts:
    333
    Hi FireFox Guy :)
    Just tried it... Very nice.

    Thank you very much. Please, feel free to share your expertise regarding FF anytime you may feel like it!

    Rgds, Crockett :cool:
     
  8. crockett

    crockett Registered Member

    Joined:
    Jul 15, 2002
    Posts:
    333
    Thanks a lot Meltdown;

    Proxo still unbeatable, ain't it ;)

    Rgds, Crockett :cool:
     
Loading...
Thread Status:
Not open for further replies.