Firefox and Thunderbird spell check fail

Discussion in 'other software & services' started by Blackspear, Apr 4, 2007.

Thread Status:
Not open for further replies.
  1. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Fresh install of Windows XP Pro, fully up to date plus the following software:

    NOD32 v2.7
    MS Office 2003
    Skype 3.1
    Messenger 8.1
    Logitech Setpoint 3.30

    The normal spell check with Firefox when typing in this forum or on the internet fails, nothing is underlined.

    Thunderbird has everything underlined in RED, and right clicking on it has no options available in the menu of the dictionary.

    Fonts are missing in the signature of my reply to emails. The signature uses MS Word saved as a HTM file.

    Fonts are missing when I copy and paste from MS Word into the body of the email.

    The font that I use all the time is Staccato222 BT and it is one that is missing when I open up MS Word, yet if I open a document that already has this font, it opens up perfectly, though in the fonts drop down menu it is not in there, nor is it in the Control Panel> Fonts list.

    I have uninstalled and reinstalled without success, as well as placed a fresh copy of Windows back on through imaging and started again.

    Suggestions please.

    Cheers :D
     
  2. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Adding the missing font into the Windows Control Panel> Fonts fixed one of the Thunderbird issues, now just the missing spell check feature that Firefox uses, and the haywire spell check that Thunderbird uses, both I think may be related to Windows.

    A SFC /scannow has not resolved the issue.

    Cheers :D
     
  3. lucas1985

    lucas1985 Retired Moderator

    Joined:
    Nov 9, 2006
    Posts:
    4,047
    Location:
    France, May 1968
    I would try repairing both Firefox and Thunderbird from a freshly downloaded installer.
     
  4. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    I have tried that, aslo tried deleting the profile, tried it in Thunderbird "Safe Mode" which doesn't load any extensions, nothing works :mad:

    Cheers :D
     
    Last edited: Apr 5, 2007
  5. lucas1985

    lucas1985 Retired Moderator

    Joined:
    Nov 9, 2006
    Posts:
    4,047
    Location:
    France, May 1968
    If your images (have their checksums been verified?) are in good shape, I would start thinking in a possible hardware failure.
     
  6. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Just discovered the Thunderbird dictionary wasn't installed, even though it said it was, reinstalled it and added the Australian one, and now it is working fine.

    Still working on Firefox, so no doubt it has to do with it's own dictionary as well as spell check.

    Cheers :D
     
  7. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    And finally figured it out, dictionary missing from Firefox, installed the En-US one and spell check is back.

    So it simply ended up being missing dictionaries.

    Cheers :D
     
  8. lucas1985

    lucas1985 Retired Moderator

    Joined:
    Nov 9, 2006
    Posts:
    4,047
    Location:
    France, May 1968
    Glad you sorted it out ;)
    Don't forget to make an image with the dictionaries installed :D
     
  9. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Have done, what a nightmare tracking it down :mad:

    Cheers :D
     
Loading...
Thread Status:
Not open for further replies.