Firefox, addon opening webpage

Discussion in 'other software & services' started by deugniet, Feb 12, 2014.

Thread Status:
Not open for further replies.
  1. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    580
    I dont want Firefox to open a webpage after installing an addon. How to do that? Noscript has a feature to disable this (Display release notes...).
     
    Last edited: Feb 12, 2014
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    I don't think you can prevent this universally. You just have to live with it, avoid addons that do this, or change the individual settings for addons that do this (if they even let you disable it).
     
  3. TheWindBringeth

    TheWindBringeth Registered Member

    Joined:
    Feb 29, 2012
    Posts:
    2,089
    Some ideas, assuming you are referring to a specific extension doing this...

    - By examining the source and/or searching about:config, look for a preference that would turn off the page load.
    - Ask the developer to include this ability.
    - Privately, or publicly, fork the source and eliminate this behavior
    - By examining source and/or searching about:config, try to locate a preference that specifies the URL of the page that is being loaded. Depending on how things are coded, setting that to a blank string and/or setting it to something like [noparse]https://localhost:14/[/noparse] may prevent the page load.
    - Using another extension and/or browser-external blocking mechanism (hosts files being one example), block the URL or host to prevent the page load.
     
  4. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    580
    Thanks for info. I could use the addon Leechblock and temporarily block a website. But better would be changing something in about:config. Don't think this is possible.
     
  5. Rainwalker

    Rainwalker Registered Member

    Joined:
    May 18, 2003
    Posts:
    2,106
    Location:
    USA
    I have blocked NoScript at firewall as every time Firefox opens NoScript attempts to connect to the NS site. It does not open page only attempts to connect to their server. I have FF set to not check for any updates at all, but.... FF v. 27.0
     
Loading...
Thread Status:
Not open for further replies.