Firefox 4 - Compatibility Issues

Discussion in 'other anti-malware software' started by hawki, Mar 27, 2011.

Thread Status:
Not open for further replies.
  1. hawki

    hawki Registered Member

    Joined:
    Dec 17, 2008
    Posts:
    1,954
    Location:
    DC Metro Area
    Symantec products currently have two major compatibility issues with Firefox 4 (Norton Toolbar and Identity Safe). Symantec states that these issues will not be resolved until May.

    I would like to know what other major security products are having similar issues and which ones are currently fully compatibile and fully functioning with Firefox 4.
     
  2. Huwge

    Huwge Registered Member

    Joined:
    Oct 21, 2004
    Posts:
    405
    Location:
    UK
    I know that the current Keyscrambler isnt working properly with FF4. It does not automatically start on loading FF even though the icon appears it does not 'turn green' and offer protection until clicked on
     
  3. Securon

    Securon Registered Member

    Joined:
    Jan 11, 2009
    Posts:
    1,935
    Location:
    London On
    Good Morning ! I e-mailed Prevx support after noticing Prevx 3.0 with Safe-On Line wasn't available with Firefox 4.0,and Prevx support replied that they're working on a compatible update but it won't be available for a couple of weeks,and they advised me to use I.E.9. It also is available on Google Chrome which I also use. So use Firefox 4 accordingly. Sincerely...Securon
     
  4. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
  5. doktornotor

    doktornotor Registered Member

    Joined:
    Jul 19, 2008
    Posts:
    2,047
    The Premium version works fine w/ FF4. :)
     
  6. Huwge

    Huwge Registered Member

    Joined:
    Oct 21, 2004
    Posts:
    405
    Location:
    UK

    I was referring to the free version. Seems strange that the free doesnt work properly but the paid one does. They should be the same for FF from what I can see (version 2.7.1.0)
     
  7. doktornotor

    doktornotor Registered Member

    Joined:
    Jul 19, 2008
    Posts:
    2,047
    Not really, AFAICT the free thing is some kind of browser add-on only. Pro/Premium is kernel-level stuff.
     
  8. lws

    lws Registered Member

    Joined:
    Aug 28, 2009
    Posts:
    196
    Keyscrambler free 2.7.1.0 is working ok here with FF4 in the Buffer Zone or out. Prevx SOL though doesn't seem to work with FF4.
     
  9. TheKid7

    TheKid7 Registered Member

    Joined:
    Jul 22, 2006
    Posts:
    3,469
  10. pegr

    pegr Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    2,279
    Location:
    UK
    That seems to be contradicted by the Firefox 4 support? thread where the Prevx forum moderator is saying that Prevx 3.0 with SafeOnline won't be updated to support Firefox 4.0, as all of the development effort is going into the forthcoming Prevx 4.0 public beta which will support Firefox 4.
     
  11. Mongol

    Mongol Registered Member

    Joined:
    Jul 24, 2004
    Posts:
    1,581
    Location:
    Houston, TX
    Yep they are recommending staying with Firefox 3 til the Prevx 4 release. This could be a while between the Prevx 4 Beta and final release. Especially for those who don't like playing with Beta's...:doubt: :cautious: :)
     
  12. carat

    carat Guest

    Norton Safe Web doesn't work as well - but you can use Norton DNS :)
     
  13. Huwge

    Huwge Registered Member

    Joined:
    Oct 21, 2004
    Posts:
    405
    Location:
    UK

    There are issues, as per this

    http://support.mozilla.com/my/questions/797951
     
  14. Triple Helix

    Triple Helix Webroot Product Advisor

    Joined:
    Nov 20, 2004
    Posts:
    12,011
    Location:
    Ontario, Canada
    Partial Quote!

    So the Beta will be very stable! And for one's that want to TRY the full version they will with the Prevx 4 beta!

    TH
     
  15. lws

    lws Registered Member

    Joined:
    Aug 28, 2009
    Posts:
    196
    I'm not saying that there aren't issues with KS free and FF4 that some people may be having. I'm saying that keyscrambler free is working ok for "me, on my system" with FF4.
     
  16. blasev

    blasev Registered Member

    Joined:
    Oct 25, 2010
    Posts:
    763
    Key scramble free + FF 4 work just fine on my system
    W7 64bit...
    Only one tiny minor glitch : the KS tray icon sometimes is still there even though the prgram itself is already closed
     
  17. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    G-Data CloudSecurity doesn't currently work on Firefox 4.
     
  18. SAW

    SAW Registered Member

    Joined:
    Oct 25, 2009
    Posts:
    48
    Trusteer Rapport has been updated and the update supports Firefox 4
     
  19. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,121
    Location:
    USA
    I much prefer LastPass to Norton Identity Safe and it is compatible with Firefox 4.
     
  20. pegr

    pegr Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    2,279
    Location:
    UK
    Yes, you are right; it does. Emerald Build 1008.29 of Trusteer Rapport now supports Firefox 4. :)

    Just for info, the latest Sandboxie 3.54 doesn't work with Rapport, and Firefox can't be opened sandboxed with Rapport running. I reverted to Sandboxie 3.52 which is compatible with the latest Rapport update. This issue has already been raised (not by me) at the Sandboxie forum.
     
  21. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Back to the newly released (about more than a year ago) of Prevx 4 beta. Firefox 4 was released in beta form for months, before it final release. Those companies who have still not yet adapted to Firefox 4, can only make feeble excuses.
     
  22. Sherlock_Holmes

    Sherlock_Holmes Registered Member

    Joined:
    Mar 21, 2010
    Posts:
    1,447
    Location:
    Mumbai
    exactly :thumb:
     
  23. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Thanks!

    Most of the software developers supported the Firefox 4 in it's beta form, such as Sticky Password and IARoboForm. Password Depot didn't, but as soon as Firefox 4 was released, Password Depot came out with the support.
     
  24. karad

    karad Registered Member

    Joined:
    Sep 10, 2008
    Posts:
    237
    I installed FF4 yesterday-which i am very happy about,but the only problem was with Password Depot : one small warning window before opening the browser and one after,when closing down, which ,at the moment, i cannot show the content of, but i simply removed PD from startup and disabled the extension in Firefox4. (it happened both in Admin&Ltd Accounts,Win7-64)
    This does not impair PD working ok and i would probably have done that anyway,as i prefer to keep FF as lean as possible with very few addons.

    At any rate, I'd like to know from KingOfRapture if he can point me to the PD Support in question- IF the move regards the FREE PD- as its certainly better to run all programs perfectly efficient.
     
  25. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    You need to downlaod the lastest version of PD, which was released few days ago. First un-install the old version, making sure the FF addon is un-installed too. Then install the latest version with the FF addon. The latest version is 5.3.0
     
Thread Status:
Not open for further replies.