Firefox 2 delayed till October

Discussion in 'other software & services' started by Legendkiller, Aug 18, 2006.

Thread Status:
Not open for further replies.
  1. Legendkiller

    Legendkiller Registered Member

    Joined:
    Jun 29, 2006
    Posts:
    1,052
    Mozilla has today delayed the release of the open source Firefox 2.0 browser until the 24th of October. The browser was supposed to be ready on 15 August. A second beta is now scheduled for 23 August. Some of the browser bugs which programmers are still working on involve visual refresh, tab overflow, spell check and security features. Firefox 2.0 Beta 1 for developers is currently available for free download.

    The new browser includes phishing protection to prevent users being fooled by fake websites, the ability to re-open tabs that have been closed by accident and better support for RSS feeds. Bookmarks will now feature micro-summaries to provide a quick précis of frequently changing web pages, enabling users to see which pages have been updated.
    Source:http://neowin.net/index.php?act=view&id=34650
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    NOOOO!!!

    now i have to wait longer til developers update their extensions/themes for 2.0 compatibility.

    o well at least a second beta will allow for more bug hunting before final.
     
  3. lodore

    lodore Registered Member

    Joined:
    Jun 22, 2006
    Posts:
    9,007
    ahhhhhhhhhhhhhhhhhhhhhhhh. i was llooking forward to that
     
  4. A1SteakSauce

    A1SteakSauce Registered Member

    Joined:
    Jul 25, 2006
    Posts:
    88
    Aw man... too bad. Oh well I'll wait for the 2nd beta. 5 Days. In the meantime, time for beta 1!
     
  5. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    https://addons.mozilla.org/firefox/958/ ;)

    Cheers,

    Alphalutra1
     
  6. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    yea, MR Tech Local Install was able to make most extensions i use compatible with beta 1. themes are another issue.
     
  7. TheQuest

    TheQuest Registered Member

    Joined:
    Jun 9, 2003
    Posts:
    2,301
    Location:
    Kent. UK by the sea
    Hi, WSFuser

    No need, just change the MaxVersion Number in them to meet the version Number in [or make it higher, I have all mine set to 1.8 for a long time now] Firefox.

    Take Care,
    TheQuest :cool:
     
  8. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    yea i know. themes are the real problem tho. i shouldnt have included extensions in my statement.
     
  9. Legendkiller

    Legendkiller Registered Member

    Joined:
    Jun 29, 2006
    Posts:
    1,052
    in my view quite a few themes and extensions have been made compatible till 3.0a1...like flashgot/roboform till 2.0b1/adblock plus...
     
  10. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    ok thats extensions. what about themes?

    btw, sry if im going too OT.
     
Loading...
Thread Status:
Not open for further replies.