Failing PC and Resulting Encryption Troubles

Discussion in 'encryption problems' started by Alexdr, May 15, 2017.

  1. Alexdr

    Alexdr Registered Member

    Joined:
    May 15, 2017
    Posts:
    1
    Location:
    U.S.A.
    I just wanted to post this thread in hopes someone would have some guidance. Last week, my laptop of a few years had its battery die. I.e., I woke up, went to the laptop and found it to be off. It wouldn't turn on except when I took out the battery and kept it plugged in with the AC adapter.
    Later that day, I shutdown the computer--at this point I'm just speculating--and then, I think, I pulled out the power cable too soon (I was packing up the laptop) such that it had an unexpected shut off (especially since no battery) while doing Windows shutdown processes.
    As a result, when I turned my laptop back on (with AC adapter connected), I went through the TrueCrypt screen to put in my password and then got stuck in a BSOD loop. It's the one that occurs after starting Windows and says "UNMOUNTABLE_BOOT_VOLUME". At this point, I though, OK, use recovery tools.
    I proceeded to tap F8 after typing in my TC password and got to the recovery screen. I ran the recovery screens "try to fix things" command, rebooted, didn't fix it. I then, from the CMD in the recovery module, ran diskpart to see what was up. I found my drive was now labeled as RAW (not NTFS). At this point, I felt that I probably ruined something in the boot sector. I proceeded to run bootrec /fixboot. I rebooted, that didn't fix anything (surprisingly it still worked if I remembered correctly, i.e. it was the BSOD that killed me). I then went back into recovery tools, ran bootrec /fixboot and then bootrec /fixmbr and then rebooted. This is where things went bad. I would turn on the computer and wouldn't even get the TC password prompt.
    My default thought was that, in fixing the MBR I overwrote something related to the TC header or the Windows header. I proceeded to get my TC Rescue disk. Instead of trying to regain the TC or System header from the TC rescue disk, I immediately ran "Decrypt everything". It was going pretty quick (supposedly only one day to decrypt), however, upon awaking the next day, I found it stopped asking "Read error: 16 bad drive 0: sector 12652XXXXXXX" skip all bad blocks? (y/n). I first typed "N", after all, I thought "even if they're bad blocks, just try and decrypt them, I don't want to miss anything". However, this stopped the decryption process. I pressed to decrypt the whole thing again and, luckly, it seemed to continue from where I left off asking me the (y/n) question again. This time, I pressed y. At this point the decrypt speed went from 10.XX MB/s to 2.27 MB/s (I hope this doesn't mean it's throwing away everything because it thinks everything is a bad sector). Now the waiting time will be for another 40 hours.
    After it finishes decrypting, I plan to run windows repair using a physical disk and run bootrec /fixboot andbootrec /fixmbr again. If this doesn't fix it, I heard about testdisk and will see if that can be used.
    If worst comes to worst, I'll image my thing with Acronis, move it onto a 3 TB harddrive and wait until I'm more capable of messing with it.
    Note, my laptop is itself a 1TB drive. I believe there are only two partitions, the recovery and the main (i.e. the main partition is also the boot partition). I will also note that, after saying (Y) to the skip bad sectors (it could've happened before but I was asleep), after a few hours it hung on a certain Remaining number of MB. It hung for a long while (I want to say an hour). It did continue after that (the speed went up from 2.27 MB/s to 2.29 MB/s) and has continued to run. I don't know what it means to hang for a long time on a certain number of MB remaining.
    Thank you for any guidance you can provide me. I've tried to do some degree of research.
     
Loading...