Failed install with RVS 2010 and 2008

Discussion in 'General Returnil discussions' started by DennisD, Oct 3, 2009.

Thread Status:
Not open for further replies.
  1. DennisD

    DennisD Registered Member

    Joined:
    Oct 3, 2009
    Posts:
    5
    I haven't searched the forum for this problem as I've a feeling it was self induced, and therefore maybe unique to my computer.

    I've used "Returnil Home" for a long time now with not a single hiccup, until tonight.

    I downloaded the 2010 version from Softpedia and then uninstalled my 2008 version and rebooted.

    After installing the 2010 version I rebooted again, and BSOD'd on reboot. After booting again successfully an info window popped up with this message:

    "RVS core system is not available".

    To cut a long story short I couldn't uninstall again properly, the same message popped up when trying to uninstall, so went to safe mode, did partial uninstall, and ended up manually removing remaining items from Program Files, Windows, and System 32. I then ran Reg Mechanic and CCleaner "Issues" which did take out what seemed to be all or most of the dead Returnil entries.

    I then tried installing my old version again, 2008 (2.0.1.9002), and got exactly the same problem.

    By now I had a suspicion as to what might be causing this problem, so I removed two reg entries I had recently installed. These are "prevent hung shutdown" reg tweaks, and by gum they do work well. My shutdowns are pretty quick.

    Auto kill hung Programs/Services during Windows shutdown:

    I also have UPHCleanup installed, but have had no noticeable conflict between the two, and UPHCleanup has never caused an issue with Returnil.

    I then removed the two reg entries, rebooted and tried to install my old fav, RVS 2008.

    Installed perfectly, and runs perfectly as before.

    Could the issue I experienced be caused by this reg tweak making my system close down too quickly during the Returnil Install and Reboot? Or could it have made no difference, and there may be an issue with the new 2010 version?

    Sorry about this turning into a mini novel, but I didn't want to miss anything out which may be relevant. We have an active Returnil thread going on another forum, and I'm trying to find the cause of this so I don't steer other members into the BSOD etc I've just experienced.

    Thanks in advance for any advice and comments.
     
  2. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hello DennisD and welcome to the forums :)

    Are you using Microsoft Security Essentials? If you are, deactivate RVS Virus Guard real-time protection as having it active with MSE installed will cause a BSOD. A report has been filed with the development team regarding this issue.

    Mike
     
  3. DennisD

    DennisD Registered Member

    Joined:
    Oct 3, 2009
    Posts:
    5
    Hi Mike.

    Nope, I'm not using Microsoft Security Essentials, and I don't have RVS Virus Guard, which I believe is a new feature with Returnil 2010, which wouldn't install.

    I use Avast Home, Windows Firewall, and Sandboxie when online, although this was not active when I tried to install the new Returnil 2010 version.

    Removing the quick shutdown reg tweak was the only thing I changed to get Returnil 2008 to reinstall OK, and of course I'm loathe to try the new version again until I can find out why I got the BSOD.

    I've ran and updated Returnil with no problems since it first came out, and this is the first issue I've ran into.
     
  4. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
  5. DennisD

    DennisD Registered Member

    Joined:
    Oct 3, 2009
    Posts:
    5
    Thanks Mike.
     
Thread Status:
Not open for further replies.