F-Secure: Firewall / Router configuration

Discussion in 'other anti-virus software' started by Simon6776, Feb 7, 2007.

Thread Status:
Not open for further replies.
  1. Simon6776

    Simon6776 Registered Member

    Joined:
    Apr 3, 2004
    Posts:
    282
    I was trying to use a torrent client last night, and found that the port forwarding was being blocked by FSIS 2007. After much fiddling, I found a drop down menu in Internet Shield > Firewall > Settings to allow / disallow my network card. It was set to None, but when I select the network card, the torrent client works fine. It's strange, because I hadn't noticed anything else being blocked. Anyway, my question is, when I selected to allow network card, F-Secure warned me that this could compromise my PC security. Is this just FSIS being a bit 'nannyish', or is this a real security risk? I connect through a router, which also has the firewall enabled.
     

    Attached Files:

  2. NAMOR

    NAMOR Registered Member

    Joined:
    May 19, 2004
    Posts:
    1,526
    Location:
    Arkham Asylum
    Read the "help" section about the "trusted network adapter" configuration. I believe that I left it set to "none" when I was using it. If you want to open the port that your torrent client uses in F-Secure's firewall take a look here.
     
  3. C.S.J

    C.S.J Massive Poster

    Joined:
    Oct 16, 2006
    Posts:
    5,029
    Location:
    this forum is biased!
    i too, when using f-secure left it on none.

    i was lucky to have no problems with torrents or anything with that setting on my computers.
     
  4. Simon6776

    Simon6776 Registered Member

    Joined:
    Apr 3, 2004
    Posts:
    282
    Yes, I found that yesterday and went all through it. I am using µTorrent, and it should have a green tick to show that the port is being forwarded, and incoming connections are being received, but it doesn't, and it seems the port is blocked. I never had a problem with it in FSIS 2006, so I just assumed they had tightened things up a bit with the 2007 version. I went all through the Firewall settings, as per the instructions in that link, but still it wouldn't forward the port, until I altered the Trusted Network Adapter setting. I didn't see it could do any harm, as I am not on a network, and am only using the one PC through my router. I surmised that it must have been a block between the FSIS firewall and the router. :doubt:
     
  5. trjam

    trjam Registered Member

    Joined:
    Aug 18, 2006
    Posts:
    9,057
    Location:
    North Carolina
    disable the routers security. Mine is Trend Micro and I would much prefer F Secures over theirs.
     
  6. NAMOR

    NAMOR Registered Member

    Joined:
    May 19, 2004
    Posts:
    1,526
    Location:
    Arkham Asylum
    Is the correct port being forwarded in the router?
     
  7. NAMOR

    NAMOR Registered Member

    Joined:
    May 19, 2004
    Posts:
    1,526
    Location:
    Arkham Asylum
    Here is what my rules look like for uTorrent (TCP and UDP are pretty much the same).
    http://img61.imageshack.us/img61/2410/portyo9.th.png

    After I created the rules I enabled them under the "rules" tab.
    http://img61.imageshack.us/img61/8899/port2bv4.th.png

    Also, I noticed that under application contol uTorrent was allowed to act as a server but, needed to prompt to access the internet. I manually changed this setting to allow uTorrent access to the internet.
    http://img61.imageshack.us/img61/5765/appcontrolbr9.th.png

    On last thing I did was to all change a setting under "Real-Time Scanning" > "System Control" (tab) > "Application" (button). After clicking the "Applications" button, highlight uTorrent and select "details" and change the setting to allow. I'm not sure if this last part is actually necessary, I just noticed that in the "Flyer history" log that uTorrent was being blocked.

    http://img61.imageshack.us/img61/4306/appcontrol3lw1.th.png

    http://img61.imageshack.us/img61/8866/appcontrol2dd0.th.png
     
  8. Simon6776

    Simon6776 Registered Member

    Joined:
    Apr 3, 2004
    Posts:
    282
    Not sure I want to do that. :doubt: The router firewall is set correctly to allow µTorrent - it's F-Secure that's somehow blocking it. There was no problem with KIS, or with FSIS 2006.

    Yes, it worked fine with KIS. I did exactly as you kindly detailed in your following post, except for the last step relating to Real-Time Scanning, so I'll try that as well, and also will try again with all the other settings. Many thanks.

    I should point out that µTorrent does actually work, in that it downloads and uploads - it's just the port forwarding that seems to be an issue, and I'm not sure how much this affects things.
     
  9. Simon6776

    Simon6776 Registered Member

    Joined:
    Apr 3, 2004
    Posts:
    282
    I've gone through everything again, and still can't get the port forwarding to work. My rules are exactly as yours are, Namor, but on the Firewall > Services tab, the two Utorrent rules say No under the 'In use' column. The port number is definitely correct, so I must be getting something else wrong somewhere. The only way I can get the port forwarding to work, is to set the router as Trusted Network Adapter, so it has to be something to do with the connection between the F-Secure firewall and the router, yes? :doubt: As torrents seem to be working OK, I'm inclined just to give up and accept it as it is, but I find it very annoying when silly things like this can't be solved, and it will bug me if I can't find a remedy for this.
     
  10. NAMOR

    NAMOR Registered Member

    Joined:
    May 19, 2004
    Posts:
    1,526
    Location:
    Arkham Asylum
    Well it sounds like you have opened the ports for uTorrent under the service tab but, you haven't activated any rules yet....

    Go to the "rules" tab in the firewall configuration and click the add button.
    http://img292.imageshack.us/img292/5889/enable1gf8.th.png

    step 1/5 name the rule whatever you like.
    http://img292.imageshack.us/img292/7987/enable2ld0.th.png

    step 2/5 check mark "any IP address"
    http://img292.imageshack.us/img292/6112/enable3hi6.th.png

    step 3/5 scroll through the list until you find the rules that you created in the "services" tab for uTorrent. Checkmark both rules and click the computer/globe icon until it shows the bi-directional arrow.
    http://img292.imageshack.us/img292/6357/enable4nv4.th.png

    step 4/5 select " no alert"
    http://img292.imageshack.us/img292/9467/enable5bc2.th.png

    step 5/5 the last step, just click finish.
    http://img292.imageshack.us/img292/1091/enable6oo5.th.png


    The rules I created for uTorrent are copied from the F-Secure FAQ that I posted above except I change the ports to fit uTorrent.
     
  11. Simon6776

    Simon6776 Registered Member

    Joined:
    Apr 3, 2004
    Posts:
    282
    Yep, the only thing that was different is the last screen which said something else where yours says uTorrent TCP 59049 . . . . both. Just to clarify, your port 59049 is the Port used for incoming connections in uTorrent Preferences > Connection, yes? Mine happens to be 50210, but I think that's immaterial, and Random port is unchecked. I will try it again, and see if I can get it right!
     
  12. Simon6776

    Simon6776 Registered Member

    Joined:
    Apr 3, 2004
    Posts:
    282
    You know what? It only bloody works now! :D I don't know what I did wrong before. :oops:

    Thanks!
     
  13. NAMOR

    NAMOR Registered Member

    Joined:
    May 19, 2004
    Posts:
    1,526
    Location:
    Arkham Asylum
    Glad everything is working. :D
     
  14. alant

    alant Registered Member

    Joined:
    Aug 1, 2007
    Posts:
    26
    The other night I installed Security Shield 2007 and was wondering how I can tell if it is really working. Is there a test somewhere I can use?
    thanks
     
Loading...
Thread Status:
Not open for further replies.