Ewidoguard.exe Memory Leakage

Discussion in 'other anti-trojan software' started by WilliamP, Jul 25, 2005.

Thread Status:
Not open for further replies.
  1. WilliamP

    WilliamP Registered Member

    Joined:
    Jun 1, 2003
    Posts:
    2,201
    Location:
    Fayetteville, Ga
    What causes it and what can be done about it? When I boot, Ewidoguard's mem. usage will run about 18,000 but it will continue to increase. When it gets about 55,000 I will reboot and let it start over.
     
  2. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    Very strange... Mine stays at ~20mb even after 10 hours :(
    However, after running a memory scan, it uses ~ 55mb for a while... Could that be the cause?
     
  3. The Hammer

    The Hammer Registered Member

    Joined:
    May 12, 2005
    Posts:
    5,619
    Location:
    Toronto Canada
    How long is a while? Then does it return to 20mb?
     
  4. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    It returns to 20mb as soon as the memory is needed. If you start a big application (photoshop, a game etc.) it will go back down to 20mb...
     
  5. WilliamP

    WilliamP Registered Member

    Joined:
    Jun 1, 2003
    Posts:
    2,201
    Location:
    Fayetteville, Ga
    The mem. usage doesn't increase fast. It takes a couple of days normally to get high. The next time it gets high[55,000] I will try opening something big. I have 1 Gig of Ram. if that makes a difference. I have never seen it drop unless I reboot.
     
  6. The Hammer

    The Hammer Registered Member

    Joined:
    May 12, 2005
    Posts:
    5,619
    Location:
    Toronto Canada
    Should the program (Ewido) not just release the memory when it no longer requires it?
     
  7. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    If it's caused by the guard itself, yes... If the memory usage is caused by running a memory scan in the suite, no.
     
  8. WilliamP

    WilliamP Registered Member

    Joined:
    Jun 1, 2003
    Posts:
    2,201
    Location:
    Fayetteville, Ga
    Right now my Ewidoguard mem. usage is at 49,000. I tried opening several big programs. It didn't change the mem. usage.
     
  9. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Hi William,

    As a recent purchaser of Ewido, I can say I've never seen the memory go above 19 MB. Whether use task manager, or using Process explorer and pulling up the performance graph for ewidoguard.exe. Even doing a memory scan, the memory use does not increase. It always stays below 19MB and this is after having the computer on for more then 12 hours. This is on a w2k sp4 PC.

    Regards,
    Jaws
     
  10. boast

    boast Guest

    same here. ewido would be at 48000 right off the bat when windows starts. so i just uninstalled it.
     
  11. WilliamP

    WilliamP Registered Member

    Joined:
    Jun 1, 2003
    Posts:
    2,201
    Location:
    Fayetteville, Ga
    I have installed Online Armor so I shut down Ewidogaurd.
     
Thread Status:
Not open for further replies.