ESS v4.0.424.0 & Windows Media Player Network Sharing

Discussion in 'ESET Smart Security' started by nickster_uk, Apr 21, 2009.

Thread Status:
Not open for further replies.
  1. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Hi..

    thought i'd give the latest build from v4 a whirl as there has been some positive reports about it but it seems that the firewall is still completely blocking wmplayer Network Sharing Service from operating properly. My PC and router are still visible in 'Network' but all user profiles have disappeared. There's no specific log entries and 'log all blocked connections' is checked in advanced settings.

    I have the firewall running in interactive mode.

    Does anyone have any suggestions please?

    Thanks :)
     
  2. DarrenDavisLeeSome

    DarrenDavisLeeSome Registered Member

    Joined:
    Mar 23, 2009
    Posts:
    315
    Location:
    Riverside, CA U.S.A
    Tried running the Firewall in Automatic Mode?
     
  3. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Thanks for the response. Yes, I have tried Automatic mode and the same problem occurs. It is only resolved when I completely disable the firewall module in advanced settings and reboot.

    I have however sorted the missing WMP profiles in Network. I had set the Cryptographic Services to manual...setting it back to automatic resolved that issue but when WMP is open, the user profiles do not appear on the left hand side. It's a bit annoying as I do use the feature quite a lot to share media between devices around the house. Would be easier to diagnose if I had a log entry to work with.

    Thanks again for the reply.
     
  4. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    pmsl:

    21/04/2009 19:19:49 Packet blocked by active defense (IDS) 192.168.x.x:49449 93.184.71.21:80 TCP

    Nice one....IDS is blocking ESET so I cannot update :)

    Oh well....back to v3.0.368 for me.

    Such a shame as v4 has a great gui and some superb features on paper..just would be nice if everything worked in practice though.
     
  5. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    All sorted now...3.0.368 works like a charm for me, no bugs, connection/networking/driver etc issues at all.
     
  6. eisefr

    eisefr Registered Member

    Joined:
    Nov 23, 2004
    Posts:
    153
    Location:
    Germany
    Connection problems here too.
    ~Snip~ :(

    This is never gonna work.

    Stuck with Version 3 for ever o_O
     
    Last edited by a moderator: Apr 21, 2009
  7. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    I don't mind sticking with v3 for now...it works as advertised and I feel secure using it. However, v4 does have a much improved interface and some other nice features so it feels like i'm missing out on a little bit, but i'm not prepared to substitute form over function.
     
  8. DarrenDavisLeeSome

    DarrenDavisLeeSome Registered Member

    Joined:
    Mar 23, 2009
    Posts:
    315
    Location:
    Riverside, CA U.S.A
    Hey nickster_UK

    Have you opened the ports described in the WMP Network Sharing Help in your Router and/or the ESS Firewall?

    WMPShare.JPG
     
  9. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Thanks for the suggestion Darren but it's definitely not a router issue as all works well with previous versions of ESS and when I selected to completely disable the firewall module in v4 via advanced settings, traffic was flowing as normal again. I also have specific ESS rules to allow traffic through specific ports on specific addresses on the local network which is controlled by MAC filtering and address reservation. The fact that no log entry is being created to let me know if any particular device/address is being blocked does lead me to believe that it is a bug with v4 builds.

    I'm not too fussed though...I think the IDS blocking ESET from updating is more of an issue so I'm happy to stick with v3 for now.
     
  10. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Turn off the "Block unsafe address after attack detection"

    Before every one jumps up and down,... it will not reduce security.


    - Stem
     
  11. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Thanks for the reply Stem, if I reinstall v4, I will give that a try...however, one would assume there would be a log entry if there was an attack detection?
     
  12. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi,

    I have just been making some tests on the latest build, and the firewall behavior as changed. I will need to re-test later.

    - Stem
     
  13. NefCanuck

    NefCanuck Registered Member

    Joined:
    May 2, 2008
    Posts:
    13
    Location:
    Mississauga, ONT, CANADA
    I'm running ESET Security suite v. 4.0424 on Vista Ultimate 64 bit version and I've been having an issue sharing media between my PC and my two networked audio devices a Denon 3808 CI (corded to a Speedstream 6520) & Aluratek Internet radio alarm clock connected wirelessly)

    I've tried opening the ports as suggested but this does not resolve the issue of the two devices being unable to play media files I have set to share. The Denon cannot even see the server while the Aluratek can in fact see the server and the music files but after selecting them, does not play them.

    When I review the firewall logs for the Aluratek for example (IP address: 198.168.2.12) the error message I get says:

    5/1/2009 12:44:24 AM Packet blocked by active defense (IDS) 192.168.2.12:2005 192.168.2.11:2869 TCP

    Any suggestions?

    NefCanuck
     
  14. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Hi NefCanuck...only advice I can offer for now is to uninstall v4 and try with v3.0.368 as that works flawlessly with media sharing. Although perhaps another possible solution would be to just use ESET for anti-virus protection and look elsewhere for a software firewall option.

    If you want to stick with it, try creating a custom rule for the address and ports identified in the log entry. When my home network sharing was being blocking, I wasn't even getting a log entry which made it even more frustrating.
     
Thread Status:
Not open for further replies.