ESS - Not recognized by Windows Security Center

Discussion in 'ESET Smart Security' started by Seb666, Apr 17, 2010.

Thread Status:
Not open for further replies.
  1. Seb666

    Seb666 Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    16
    Hi all,

    I have a problem since some days : Windows show me an error that I don't have any antivirus software (find attached a screen shot of the Security Window... sorry it's in French).

    As I see this problem, I uninstall the 4.0 version and install the 4.2 version.
    But the problem is still there... and I have an other problem : errors messages on start up and antivirus and antispyware are disabled (see post : https://www.wilderssecurity.com/showthread.php?t=270012).

    Perhaps the 2 problems are linked but I don't think so. Because the 4.0 version become to be not recognized and I have no error messages...

    The configuration of my XP sp3 didn't changed. I just make all updates frequently.
    Did Msoft do a stupid update which make this trouble?
    Did some one have the same problem and perhaps a solution?

    ESS : before 4.0 and now 4.2.40.10
    OS : Windows XP sp3

    Best regards from France,
    Seb.
     

    Attached Files:

  2. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    621
    Location:
    Sydney Australia
    See if this resolves the issue.
     
  3. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
  4. Seb666

    Seb666 Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    16
    Hello,

    Thanx for your answer.

    I try it... unfortunatly, all files are deleted but not restored... and now I have a lot of error messages from ESS...

    I try to uninstall and reinstall ESS now.

    Seb.
     
  5. Seb666

    Seb666 Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    16
    Hello,

    Thank you for your answer.

    I uninstall completely, delete all ESET folders, clean the registry and reboot.
    After the re installation of ESS, same problem and more and more error messages...
    System error reports : WMI problems...

    I try to restaure the delete files from wbem and try to restart the computer.
     
  6. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    621
    Location:
    Sydney Australia
    Start > Run > services.msc - check that the Windows Management Instrumentation service and the Remote Procedure Call (RPC) service are both set to automatic start up and that both are started.

    If you have have an xp sp3 installation disk you could try the following commands from the Run box or Command Prompt -
    sfc /purgecache followed by sfc /scannow
     
  7. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Sometimes Windows Security Center needs some persuading.

    Check and uncheck to virus settings several times as indicated in the screenshot, unless you have an installation issue, it may be just an annoyance that needs to be persudaed that you have virus protection.

    Enable services.msc ensure Security Center is enabled and started:
     

    Attached Files:

    Last edited: Apr 17, 2010
  8. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    The WMI tweak per the ESET KB article, imo is way off base.
    RPC would cause system instability that would have flagged in Event Viewer, so, I would rule that out as a possibility.
    System File Checker or sfc / I find that recommendation questionable since running sfc would render most Windows Updates back to day one of the last successful installation on the Posters machine.

     
  9. Seb666

    Seb666 Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    16
    Thank you for all answers.

    I had a big problem.
    I uninstall Spyware Doctor to be sure it will not make any trouble and I will not be able to restart my computer anymore (on startup, Windows logo with an infinite progress bar... not more...).
    I have to find a good solution to uninstall this software...

    I restore an old backup (done some days before) and now I have the old version of ESS (4.0.437.0)...
    No error message but not recognized too by Windows Security Center.

    The security center is running and set on Automatic and Security Center options are check.
    I try to check and uncheck... but nothing changed.

    I know it's anoying and I can say that I manage by myself the antivirus software, but it's strange...

    And I know that it was recognized well since I install ESS on this computer...

    I will try sfc but I have only a sp2 windows CD...

    Seb.
     
  10. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Fully remove Spyware Doctor using this tool

    Remove your ESS installation with this tool

    Ensure that Services as previously noted by me are fully started in Services.msc

    Do not run sfc from media that is not current to your installed operating system as this will result in you having to do a complete re-installation of the Operating System !

    Please post back your findings.

    Bon chance,
     
  11. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    621
    Location:
    Sydney Australia
    Actually sfc will just refuse to replace the files if the installation disk service pack is not the same as the service pack installed. There is no risk of it corrupting the installation.

    For xp:
    WMI service is dependent on RPC service. Security Centre and Windows Firewall/ICS are dependent on WMI service.

    Have a look in your event viewer logs for WMI errors, anything relevant then post the error messages.
     
  12. Seb666

    Seb666 Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    16
    Unfortunatly, I insall this software but it didn't find Spyware Doctor.
    I use another one, clean the registry with CCleaner and with Registry Mechanic...
    After reboot... same problem : infinite progess bar... I reinstall the backup...
    I'm tired... it's a good software but the uninstallation is ~ Snipped as per TOS ~

    I will try later to uninstall it.

    I will try it tomorrow... because for the moment, I'm fedup with uninstall, reinstall,...

    I will not do it because I don't have any sp3 CD... Only a sp1 one (I thought it was a sp2 but not)...

    Thank you :)

    I will keep you informed of my progress...

    Have a nice day or night.

    Seb.
     
    Last edited by a moderator: Apr 17, 2010
  13. Seb666

    Seb666 Registered Member

    Joined:
    Apr 15, 2010
    Posts:
    16
    I check it and all are running.
    If I restart the Security Center service, I don't have anymore the problem :)
    But if I restart the computer... same problem, no antivirus software is installed :-(
    The problem is still the same...

    (I use the 4.0.437.0 version of ESS now...).

    Best regards,
    Seb.
     
  14. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Please submit an issue ticket to ESET

    bon chance!
     
Thread Status:
Not open for further replies.