ESS: Firewall prohibits FTP connections

Discussion in 'ESET Smart Security v3 Beta Forum' started by Sovjohn, Apr 12, 2007.

Thread Status:
Not open for further replies.
  1. Sovjohn

    Sovjohn Registered Member

    Apr 12, 2007
    Lancaster, UK

    I am unsure whether this has been mentioned before, however I noticed something peculiar happening with my FTP client.

    I tried to connect to my webserver using SFTP / SSH, through port 22 and a secure connection, and everything went smoothly. I then tried to connect to the same server through standard FTP port, 21, and I was receiving a response proclaiming my request could not reach the server.

    I tried everything possible, but had forgotten about ESS and its beta stage...Finally, I switched the firewall from Automatic to Interactive mode and created a rule allowing my FTP program full communication from / to external servers in port 21.

    This didn't work.

    I have to completely disable filtering and then connect to the server, otherwise, despite rules being in place etc, it will never let me connect.

    My operating system is Windows XP Home SP2, using standard ESS beta, and FTP program mentioned is Globalscape CuteFTP 8 Professional.

    On a sidenote, I was a lurker in those forums for a long time - I'd like to extend my thanks to all ESET people for their excellent products and support!
  2. Meister

    Meister Registered Member

    Apr 8, 2007

    There was a similar topic a few days ago. I suggested that the firewall was placed in interactive mode and then you would use one of those online port scanners.

    When the scanner tries to contact port 21, you will get a message and you will accept it and a rule will be created automatically.

    It worked for me. I had the same problem as you.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.