ESS + ESS = 0

Discussion in 'ESET Smart Security' started by exwoll, Nov 21, 2008.

Thread Status:
Not open for further replies.
  1. exwoll

    exwoll Registered Member

    Joined:
    Nov 21, 2008
    Posts:
    6
    Hello
    I have problems with ESS firewall when i trying to play some multiplayer games on CIV4 with some friends, the thing is that the friends that 1 friend is using ESS to, and we cant conect to a same game because there allways appear some firewall error message :(. Since i'm the host i've tryed everything, turnin dwn the firewall, activating interactive mode(i dont know why its called that, because i't doesn't show any message when new connection appears, it just block them, and if i want somethin to work i need to create the rule manually, nd it's rlly tedious to make that to every single program, i think to get another soft just of that, because kaspersky nd bitdefender r more user friendly), allowing himashi IP (because the real ones are dinamic nd i cant change it everytime -_-, opening ports,etc... nothing of this works!!
    And all is ok when a player with another security software joins, i dont know whats the matter with ESS :S. Plssss heeeelp.
    Btw, why i cant create rules in automatic modeo_O?? -_- that sux, i have to activate "interactive" or the other one that i dont remember...
     
  2. unclejohn

    unclejohn Eset Staff

    Joined:
    Nov 20, 2008
    Posts:
    13
    Hello exwoll,
    I'm sorry for the disappointment, but maybe we can sort it out together. Let me address all of it quickly:

    -which version (addon) of CIV4 are you playing?
    -what does the error say - can I have a screenshot of it?
    -interactive mode is designed just for the reason you describe - to allow creating communication rules ad hoc ("on the run"), but you need to mind the sub-options like local or remote port number, as games tend to use whole ranges of them
    -hamachi runs fine with our ESS as well, but maybe it's generally a problem of know-how with networking - and virtual private networks (=hamachi) are not that easy, as they tunnel encrypted channels through firewall
    -we are now preparing the beta builds of next version of ESS - the new version comes with a learning mode in firewall, and other improvements are ready in this module that may be more suitable for home users

    Nevertheless, if you send me your configuration file and some screenshots, that make life unpleasant to you, we will see.
     
  3. exwoll

    exwoll Registered Member

    Joined:
    Nov 21, 2008
    Posts:
    6
    thnx for the reply
    im playin civ4:beyond the sword. the errors that appears are:1.couldn't negotiate with user firewall 2.Bad firewall configuration 3.Connection time outs (somethimes).
    the interactive mode issue have been fixed now, i dlded ESS again from the site, nd reinstalled it, all works ok now (i had 3.0.635 before, nd tought that it updated to .672 automaticly -_-).
    we tryed to play again, with all the rules in my firewall, but it didn't worked again. My friend have ESS .669, he tryed to create rules and even shuted down his firewall, but the effect was the same.....
    here is my configuration file
     
  4. unclejohn

    unclejohn Eset Staff

    Joined:
    Nov 20, 2008
    Posts:
    13
    Hi exwoll,
    I've reviewed your config-file and it shows, that you don't have any communication rule for CIV4 at all. It's sometimes trouble with creating rules for games, because the game launches in directx-full-screen and may suppress overlays of other applications - so I would suggest to create & save a rule for CIV4 beforehand. If you cannot manage this by yourself, then let me know, which files are in the CIV4 program folder and I can assist you with setup. Moreover I am firmly convinced, that disabling firewall (in the system tray - effective until reboot) should really let you play without any problem - it could actually indicate a secondary problem (port forwarding on your router maybe?).
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    You can also try installing ESS v4 beta (more info here) and switch the firewall to learning mode so that all communication is allowed and the appropriate rules are created.
     
Thread Status:
Not open for further replies.