ESS blocked L2TP Vpn.

Discussion in 'ESET Smart Security' started by neoz, Jun 15, 2011.

Thread Status:
Not open for further replies.
  1. neoz

    neoz Registered Member

    Joined:
    Jun 15, 2011
    Posts:
    5
    Hello there, good day. I'm having problem on L2TP Vpn with ESS, my problem is when i connect to the Vpn it seems unable to connect BUT once i turned off the firewall i be able to connect without any problem and the stranger thing is if i use PPTP i can connect without turned off the firewall, so what could be the problem? Why it allowed PPTP but not L2TP? Anyway i'm on Win XP Pro Sp3, please help, thanks.

    P.S
    I'm on version 4.2.64.12
     
  2. neoz

    neoz Registered Member

    Joined:
    Jun 15, 2011
    Posts:
    5
    Any idea guys?
     
  3. MattJN

    MattJN Former ESET Support Rep

    Joined:
    Feb 19, 2010
    Posts:
    149
    Hello,

    Have you changed the firewall mode for your installation from the default at all? If not, it probably created its own rule to block the L2TP connection. You should probably change the firewall mode to Interactive mode (open the GUI, press F5 for advanced setup, click on Personal firewall on the left, then in the dropdown on the right, choose Interactive mode), then reset the firewall rules to defaults and try to connect with the VPN again. This will allow ESS to prompt you to allow/deny the traffic.

    Thanks,

    Matt
     
  4. neoz

    neoz Registered Member

    Joined:
    Jun 15, 2011
    Posts:
    5
    I tried your method but still doesn't work, when i connect to the Vpn via the dialer i created in network connection it didn't popup anything, if i not mistake that prompt only works when there's a application try to connect to internet not in dialer right?

    Thanks.
     
  5. MattJN

    MattJN Former ESET Support Rep

    Joined:
    Feb 19, 2010
    Posts:
    149
    Hello,

    Please try this.

    Try to connect again and then open the firewall by opening the GUI, clicking tools on the left (may need to display advanced mode), click on log files, then choose ESET Personal Firewall log from the drop down list in the main window. See if there's anything pertinent there.

    If that doesn't help, you can enable special logging to see what's happening.

    Thanks,

    Matt
     
  6. neoz

    neoz Registered Member

    Joined:
    Jun 15, 2011
    Posts:
    5
    This is what i get in the log.

    6/17/2011 1:33:31 AM No usable rule found 0.0.0.0 xxx.xxx.xxx.xxx:500 255 C:\WINDOWS\system32\lsass.exe NT AUTHORITY\SYSTEM
     
  7. neoz

    neoz Registered Member

    Joined:
    Jun 15, 2011
    Posts:
    5
    I figure out how to make it works. Add a rule -> Select protocol -> put a number "255" and click ok, you should be able connect with L2TP protocol.

    Tested on Windows XP.
    Anyway Eset should allowed it by default just like PPTP protocol.
     

    Attached Files:

    • Rule.PNG
      Rule.PNG
      File size:
      31.5 KB
      Views:
      358
  8. dutx12

    dutx12 Registered Member

    Joined:
    Aug 22, 2011
    Posts:
    1
    Thank you very much for your help

    For the rule is not so generic I recommend you add in "Local" "Application"

    C:\WINDOWS\system32\lsass.exe

    regards
     
Thread Status:
Not open for further replies.