ESS and not getting an IP from Router

Discussion in 'ESET Smart Security' started by falke69, Mar 14, 2008.

Thread Status:
Not open for further replies.
  1. falke69

    falke69 Registered Member

    Joined:
    Mar 14, 2008
    Posts:
    45
    Hallo to all,

    I purchased ESS 3.0, installed it and it was working great. ESS updated without problems. But now after reboot my pc can not get an IP from router. After installation ESS detected my network correct and added it into the trusted zone. e.g. 192.168.178.0, 255.255.255.0.

    When I click on the icon of the network card I get information that no tcp ip driver is installed. But there is an additional driver of ESS on the network card. The network card icon shows that I have connection to a 100 MBit network. So it is not a problem with my connection. I tried setting an fix IP to network card but same result. No IP from router.

    After uninstalling ESS again I can go to internet without problems.

    On my pc I am using Windows XP SP2. No other antivirus or firewall is installed.

    Has anyone an idea what's the problem ?

    Thx for an answer.
     
  2. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    You did not say what mode the firewall is in. from the sound of things it is in policy mode. That means by default everything is blocked unless specifically allowed by a rule. I would go into the advanced firewall settings and put it in interactive mode; then use a DOS window to get a new IP lease

    ipconfig /renew


    At this point, the firewall does block all traffic but it will prompt you, giving you the option to allow/save DHCP requests...you will have to test all your apps that access the internet or modify other applciations ensuring to do an allow/save if it is something you want to happen with no further notification.

    Hope this helps......
     
  3. falke69

    falke69 Registered Member

    Joined:
    Mar 14, 2008
    Posts:
    45
    Hallo shansmi,

    thanks for your reply. I tried your suggestion. But I got the answer "Failed because of no adapter is in an allowed state".

    I put the firewall in interactive mode and now I am always asked e.g if internet explorer wants to access internet. So ESS is working correct.

    For me it seems that the new driver applied to the network card (Eset Personal Driver) is not installed properly. So no commands can go through the network card to the router.

    Again, the network card says it has an 100 MBit connection to router but cannot get an IP. It seems that all transfer is blocked. I also tried to disable firewall but same results.

    Can I try anything else ?


    Here some futher information:
    - installed vmware 6 with two connections (192.168.149.1 and192.168.138.1)
    - applied services to network card: Client for Microsoft Network, Eset Personal Firewall, VMWare Bridge protocol, Virtual machine network services, File and printer access for Microsoft network, QOS packet planer, Network monitor driver, Internetprotocol TCP/IP
     
    Last edited: Mar 15, 2008
  4. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    I would suggest a few things....This has worked for me at least 6 times while testing ESS and AVG8...and I already have the latest NIC drivers ....

    remove ESS using the following instructions:

    after uninstall delete these folders
    C OR D:\Documents and Settings\All Users\Application Data\ESET
    C OR D:\Documents and Settings\USERNAME\Application Data\ESET
    C OR D:\Program Files\ESET <---will be deleted by the required restart
    AND some registry keys
    HKEY_CURRENT_USER\Software\Eset
    HKEY_LOCAL_MACHINE\SOFTWARE\Eset
    THIS WILL MAKE EAV AND ESS COMPLETLY REMOVE

    Reboot your PC,

    Use registry cleaners to make sure all is ok in your registry (ccleaner is free and I also use Registry Mechanic). (I uncheck "unused File Extensions" and "Smart Menu Ordering" in crap cleaner on registry scans).

    Go to your Network properties and ensure the ESS network dirver is not there.

    Update your NIC drivers to ensure your have the latest versions.

    ***** Test everything to ensure all is working ********

    If all is working, install ESS and ensure you choose a custom install; this way you can go through all the menus and max out protection and scans plus set the firewall to interactive mode during the install....


    Hope this helps,

    If it does not it may be a driver interaction. Please use CPU-Z and Everest Home addition (both can be found using Google - CPU-Z is current version 1.44.1 and is still free, there is a very old version of Everest Home floating around but there is also a pay version that is currrent) to give us you motherboard type and NIC info....Also I do not remember reading what OS you are running, XP or Vista? Is your system fully patched?
     
    Last edited: Mar 15, 2008
  5. falke69

    falke69 Registered Member

    Joined:
    Mar 14, 2008
    Posts:
    45
    Hallo shansmi,

    thanks for your help.

    I have done like you suggested. Now ESS is working. Many thanks.

    I suppose there was something in registry or in folders what wasn't removed properly by uninstall routines from previous versions of NOD32 (I started with NOD32 2.5.... until 2.7.39).

    So my tip for Eset: maybe the install routine from ESS could be improved. It should check and remove old entries in registry which aren't necessary for ESS anymore.

    P.S. In my very first answer I wrote I am using Windows XP SP2 with all up to date patches.
     
  6. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    glad that worked! that is a general install/removal procedure for most popular AV / ISS packages ....it has not let me down yet....

    I saw you were rinning XP Pro SP2 fully patched after your comments...sorry for the duplicate effort as I did not go back through all the posts and luckily the procedure does not change per OS....

    :D
     
Thread Status:
Not open for further replies.