Eset Smart Security blocks all connections when starting windows

Discussion in 'ESET Smart Security' started by Lain, Dec 30, 2008.

Thread Status:
Not open for further replies.
  1. Lain

    Lain Registered Member

    Joined:
    May 19, 2008
    Posts:
    12
    Hello,
    I have a weird problem recently. Eset Personal Firewall blocks all connections to the internet by default when I start it up. Thunderbird, Firefox, IE, Windows Update, Hamachi, Skype, Pidgin etc. all can't get any kind of connection although I'm definitely connected.

    The only workaround is to disable the firewall, then re-enable it again immediately. Then it works as it should (presumably).

    How do I fix this misbehavior? It's really going on my nerves.
     
  2. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
    Hello,

    Which versions of Microsoft Windows and ESET Smart Security are you using?

    Regards,

    Aryeh Goretsky
     
  3. Lain

    Lain Registered Member

    Joined:
    May 19, 2008
    Posts:
    12
    I'm using Windows XP x86 SP3. My ESS version is 3.0.650. Before you tell me to update the software to the current version: because ESS fails to let me uninstall it and an update requires the uninstall of the currently installed version, as desribed in this thread, I sadly cannot do so. So this is not an option, unless you find a solution for me in that thread.
     
  4. Lain

    Lain Registered Member

    Joined:
    May 19, 2008
    Posts:
    12
    *bump*
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    ESS 3.0.650 is not the most current version, there's a newer one 3.0.684 which includes fixes to certain issues. However, I'd recommend installing ESS v4 beta and switching the firewall to learning mode so that all necessary rules are created automatically. You can edit these rules later, if necessary.
     
Thread Status:
Not open for further replies.