Eset hinders my local network from detecting my computer

Discussion in 'ESET Smart Security' started by slim2fattycake, Aug 17, 2010.

Thread Status:
Not open for further replies.
  1. slim2fattycake

    slim2fattycake Registered Member

    Joined:
    Aug 17, 2010
    Posts:
    6
    I have 3 wireless laptops and a wired desktop. When I have Eset firewall active on the desktop, none of my other PCs are able to see the desktop in the network folder. The 3 other wireless devices show up in the network folders. I know it is a Eset problem because my desktop shows up when I disable the firewall, the desktop shows up in the network folders for the other devices on the network. Also, None of the other 3 devices show up on the desktop's network folder. I want the desktop to show up because I want to print from the printer that is connected to the desktop. I am using Eset smart security 4 on the desktop on 64bit xp pro and the 3 laptops have vista and win7s. Please help me out. Thanks.
     
  2. picomanico

    picomanico Registered Member

    Joined:
    Aug 3, 2010
    Posts:
    19
    hi, try this: open ESET main window (advanced mode), in the left side choose setup-personal firewall. then choose the Change the protection mode of your computer in network and in the new window choose allow sharing.
     
  3. AlwaysLearning

    AlwaysLearning Registered Member

    Joined:
    Aug 1, 2010
    Posts:
    22
    I am seeing the same issue.

    Both the desktop PC and the notebook are running Windoze XP with all available updates applied; ESET ESS 4.2.58.3 with Virus Signature Database 5372.

    In the Firewall Log (Tools -> Log Files -> ESET Personal Firewall Log), I see these entries at the time I was testing this issue yesterday afternoon ...

    8/16/2010 4:14:41 PM No application listening on the port 192.168.1.6:68 255.255.255.255:67 UDP

    8/16/2010 4:14:38 PM No application listening on the port 192.168.1.6:68 255.255.255.255:67 UDP

    8/16/2010 4:14:37 PM Communication denied by rule 192.168.1.6:138 192.168.1.255:138 UDP Block incoming NETBIOS requests

    8/16/2010 4:14:37 PM Communication denied by rule 192.168.1.6:138 192.168.1.255:138 UDP Block incoming NETBIOS requests

    8/16/2010 4:14:37 PM Communication denied by rule 192.168.1.6:138 192.168.1.255:138 UDP Block incoming NETBIOS requests

    8/16/2010 4:14:37 PM Communication denied by rule 192.168.1.6:138 192.168.1.255:138 UDP Block incoming NETBIOS requests

    A screenshot of the Firewall Rules and zones gives a strong hint of why this is happening ... but how to adjust those rules ? ? ?

    Any/All Comments/Suggestions accepted and appreciated ...

    --Always Learning
     

    Attached Files:

  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    1, make sure the subnet 192.168.1.0/255.255.255.0 is in the TZ
    2, toggle detailed view of all rules
    3, enable the rules "Allow incoming NETBIOS requests in TZ" and "Allow outgoing NETBIOS requests in TZ" (seem to be enabled already). The general blocking rule for NETBIOS communication would only be applied to addresses outside TZ as it's a less specific rule.
     
  5. slim2fattycake

    slim2fattycake Registered Member

    Joined:
    Aug 17, 2010
    Posts:
    6
    It is on allow sharing.

    Both those rules are enabled.

    I am currently in learning mode.
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Please refer to these instructions, in particular, the one commencing with "If a specific communication is blocked". When you have the requested stuff ready, let me know so that I can provide you with further instructions.
     
  7. slim2fattycake

    slim2fattycake Registered Member

    Joined:
    Aug 17, 2010
    Posts:
    6
    I am running Windows XP 64-bit service pack 1
    My ESET version is ESET Smart Security 4.2.35.0
    Virus sigature database: 5374
    update module: 1031
    antivirus and antispyware scanner module: 1284
    advanced heuristics module: 1112
    archive suppport module: 1221
    cleaner module: 1048
    anti-stealth support module: 1021
    personal firewall module: 1060
    antispam module: 1014
    sysInspector module: 1216
    self-defense support module: 1016
    real-time file system protection module: 1004

    I figured out what it was. I created a similar rule to "allow incoming NETBOIS requests in the trusted zones". I changed the protocal to TCP & UDP and changed directions to both. Now the desktop shows in the other computer's network folders.
     
  8. slim2fattycake

    slim2fattycake Registered Member

    Joined:
    Aug 17, 2010
    Posts:
    6
    Okay, nevermind. That didn't work. It worked for a while and then just randomly stopped working and now is blocking network asset again.
     
  9. slim2fattycake

    slim2fattycake Registered Member

    Joined:
    Aug 17, 2010
    Posts:
    6
    bump for help. i am getting blocked NETBOIS requests even after I disable the rule.
     
  10. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Where could I find the stuff requested in my previous post?
     
  11. slim2fattycake

    slim2fattycake Registered Member

    Joined:
    Aug 17, 2010
    Posts:
    6
    What else should I include?
     
  12. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    As stated in the instructions for troubleshooting connection issues:
    If a specific communication is blocked, enable logging of all blocked communication per the instructions here and here. The firewall log will show details about the rule that blocked the communication and thus will give you a clue what rule needs to be adjusted. If you're unable to make the necessary rule adjustment yourself, provide the pcap log, firewall log as well as the program configuration (Tools -> Export/Import configuration) to a trained support personnel.
     
Thread Status:
Not open for further replies.