Eset full scan scans only half of the files?

Discussion in 'ESET Smart Security' started by satasonic, Jun 27, 2012.

Thread Status:
Not open for further replies.
  1. satasonic

    satasonic Registered Member

    Joined:
    Apr 14, 2011
    Posts:
    51
    Basically, this is a new laptop. Its about a week old now.

    Yesterday I did a full scan, and it took me about 30 minutes for 300,000 files. Now, when I do a full scan, it scans only 3 minutes, and only 100,000 files. When I view the scan logs however, they are quite strange- As there are a lot of [4]- file cant be accessed errors. This definitely wasnt there today in the morning.


    If I do a quick scan- It finishes in about the same time, so scan profile wont make any difference.

    Any idea?
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,375
    Maybe you have UAC enabled and didn't run the scan with admin rights so the scanner could not access a lot of files.
     
  3. satasonic

    satasonic Registered Member

    Joined:
    Apr 14, 2011
    Posts:
    51
    Nope, Im pretty sure that UAC was off since the moment I first scanned, so that cant be it as well :D


    Thanks for the answer, by the way!
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,375
    Then we'll need to see some examples of records from your on-demand scanner log showing files that could not be scanned.
     
  5. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,052
    Location:
    USA
    Seriously? I can understand it not being able to scan locked system files like the pagefile and such, but it is limited by UAC? By no means should an AV scanner be running under a user's credentials. There are just way to many ways to bypass that. It should either prompt for elevation when run or run as a system account or service. :doubt:
     
  6. encus

    encus Registered Member

    Joined:
    Nov 2, 2009
    Posts:
    535
    Actually I've been having almost a similar issue like yours. Everytime I do a smart scan, I pay good attention on the scan progress and one thing that I notice is ESS only scans 1 or 2 JPEG files. The fact is I have not 1, not 2 but more than 100 JPEG files.
    I've already done the right settings which is In Depth Scan profile. So what's the problem here? o_O

    Thank you.
     
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,375
    The problem is not similar as you're probably not getting a lot of blue messages in the log.

    Perhaps it's because of Smart optimization? Try running a scan with Smart optimization disabled and another one with SO enabled.
     
  8. encus

    encus Registered Member

    Joined:
    Nov 2, 2009
    Posts:
    535
    Pardon me, but as a matter of fact, I do always get a lot of those blue messages with error opening [4] at the end of each messages. I know this is normal because they're system files which are apparently still being used by another program or application when the on demand computer scan is running.


    By default, is this Smart Optimization enabled or disabled?
    How does it work that it skips some files from scanning?
    Is it risky to make it disabled?

    Thank you.
     
  9. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,375
    Enabled because there are no security risks connected with this.

    There are various mechanisms in place to ensure that malicious files will be detected.
     
  10. encus

    encus Registered Member

    Joined:
    Nov 2, 2009
    Posts:
    535
    I've checked this Smart Optimization setting; it is disabled. So I guess this is not the problem. BTW, I'm currently on v4.2.64.12.

    Thank you.
     
Thread Status:
Not open for further replies.