Eset firewall blocking my iOS devices from showing in Spotify app

Discussion in 'ESET Smart Security' started by nightfox, Mar 13, 2013.

Thread Status:
Not open for further replies.
  1. nightfox

    nightfox Registered Member

    Joined:
    Sep 26, 2008
    Posts:
    33
    Location:
    South Sweden
    Hi all,

    Have a problem with my Eset firewall and could need some help setting it up properly,

    The problem is that everytime i want to sync local files (from my PC) to my iOS devices (iPhone & iPad) i connect the them to the PC and open up Spotify on computer but the iOS devices does not show up under "devices" in Spotify.

    So i temporarely disabled the firewall and the iOS devices showed up, i also tried to change the firewall setting from "automatic" to "interactive" mode and this also helped.

    But surely, there must be a way to make this work without having to disable the firewall everytime. How should i set up the firewall so that my iOS devices always show up whenever i connect them to computer?
     
  2. dwomack

    dwomack Eset Staff Account

    Joined:
    Mar 2, 2011
    Posts:
    588
    If you set the firewall to "interactive filtering mode", before clicking "ALLOW" on the pop-up window, select the box to "Remember Action (Create Rule)" and once you get a clear connection, set your firewall filtering mode to "Automatic mode with exceptions." This will allow your firewall to remember the rule you just created so you won't have to disable it every time you sync your devices.

    For more information, check out this KB Article: Why is my application not working correctly in Automatic filtering mode?
     
  3. nightfox

    nightfox Registered Member

    Joined:
    Sep 26, 2008
    Posts:
    33
    Location:
    South Sweden
    Thank you dwomack, it worked!
     
Thread Status:
Not open for further replies.