Error when selecting file name on network

Discussion in 'Acronis True Image Product Line' started by Secure1, Feb 14, 2006.

Thread Status:
Not open for further replies.
  1. Secure1

    Secure1 Registered Member

    Joined:
    Jun 14, 2005
    Posts:
    24
    Error when selecting file name for image

    I get the following error when trying to create an image on a Samba share on my home LAN. This occured when I booted from the rescue disk TI8 build 937. I could traverse the folders on the Samba system (so I was connected to the destination server), but when I typed in a file name (for the .tib file) I always got this error:

    "The file name, location or format "\\MYPC\images\suzanne.tib" is not valid. Please type the file name or location in the correct format."

    I was unable to create the image on this system. By the way, I use this Samba system quite often to create images from another PC, so I think the system itself is OK.
     
    Last edited: Feb 14, 2006
  2. AcrBuggy

    AcrBuggy Registered Member

    Joined:
    Feb 8, 2006
    Posts:
    5
    Location:
    South Germany
    i'm surprised, that you got this failure on rescue cd version 8, because i know this "symptoms"/bugs very well in most builds from version 9 rescue cd - with the exception from latest build 9.0-2337 (german) - there, i do not see this message of this, in truth, symptoms of an denied access-procedure; on builds before 9.0-2337, on using the rescue cd, when server or an equivalent auth.-instance (e.g. ldap-database, active directories etc.) asks for an authentification when try to write an image file on a network share, i even had exact this message, although username and password were correct, and access-rights were more as enough (full share-rigts, full directory-/file-rights etc.) ...but only in cases, you must use a "extended" user name like - in e. g. microsoft netbios-syntax - "thisserver\thislocaluserfromthisserver" or "netbiosdomainorworkgroup\user; then the smb-client from older rescue cds could not correct authentify against the target auth. instance, especially when only high encryption methods of auth. are allowed ...and then e. g. exact this message, that you have, pops up.

    by using only "username" (without backslash or without e.g. kerberos-"@"-extensions and/or by using only netbios-like usernames which were not longer as 15 (16!?) characters and so on) then, in my formerly tests with version 8 rescue cds i could successful write an image file on a network share.

    what i'm wondering is, that in my older tests at least with the german rescue cd 8.0-937 i do not have this failures - even by auth. against samba-systems, or via pam against an ldap-directory or against a active directory; i could only reproduce this failures with most builds from version 9.0 before build 2337, ...and most of them were german versions.
     
  3. Secure1

    Secure1 Registered Member

    Joined:
    Jun 14, 2005
    Posts:
    24
    The odd thing is that I was not asked for user name and password.

    I believe that this worked in the past, but its been quite some time since I tried it, so I may have been using an older build when it last worked, not sure.
     
  4. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Re: Error when selecting file name for image

    Hello Secure1,

    Thank you for choosing Acronis Disk Backup Software.

    First of all, please make sure that the sharing permissions for the folder you try to save your image to are set to Full Control (right-click on the folder in Windows Explorer -> Properties -> Sharing).

    If that does not help then please do the following:

    - Boot the computer from Bootable Rescue CD created using the latest build (937) of Acronis True Image 9.0 and press F11 key when the "Starting Acronis Loader..." message appears;

    - After you get the "Linux Kernel Settings" prompt, please remove the "quiet" word, click on the OK button and wait for # prompt to appear;

    - Issue the following commands:

    asamba dhcp -n
    asamba masters

    - Write down the output after each of the commands or use a digital camera to make a shots of the output screens;

    - Insert a diskette in a floppy disk drive and issue the following commands;

    cd tmp
    mkdir mntdir
    mount /devfs/floppy/0 mntdir
    cat /proc/net/dev > mntdir/net.txt
    sysinfo > mntdir/sysinfo.txt
    umount mntdir

    - Collect the net.txt and sysinfo.txt files from the diskette.

    Please also note that sometimes the sysinfo.txt and net.txt files are not readable from under Windows. In this case please try entering the file name in capital letters (SYSINFO.TXT, NET.TXT) or follow the instructions provided in this previous post of mine.

    If you do not have a floppy drive then please take a look at this previous post of mine explaining how to save the sysinfo.txt file to USB flash drive.

    Please also provide us with the following information:

    - What operating system is installed on the computer where the shared folder is located?

    - Try to create an image saving it to the same shared folder when the latest build (937) of Acronis True Image 8.0 is running from under Windows and inform us about the result;

    - Describe your network structure in more detail (hardware and software vendors and models, connection type, etc.);

    - Download and install the free trial version of Acronis True Image 9.0, create new Bootable Rescue CD, boot your computer from this CD and see if the problem still persists. Let us know the result;

    - Describe actions taken before the problem appears step-by-step.

    Please submit a request for technical support. Attach all the collected files and information to your request along with the information about your purchase of Acronis software (order number, e-mail, where did you purchase our product, etc.) and the link to this thread. We will investigate the problem and try to provide you with the solution.

    Thank you.
    --
    Alexey Popov
     
  5. Secure1

    Secure1 Registered Member

    Joined:
    Jun 14, 2005
    Posts:
    24
    I have narrowed down the problem to file permissions on the Samba server. Changing the perms on the destination directory from 755 to 777 allowed TI8 to create an image in this shared Samba directory.

    What I don't understand is why True Image (recovery disk) won't simply prompt for credentials to allow access to a Samba directory, like the installed Windows TI8 does, and like the rescue disk does when it connects to a Windows share.

    Server with shared folder:
    OS: Ubuntu Linux v5.10 (running Samba)
     
    Last edited: Feb 17, 2006
Thread Status:
Not open for further replies.