Echo Agent on Linux: HOW TO EXCLUDE FOLDERS?

Discussion in 'Acronis True Image Product Line' started by DataScan4000, May 27, 2009.

Thread Status:
Not open for further replies.
  1. DataScan4000

    DataScan4000 Registered Member

    Joined:
    May 27, 2009
    Posts:
    3
    We are testing TI Echo Enterprise Server for hot-imaging linux servers and we require ability to exclude directories including subdirectories on a full system backup (not a data backup), re-partitioning/moving exclude data is not an option.

    I have read too many posts and not found an answer which works for linux agent.

    So, on the linux agent using management console backup wizard for a partition 'sda1' how can I exlude this directory tree?:

    /exclude/subfolder/file

    I have tried:

    Exclude masks:
    /exclude/
    /exclude
    /exclude/*
    /exclude/*/
    /exclude/*.*
    /exclude/*.*/
    exclude/
    exclude
    exclude/*
    exclude/*/
    exclude/*.*
    exclude/*.*/
    C:\exclude\
    C:\exclude
    C:\exclude\*
    C:\exclude\*\
    C:\exclude\*.*
    C:\exclude\*.*\
    \exclude\
    \exclude
    \exclude\*
    \exclude\*\
    \exclude\*.*
    \exclude\*.*\
    ^(curious as the resulting .tib always has C: as root and lack of docs).

    Nothing works, the /exclude/subfolder/file is always in the resulting .tib.

    Any ideas?
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello DataScan4000,

    Thank you for your interest in Acronis True Image Echo Enterprise Server

    If you want to exclude some folder it should be kept in slashes. Here is the example:

    C:\Documents and Settings\User\My Documents\Test\

    In this example folder Test should be excluded using exclude specified file/folders option.

    Best regards,
    --
    Dmitry Nikolaev
     
  3. DataScan4000

    DataScan4000 Registered Member

    Joined:
    May 27, 2009
    Posts:
    3
    Thank You Acronis Support/Dmitry but we are backing up a Linux computer using Management Console on Windows connecting to the Remote Linux Agent, and the paths in Linux start from '/' (root) and use '/' as a directory separator, instead of '\' like on Windows, so we have tried this:

    /exclude/

    But the resulting backup image still contains the test /exclude/ directory, it's file, and it's subfolder, I am not sure how to proceed, please can you tell me if it should work or how I can exclude a folder specifically for Linux?

    Somebody must know as you have gone to the trouble of developing linux programs and kernel drivers.
     
  4. DataScan4000

    DataScan4000 Registered Member

    Joined:
    May 27, 2009
    Posts:
    3
    FYI This is the dialog I am using to exclude the files, it does not say 'files/folders' just 'files':

    Image1.PNG
     
Thread Status:
Not open for further replies.