E00040014: Access to file is denied

Discussion in 'Acronis True Image Product Line' started by Vanguard, Aug 3, 2007.

Thread Status:
Not open for further replies.
  1. Vanguard

    Vanguard Registered Member

    Aug 27, 2003
    Acronis True Image Home v10

    Been using TI Home for a couple weeks. After figuring out how to define and use backup locations (so I could use disk quota to limit the backups from consuming all the disk space and providing for auto-delete of old backups), the backups were working okay ... for awhile. I don't like the limited functionality of the scheduler included in Acronis so I found out here how to define an event in Task Scheduler using the .tis file. That was working ... for awhile.

    In Task Scheduler, the parameters to run the event (at 3AM) were:

    Run: "C:\Program Files\Common Files\Acronis\TrueImage\TrueImageService.exe" /script:E7ECAC05-165F-4DDE-BC61-2C5084D84D25.tib.tis

    Start in: "C:\Documents and Settings\All Users\Application Data\Acronis\TrueImage\Scripts"

    This runs under my account which is in the Administrators group. When it was working (sort of), I saw files saved in the backup location with filenames like "2007....Dx.tib" where x was blank (for the full backup) or 1, or higher, for each incremental created after the full image backup.

    The task defined in TI Home is to save an image and created incremental backups with a full backup after the 7th task. The above was working for the backup location where I saved the images for drive C:. The quota set there was 40GB and when the backup files accumulated to more than that then the old backup files got deleted. Didn't work that way for the D: backups which keep accruing incremental backups past the 7 count specified (I had 15 incrementals after the full one) and their total size was at 55GB (over the 40GB quota).

    Then today the filenames changed. Instead of using a format that would let me see the full backup followed by the incrementals (I would sort the folder by date, oldest to newest, and would see the full backup followed by the incrementals based on that full backup), I now see a filename that is the same as the .tis script name. Now I'm not sure how to determine which file is for what backup. Since TI Home doesn't use cataloging, it's not like I can select a date on which a backup got performed and then have the program walk backward through the incrementals to the full backup. I have to actually select the file from which to walk backward and the filename gave me a clue as to which one to select since it wasn't always from the last backup from which I wanted to start.

    The disk size quota was not getting honored in one backup location. The filenames changed so I cannot easily determine by their filenames as to which backup file belongs to which backup set. And now when I run the scheduled task there is a file access error.

    I deleted the tasks in TI Home and created new ones and then updated the scheduled task to use that .tis file but still got the file access error. I then checked the permissions on the folder and script files and, as an administrator, I have the necessary file system permissions on those .tis files. I can run the tasks by using the TI Home application but they no longer run as scheduled tasks using Task Scheduler due to the file access error.

    I don't want umpteen different programs, each with its own scheduler, and me having to wade through them all to figure out how to organize my scheduled events so they don't interfere with each other. That's why I want to have command-line execution of them so they are all together in Task Scheduler. Was working but now I get the file access error.

    Sure would be handy if the error dialog said what file is "the file". Below is the logfile of the attempting backup when starting it from an event in Task Scheduler:

    <?xml version="1.0" encoding="UTF-8" ?>
    <log build="1" product="Acronis True Image Home" task="E7ECAC05-165F-4DDE-BC61-2C5084D84D25.tib.tis" uuid="95999FB0-0AFE-4537-963F-67908BE76B4E" version="1.0">
    <event code="2" id="1" level="2" message="The &quot;C - Images&quot; operation started" module="100" time="1186186153" />
    <event code="503" id="2" level="2" message="Analyzing partition 0-0..." module="1" time="1186186155" />
    <event code="503" id="3" level="2" message="Analyzing partition C:..." module="1" time="1186186155" />
    <event code="503" id="4" level="2" message="Analyzing partition E:..." module="1" time="1186186155" />
    <event code="503" id="5" level="2" message="Analyzing partition 0-0..." module="1" time="1186186155" />
    <event code="503" id="6" level="2" message="Analyzing partition D:..." module="1" time="1186186156" />
    <event code="503" id="7" level="2" message="Analyzing partition F:..." module="1" time="1186186156" />
    <event code="11" id="8" level="3" message="Priority changed to High priority" module="100" time="1186186156" />
    <event code="503" id="9" level="2" message="Analyzing partition C:..." module="1" time="1186186156" />
    <event code="4" id="10" level="2" message="Cannot open archive for appending changes." module="64" time="1186186156">
    <field name="path" type="TString" />
    <event code="1008" id="11" level="2" message="&lt;bold>Create Differential Backup Archive&lt;/bold>&lt;endl/>&lt;tabpoint value=30>&lt;indent value=4>From: &lt;indent value=10>&lt;textcolor value=&quot;navyblue&quot;>WindowsXP (C:)&lt;/textcolor>&lt;/indent>&lt;indent value=4>&lt;endl/>To: &lt;indent value=10>&lt;textcolor value=&quot;navyblue&quot;>F:\Backups\&lt;/textcolor>&lt;/indent>&lt;indent value=4>&lt;endl/>Compression: &lt;indent value=10>&lt;textcolor value=&quot;navyblue&quot;>Maximum&lt;/textcolor>&lt;/indent>&lt;indent value=4>&lt;endl/>Description: &lt;indent value=10>&lt;endl/>&lt;textcolor value=&quot;navyblue&quot;>&quot;C: - Full &amp; differential images&quot;&lt;/textcolor>&lt;/indent>&lt;indent value=4>&lt;endl/>&lt;/indent>" module="1" time="1186186156" />
    <event code="504" id="12" level="2" message="Pending operation 128 started: &quot;Saving partition structure&quot;" module="1" time="1186186156" />
    <event code="504" id="13" level="2" message="Pending operation 131 started: &quot;Creating partition image&quot;" module="1" time="1186186156" />
    <event code="506" id="14" level="2" message="Locking partition C:..." module="1" time="1186186156" />
    <event code="20" id="15" level="2" message="Access to the file is denied." module="4" time="1186186164">
    <field name="function" type="TIdentifier">
    <field name="filename" type="TString">
    <event code="65520" id="16" level="2" message="Access is denied." module="0" time="1186186164">
    <field name="code" type="TULong64">
    <event code="20" id="17" level="4" message="Access to the file is denied.

    Please press &lt;bold>Retry&lt;/bold> to try again or press &lt;bold>Cancel&lt;/bold> to cancel the operation and stop.: Retry/Cancel" module="4" time="1186186165" />
    <event code="20" id="18" level="2" message="Access to the file is denied.

    Please press &lt;bold>Retry&lt;/bold> to try again or press &lt;bold>Cancel&lt;/bold> to cancel the operation and stop.: Retry/Cancel: User replied: Retry" module="4" time="1186186177" />
    <event code="1" id="19" level="3" message="Terminated by user" module="100" time="1186186305" />
    Last edited: Aug 3, 2007
  2. Vanguard

    Vanguard Registered Member

    Aug 27, 2003
    Well, when the event failed to run using Task Scheduler, I started it using the TI Home application and it started. However, on trying this again (so I had a backup), I select the task (set to run manually) and select Run which results in the following error popup:

    E00640068: Failed to create the scheduled task
    Failed to create the scheduled task. Error #1772 - "The RPC server is unavailable (0xFFF0).
    code = 800706BA
    Tag = 0xBD28FDBD64EDB8A6

    I went into the NT Services applet (service.msc) and saw the "Acronis Scheduler2 Service" was set to Disabled (so it never started after a reboot). I set it to Automatic (to load when Windows starts) and started it. I think that I may have disabled this service thinking it was the fluff scheduler included in TI Home that I did not want to use (because I wanted to use Task Scheduler instead). Apparently TI Home still requires this service even when no tasks are scheduled.

    With the "Acronis Scheduler2 Service" running, I went back to Task Scheduler and manually started the event that runs the .tis script to do the backup of the C: drive. Since that task runs at high priority, and since anything at or above Normal priority for TI Home tasks ends up locking my host from use of that host, I won't be able to report what happened until the attempted backup started using the Task Scheduler event worked or if it failed until after that backup completes. So I'll be back.
  3. thomasjk

    thomasjk Registered Member

    Jul 22, 2005
    Charlotte NC
    Read this thread for an explanation of the error Error 1722, the RPC Server is unavailable. You've already found the answer to the 1722 error.
    This may also be of interest:
    Why Run The True Image Services
    - schedul2.exe, schedhlp.exe and TrueImageMonitor.exe
    - Timountermonitor.exe
  4. Vanguard

    Vanguard Registered Member

    Aug 27, 2003
    Yep, enabling the Acronis Shedule2 Service (to Automatic and starting it) fixed the problem.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.