Dual Booting Windows 10 and Mint KDE w/UEFI

Discussion in 'all things UNIX' started by n8chavez, Mar 31, 2017.

  1. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    "Access to the motherboard alternate boot menu". I assume that means you are using CSM, so you can see Legacy and UEFI boot media. When you are booting your Mint boot media, do you have two options in the BIOS Boot Menu? Which are you choosing?
     
  2. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    I disabled Secure Boot in my BIOS and enabled CSM. I then booted my Mint UFD in Legacy mode. On the Prepare partitions screen the EFI partition was not Type efi. It was Type fat16. Is this what you see? fat16 instead of efi. On clicking Change it didn't say "EFI System Partition". It said "do not use this partition". There was no option for "EFI System Partition".

    Interesting.

    I remained with Secure Boot disabled and booted my Mint UFD in UEFI mode. The EFI partition was Type efi. When I clicked Change on the EFI partition, "EFI System Partition" was the first default choice. Mint booted.

    I guess we need to know if you have been booting the Mint media in Legacy mode.

    When you boot the media in Legacy mode the first screen is a Mint icon and "Automatic boot in 9 seconds" countdown.
    When you boot the media in UEFI mode the first screen is 4 lines of text at the top left with a surrounding large white rectangular border on the monitor. Above the rectangle is GNU GRUB version 2.02~beta2-36ubuntu3

    When you said
    "I even gave the Mint UEFI partition a size that would maje it stand out so that I'm sure to put the loader there. Nothing seems to work."
    I should have been more suspicious as that suggests it was not labelled Type efi.
     
  3. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    I am definitely using legacy mode. How do I boot mint in UEFI to install it?
     
  4. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    Maybe like this? Off to test.
     
  5. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Plug in the UFD/DVD. Get into the BIOS. You will see 2 entries for the device. One commences with UEFI.

    Nate, you should now be on the home run.
     
  6. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Amended instructions.

    This is loosely based on...

    http://www.terabyteunlimited.com/kb/article.php?id=281

    Backup Win10 before commencing (standard instruction)


    Boot IFL, Partition Work
    Delete the EFI System partition but don't select "Clear Boot Sector" (We are going to Undelete it later) If you don't do this Grub installs to the Win10 ESP instead of the Mint ESP
    In Free space click Create, Name ESP, File System EFI System, Size 100 MiB
    Select ESP, Properties, make sure Type is EFI System
    In Free space click Create, Name Mint, File System Linux Native, Size 20000 MiB (or whatever you like)
    Select Mint, Properties, change Type to Linux Data
    In Free space click Create, Name Swap, File System Linux Swap/Solaris, Size 1000 MiB (or whatever you like)
    Select Swap, Properties, change Type to Linux Swap

    Boot a Mint UFD/DVD in UEFI mode
    In the Start Menu, Install
    In step 9 of the above web page, choose Manual
    Select the efi partition (it is labelled efi), Change, Use as EFI System partition
    Select the Mint partition, Change, Use as Ext4, Format, Mount point /
    Select the Swap partition, Change, Use as Swap Area
    Boot Loader, choose the efi partition. For example /dev/sda5 (DON'T CHOOSE /dev/sda)

    After the install let Mint boot

    Boot IFL, Partition Work
    select the Free Space where the EFI System partition used to be, click Undelete
    select the undeleted partition, Properties, change the Type to EFI System, change the Name from the arrow to ESP
    Boot Win10 from the BIOS Boot Menu

    In EasyUEFI you might see 2 Ubuntu entries referencing the same Mint ESP. Delete one. Edit the other one and change the name to Mint
    Make sure Windows Boot Manager is the first entry in the Boot order.

    Try a One-Time boot of Mint

    reboot to Win10
     
  7. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    It works now. After booting Mint via UEFI the loader was correctly written. After that everything works fine. Thanks Brian!!
     
  8. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Great news. Glad I could help. We are both wiser.
     
  9. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Nate, I have my BIOS firmware set to Secure Boot, CSM disabled. On the rare occasion I want to boot Legacy media I disable Secure Boot (and use the "Other OS" setting) and Enable CSM.

    Because of my settings I don't see the double Boot Menu items you are seeing. I just see UEFI items.
     
  10. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    9,020
  11. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Hi Mrk,

    That's a really nice tutorial but we didn't want grub in /dev/sda. Nate was already dual booting Win10 and Image for Linux, using EasyUEFI as the Boot Manager. Adding Mint made it a a triple boot. TBWinRE is being considered for a quadruple boot. Continuing to use EasyUEFI makes this, well, "easy".
     
  12. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    I'm switching out Mint KDE for Kubunt, because Mint is ditching the KDE. Following the instructions here, I deleted and recreated the "Mint" partition, the swap partition, and the UEFI partition which holds the loader. The partitions were recreated with the appropriate type. I am having trouble, however, getting the Kubuntu entry to show up in my bios boot menu. (It should be listed as Ubuntu.) I do not believe it's possible to select UEFI system partition type within a Ubuntu installer. That is where I think my issue is. I would appreciate any advice on switching to Kubuntu from Mint KDE using UEFI.
     
  13. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Nate,

    Does EasyUEFI see "Ubuntu"?

    I feel the same about the future of Mint KDE. I installed Kubuntu and Mint Cinnamon. Both are fine but I prefer Cinnamon.
     
  14. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    Before I started the switch from Mint to Kubuntu EasyUEFI (FWI, it's no longer called that) saw the entry. Afterwards it does not. I'm at a loss. I've tried deleting the native (mount point /), swap, and efi partition, recreating them and booting the loader to the efi partition. After I did that neither Kubuntu or Windows would boot.

    I've tried deleting the native (mount point /), swap but not the efi partition, recreating them and booting the loader to the efi partition. After I did that neither Kubuntu or Windows would boot.

    Also, EasyUEFI resets itself every time I reboot; the edited entries are reverted.

    Any ideas?
     
  15. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Nate,

    Sounds nasty. If you delete the three Linux partitions, does Win10 boot? How many HDs do you have in that computer?
     
  16. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    If I delete all three partitions, EFI, Native, and SWAP, Windows 10 will not boot. If I simply delete the EFI partition Windows 10 will not boot. Going by what EasyUEFI shows there is a Windows entry within the ubuntu entry bootfile, seen below. I'm not sure why that is, or if it is the cause of the booting issue.

    sshot-3.png


    My disks are shows below. The Linux native partition is cyan (blue) and the EFI partition is white.

    sshot-1.png
     
  17. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Nate,

    Can you restore the Win10 ESP from an image taken prior to the Linux install? Win10 should then boot.
     
  18. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    I don't have an EFI partition without Linux on any older images.
     
  19. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
  20. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    I don't think this is going to work. There's no way I can specify that ESP is UEFI within Kubumtu installer. (Mint is now th same way also. It's no longer listed as a partition type for manual partitioning installs. Can you think of a better way? Following your instructions earlier in the thread, that is a necessary step. I can create ESP in Image for Linux, but I cannot tell Linux to use it regardless of I select the bootloader to be placed there.

    It seems like my best bet at this point would be to install Kubuntu, placing the bootloader or my windows drive and let it get overwritten with Grub. Then edit GRUB for the default OS and timeout.

    I can't think of any other way.
     
  21. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    First things first. Boot an IFL disk. Restore the ESP with IFL. Then use PartWork to do a BCDEdit. (Select the ESP for this) Does Win10 boot?
     
  22. n8chavez

    n8chavez Registered Member

    Joined:
    Jul 19, 2003
    Posts:
    2,464
    Location:
    Location Unknown
    I managed to find an image that had everything, Mint, Windows 10, and IFL. It wasn't too old. Now at least my system is functional. I have no idea why I'm having soooo much difficulty with this. I printed out the directions earlier in the thread so as to be sure not to make a mistake, but every time I try to swap out Mint for anything else the result is that my system becomes entirely unbootable. The system I have now does not use the UEFI boot menu to launch Mint; I believe it uses Grub installed to the Windows 10 loader. So essentially, I need to know how to swap out MintKDE for Mint Cinnamon without breaking the dual-booting functionality.
     
  23. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,235
    Location:
    NSW, Australia
    Nate,

    Unfortunately you didn't follow the instructions in #31. You only have one ESP instead of two. The idea was to have a dedicated ESP for each OS but your single ESP is sharing booting files from both OS.
     
Loading...