Dual Boot Xp and Win2000

Discussion in 'Acronis Disk Director Suite' started by Tony Yarwood, Mar 10, 2008.

Thread Status:
Not open for further replies.
  1. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi guys

    Sorry to bother you all with this. I've been using Acronis for a couple of years now and I've been dual booting Win98se and Win2000 successfully.The other day however I bought a IBM T40 laptop that was preloaded with XP, I wanted to have Win2000 Pro as the other bootable OS. After installing Acronis on XP and making some separate partitions I installed 2000 on to a separate partition and hid them from each other.

    I then enabled OS selector from within XP and that's the last time I've managed to boot into XP. Win 2000 has completely hijacked the system. Whether I set XP to be the default or not I still get 2000.

    I 've tried deleting 2000 but that doesn't work.

    What am I doing wrong?

    Best regards

    Tony
     
    Last edited: Mar 10, 2008
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    What build of OSS are you using?

    Did you use "Force Hiding" on the XP partition?

    Was the XP partition still the Active partition when you installed Windows 2000?

    Can you post a screenshot of what Windows 2000 shows in Disk Management and what DD (in Manual Mode) shows?

    By "deleting" Windows 2000 do you mean you deleted the OS menu entry in OSS?
     
  3. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi Mudcrab

    Many thanks for your reply

    >What build of OSS are you using?

    Ver 10 Built 2,007

    >Did you use "Force Hiding" on the XP partition

    Yes

    >Was the XP partition still the Active partition when you installed Windows 2000?

    Yes too that as well.:oops:

    >Can you post a screenshot of what Windows 2000 shows in Disk Management

    This one is kinda wierd, it's showing I've got way too much space on my disk.

    Disk_Management.jpg


    >and what DD (in Manual Mode) shows?

    DD_Manual_Mode.jpg

    >By "deleting" Windows 2000 do you mean you deleted the OS menu entry in OSS?

    Not only that, actually formatting the drive it was on. I've since re-installed it.

    Once again many thanks for your time and trouble.

    Best regards

    Tony
     
  4. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    It it working since the reinstallation?

    Don't worry about the incorrect display in Disk management. It's because of the "mixed" Primary and Logical partitions. Just don't use Disk Management to make any partition changes. Use DD.

    I would also recommend updating to the latest build of DD/OSS 10 (2,160).
     
  5. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    >It it working since the reinstallation?

    'Fraid not..when I try to boot xp the first screen is so fast it's difficult to read it all, but it definitely says something about invalid boot.ini. The next screen says 'Win 2000 failed because the the following file is missing or corrupt \system32\ntoskrnl.exe'

    >Don't worry about the incorrect display in Disk management. It's because of >the "mixed" Primary and Logical partitions. Just don't use Disk Management >to make any partition changes. Use DD.

    That's about the best news so far :)

    >I would also recommend updating to the latest build of DD/OSS 10 (2,160).

    Did that after a bit of a struggle, first of all when I downloaded it and installed it came up with the same build! Anway I ended up re-installing 2000 again, and then then new build went in fine. However now that I've enabled OSS it doesn't see the xp installation, I tried the OS Detection wizard but either I'm doing something wrong or it just don't want to see xp as being bootable.

    Thanks again for your time and patience with this.

    Best regards

    Tony
     
  6. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Can you attach the BOOTWIZ.OSS file to a post? It's in the hidden BOOTWIZ folder on the partition in which OSS was installed. Make a copy of the file and rename it to BOOTWIZ.TXT so you can attach it.

    I may be able to fix it for you so that XP will boot.
     
  7. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi Mudcrab

    >Can you attach the BOOTWIZ.OSS file to a post? It's in the hidden BOOTWIZ folder on the partition in which OSS was >installed. Make a copy of the file and rename it to BOOTWIZ.TXT so you can attach it

    Here it is;

    View attachment bootwiz.txt

    >I may be able to fix it for you so that XP will boot.

    Many thanks again for your time and trouble.

    Best regards

    Tony
     
  8. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    The BOOTWIZ.OSS file shows the XP partition as the Active (booting) partition. This doesn't agree with the Windows 2000 Disk Management screenshot which has the Windows 2000 (G: drive) marked as the "(Boot)" partition. Nor does it agree with the DD screenshot showing the G: partition as the Active partition.

    Can you please provide the following information?

    Attach the boot.ini file from the XP partition.

    Attach the boot.ini file from the Windows 2000 partition.

    As of the BOOTWIZ.OSS file you attached in your last post, does the Windows 2000 OS show up and boot okay from the OSS menu?

    Do you have an XP CD that can be used to access the Recovery Console?
     
  9. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    >The BOOTWIZ.OSS file shows the XP partition as the Active (booting) partition. This doesn't agree with the Windows 2000 >Disk Management screenshot which has the Windows 2000 (G: drive) marked as the "(Boot)" partition. Nor does it agree with >the DD screenshot showing the G: partition as the Active partition.

    >Can you please provide the following information?

    >Attach the boot.ini file from the XP partition.

    I've attached boot.txt, the same file is located three times in xp! once in root, again in \Bootwiz\d1b4ba4 and again in \Bootwiz\uninstal\d1b4ba4

    View attachment boot.txt

    >Attach the boot.ini file from the Windows 2000 partition.

    Now this is strange; there is no boot ini in the Win 2000 partition!

    >As of the BOOTWIZ.OSS file you attached in your last post, does the Windows 2000 OS show up and boot okay from the >OSS menu?

    Yes it does.

    >Do you have an XP CD that can be used to access the Recovery Console?

    Yes

    Best regards

    Tony
     
  10. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    It appears that the XP partition wasn't hidden well enough when Windows 2000 was installed. The Windows 2000 booting files took over the XP files.

    Since everything else is probably intact, I would try the "Shortcut" fix first and see if it works.

    For reference, please see this thread: Booting Into Safe Mode and especially note Post #8 as it details the types of changes needed.

    Basically, you need to do the following:

    1. Unhide the XP partition for the Windows 2000 entry and uncheck the Force hiding option, if selected. Windows 2000 is currently seeing the partition so these options are not needed.
    2. Create a Shortcut of your Windows 2000 OSS menu entry (instructions in thread linked above).
    3. Rename the Shortcut to Windows XP.
    4. Edit the boot.ini file associated with the Windows XP Shortcut entry so that the partition(#) entries are partition(1), the directory is WINDOWS and the OS name is Microsoft Windows XP (or whatever name you want to use). Make these changes by editing the boot.ini file in OSS in the Shortcut entry's Properties.
    A sample of the file is below with the changes in RED:
    Code:
    [boot loader]
    ;timeout=30
    default=multi(0)disk(0)rdisk(0)[B][COLOR="red"]partition(1)\WINDOWS[/COLOR][/B]
    [operating systems]
    multi(0)disk(0)rdisk(0)[B][COLOR="red"]partition(1)\WINDOWS[/COLOR][/B]="[B][COLOR="red"]Microsoft Windows XP[/COLOR][/B]" [B][COLOR="red"]/noexecute=optin [/COLOR][/B]/fastdetect
    Once these changes are made, if it doesn't work, please post the BOOTWIZ.OSS file again.
     
  11. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi MC

    Made the changes and still no joy.
    The first screen is still coming up with something about invalid boot.ini. The next screen is still saying 'Win 2000 failed because the the following file is missing or corrupt \system32\ntoskrnl.exe'

    >Basically, you need to do the following:
    >Unhide the XP partition for the Windows 2000 entry and uncheck the Force hiding option, if selected. Windows 2000 is >currently seeing the partition so these options are not needed.

    Not quite sure what you mean here; do you mean like this, vice-versa, or both unhidden? I've unchecked the Forced hiding on both of them, is that right?

    Like_this.jpg

    Here's the bootwiz.

    View attachment bootwiz.txt

    Many thanks

    Tony
     
  12. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    It may not work to try and use the Shortcut method to boot XP from Windows 2000, but there are still a few things to check.

    I'm attaching a slightly modifed BOOTWIZ.OSS file that does not have the Windows 2000 OS as a "Hidden" OS and isn't using Force Hiding. No partitions are hidden, so that option won't do anything.

    Now that the XP Shortcut entry has been created, check the \BOOTWIZ folder for the existance the Shortcut's data folder. It should be afa15fc4 if it's there. If found, please attached the boot.ini file in that folder.

    If not found, please post a screenshot similar to the second one in Post #10.

    I just want to verify the boot.ini file settings are correct for the XP entry.
     

    Attached Files:

  13. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    >I'm attaching a slightly modifed BOOTWIZ.OSS file that does not have the Windows 2000 OS as a "Hidden" OS and isn't using >Force Hiding. No partitions are hidden, so that option won't do anything.

    >Now that the XP Shortcut entry has been created, check the \BOOTWIZ folder for the existance the Shortcut's data folder. >It should be afa15fc4 if it's there. If found, please attached the boot.ini file in that folder.

    It has created that directory, and here's the .ini View attachment boot.txt
    I did notice it's got a funky bit in it, don't know why, I didn't paste or anything like that.

    >If not found, please post a screenshot similar to the second one in Post #10.

    >I just want to verify the boot.ini file settings are correct for the XP entry.

    Best regards

    Tony
     
    Last edited: Mar 12, 2008
  14. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    That can happen sometimes even if you're careful and it may have just been OSS.

    Try the attached file in place of the boot.ini file in the afa15fc4 sub-folder and see if it works (rename it to boot.ini, of course). I've fixed it and verifed the line-breaks in a hex editor to make sure they're correct.
     

    Attached Files:

  15. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    >Try the attached file in place of the boot.ini file in the afa15fc4 sub-folder and see if it works (rename it to boot.ini, of >course). I've fixed it and verifed the line-breaks in a hex editor to make sure they're correct.

    What happening now is that I'm getting 'Windows 2000 could not start because the following file is missing or corrupt \system32\systemd.

    I think I've dropped a clanger though, for some stupid reason I thought it might be a good idea to copy boot.ini to all the directories that had a boot.ini

    Not a good idea! Now not even win2000 will fire up, suppose I'll have to re-install again.

    Best regards

    Tony
     
  16. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi MC

    Right back up and running, one off these days I'll learn to leave things alone!

    Anyway I've not reinstalled DD yet on the win2000 partition, should I?

    On booting it's now showing an icon for win2000, xp, and a shortcut to xp. Both the xp icons however just lead to win2000 complaining that a file is missing or corrupt.

    Best regards

    Tony
     
  17. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Tony,

    What really needs to be done is to get XP booting properly and then install Windows 2000 into its own partition instead of how it's being installed to boot from the XP partition. These creates all kinds of problems (like this one) when you try to separate them.

    When you installed Windows 2000 the first time, you had the "Force" option selected, but no partitions were actually checked as Hidden. This meant that Windows 2000 saw the XP partition and took it over.

    To start, I would do the following:
    1. Make sure the boot.ini file in the XP partition is correct (as in my previous post).
    2. Uninstall OSS (select Windows 2000 as the default OS if you have to).
    3. Boot to the DD CD and set the XP partition as Active.
    4. Boot to the XP CD and enter the Recovery Console.
    5. Run the fixmbr and fixboot commands.
    6. Exit the Recovery Console and reboot the computer to the hard drive.
    7. See if XP will boot and run.

    Once you get XP booting, Windows 2000 should be able to be installed in such a way that it will be contained on its own partition and leave XP alone.

    If you need to run the bootcfg /rebuild command from the XP Recovery Console (to rebuild the boot.ini file), I would boot to DD and hide the Windows 2000 Partition before you do so.

    Post back with how you want to proceed.
     
  18. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi MC

    Well I'm really stumped now, I tried everything you suggested in your last post and I still can't get xp to boot.

    Best regards

    Tony
     
  19. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Tony,

    Are you getting any error message(s) when you try and boot?

    Have you verified the boot.ini file contents are correct? (The OSS uninstallation may have changed it.)

    Are the XP booting files in the XP partition's root directory (ntldr, ntdetect.com). If Windows 2000 uses these same files, have you tried replacing them with the XP versions?
     
  20. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi MC,

    Sorry its taken so long to get back; I was booked into hospital for a quick op.

    >Are you getting any error message(s) when you try and boot?

    The same old one about 'Windows 2000 could not start because the following file is missing or corrupt \system32\systemd.

    >Have you verified the boot.ini file contents are correct? (The OSS uninstallation may have changed it.)

    No..the boot ini is unchanged, I made a backup of the one you made and just keep copying from that one.

    >Are the XP booting files in the XP partition's root directory (ntldr, ntdetect.com). If Windows 2000 uses these same files, >have you tried replacing them with the XP versions?

    ntldr, ntdetect.com and boot.ini are all in c:\ (the xp partition). They are not present at all in the w2k partition.

    Best regards

    Tony
    __________________
     
    Last edited: Mar 15, 2008
  21. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Do you have another XP installation (on another computer) that you can copy the ntldr and ntdetect.com files from and put them on the XP partition (replacing the existing files)? This would make sure the files on the partition are the XP versions.
     
  22. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    >Do you have another XP installation (on another computer) that you can copy the ntldr and ntdetect.com files from and put >them on the XP partition (replacing the existing files)? This would make sure the files on the partition are the XP versions.

    Yes I do. Once I've done that and replaced the boot.ini I'll give it a whirl, unless you think I should do something else first. On second thoughts I'll wait for your response.

    Best regards

    Tony

    p.s. Now that I've had a look at them, they are different.
     
    Last edited: Mar 15, 2008
  23. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    Since I don't have Windows 2000, I'm just guessing that those files may still be trying to boot Windows 2000. They may not be the XP files.

    I would do the copy and see what happens.
     
  24. Tony Yarwood

    Tony Yarwood Registered Member

    Joined:
    Mar 10, 2008
    Posts:
    17
    Hi MC

    This is what I've done so far;

    I copied the ntldr and ntdetect.com from a different computer and replaced them in the xp partition, to be sure I also replaced bootwiz.oss and the boot.ini with the ones you sent me. I then booted with the DD disc and hid the W2k partition.

    After firing up I got the message 'NTLDR is missing' so then I tried the recovery console from a xp disc and ran fixmbr and fixboot.

    On re-starting I'm still getting 'NTLDR is missing'

    Best regards

    Tony
     
Thread Status:
Not open for further replies.